Open new windows in tabs

  • Hello everyone,

    since the latest snapshot 1.8.770.25 I notice a different behaviour in my webmail client. Previously, when I composed a new mail, it opened the editor in a new maximized tab. Now, a real new window is opened.

    I looked into the source, and it is done with Javascript:, "_blank","width=640,height=480,scrollbars=yes,resizable=yes,status=yes");

    However, I don't like web applications to open new windows, I prefer tabs. Is there an option to restore this old behaviour and open new windows in tabs again?

    Btw, "vivaldi://settings/content -> Pop-ups" is of no use.


  • Does Settings --> Appearance --> tick the box for "Show Popups in Tabs" solve the issue for you?

  • yes, it's a long-awaited-by-many new feature in the latest snapshot 🙂
    do as zaibon said, it returns to old behaviour

  • Now this is really odd. Looks like a translation issue 🙂

    I could not see that option in my language, or rather the translation was wrong for it.

    The re-translation of the relevant setting in my language back into English is something like "Show preview thumbnails in tabs", which is hardly the same as "Show Popups in Tabs". So I switched the GUI language to English, and there it was.

    That being said, thank you both very much for your help.

    Btw, the language I'm talking of is German.

  • @Turandot Just had a look at it and have to admit that you're right. The translation is indeed misleading. But the issue is already addressed in the german translation forum

    @Alexs said in Vivaldi Browser Übersetzungen - Fehler Korrekturen, Vorschläge:


    Gemeint ist damit, dass Pop-Ups entweder als eigenständiges Fenster oder als Tab geöffnet werden soll.

  • @Turandot Hehe speaking of the devil... I just installed the latest snapshot that was released a few minutes ago and this translation issue is fixed already ^^

  • Good to know, thanks again. Oh wait, a new snapshot? Have to get it...! panting

  • I was missing this feature so much!

    Just want to say thank you to VIVALDI team. 🙂


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.