"ewige" Ladezeit nach Öffnen von Vivaldi und Einstellungen



  • Hallo,
    Vivaldi benötigt seit geraumer Zeit "ewig" (circa fünf Minuten und mehr) zum Laden. In der Regel habe ich genug Zeit einen anderen Browser zu öffnen darin schon mal das Nötigste abzusurfen und danach dann mit Vivaldi weiterarbeiten. Gleiches Problem bei Dialogfenstern wie Downloads, Downloads speichern, Einstellungen oder Lesezeichen exportieren.

    Aktuell nutze ich ein 64-bit-System, es ist jedoch egal welcher Vivaldi (32 oder 64-bit). Diverse Neuinstallationen ergaben nach einiger Zeit immer wieder dasselbe Ergebnis. Zusätzlich ist es egal ob ich Erweiterungen installiert habe oder nicht. Nach einiger Nutzung wird es immer auffälliger.

    Was könnte der Grund hierfür sein?

    Danke schonmal und Grüße



  • @lord.flame Nachtrag:

    ähnliches Problem nach dem Schließen, Vivaldi hängt mindestens eine halbe Stunde im Speicher rum und blockiert circa 30 % Systemleistung:

    0_1489754298942_vev.png



  • Das ist nicht normal. Du solltest Vivaldi einmal im Neuzustand ausprobieren, um festzustellen woran es liegt. Hierzu eine Sicherungskopie des Ordners Vivaldi/Default herstellen, und danach das Original löschen. Vivaldi sollte dabei geschlossen sein und es sollte kein Vivaldi Prozess mehr laufen. Wenn das geklappt hat Vivaldi hochfahren, wenn dass das Problem löst kannst du versuchen einzelne Dateien/Ordner von der Sicherungskopie wieder in den Default Ordner zu kopieren. Aber niemals während Vivaldi läuft -- das könnte zu gröberen Problemen führen.

    Wenn dann das Problem wieder auftritt, weißt du zumindest welche Dateien es verursachen und kannst diese gezielt von Zeit zu Zeit löschen.



  • Was eventuell auch noch eine Möglichkeit ist um die "Zombie-Prozesse" nach dem Beenden von Vivaldi zu schließen, ist folgender Weg:

    • vivaldi://chrome/settings/search#hardw
    • den Haken bei *"Continue running background apps when Vivaldi is closed" rausnehmen
    • Vivaldi neustarten


  • Danke euch für die Tipps. Seit V1.8 und dem abstellen der Hintergrundprozesse läuft es wieder besser.

    Grüße



  • @zaibon said:
    ......

    • vivaldi://chrome/settings/search#hardw
    • den Haken bei *"Continue running background apps when Vivaldi is closed" rausnehmen

    ........

    In Version 1.8.770.50 (Stable, 64-bit) erreiche ich die Einstellung nicht (mehr?).

    Ist das eine Folge des Updates? Wenn ja, wie komme ich dann an die Einstellung?



  • @xcountry Mmh komisch bei mir klappt das noch ohne Probleme.
    was passiert denn bei dir wenn du das eingibst? bzw was steht dann in der url-leiste



  • @zaibon

    Danke! Bei mir auch :blush: , jedenfalls im Normalmodus.

    Ich hatte (wie fast immer) den Incognitomodus an. Da geht's dann nicht ...



  • Ich häng mich mal mit ran:

    mein Vivaldi braucht nach dem Programm start ca. 30 Sekunden, bis er benutzbar ist. Während dieser Zeit lädt er irgendwas von der Platte (HDD-LED ist durchgängig am leuchten und die Platte "rödelt").

    Geöffnet ist beim Start lediglich ein Tab mit Google.de als Startseite.



  • @wolkenkrieger Ehrlich gesagt hab' ich keine Ahnung wie lange meine Vivaldi-Installation für einen Start benötigen würde, wenn ich eine gewöhnliche Festplatte benützte. Programme von einer SSD zu starten ist einfach viel schneller. Aber schwer einzuschätzen ob da bei dir in Wahrheit andere Probleme zu solch einer langen Startzeit führen.



  • @wolkenkrieger, die Download Liste im entsprechenden Panel wird beim Start immer neu eingelesen, einfach mal löschen.
    Hier noch ein paar Tips:

    https://www.ghacks.net/2017/02/13/how-to-speed-up-the-vivaldi-web-browser/

    Gruß, mib



  • @wolkenkrieger bei mir 4 Sekunden auf Windows 10x64 (Creator) und das wenn 6 Tabs offen und 10 Erweiterungen laufen.



  • @mib2berlin Ich gewöhnte mir das Löschen der Liste schon seit Opera 12-Zeiten an, wenn ich nix mehr herunter lud.
    Ich mag nämlich unübersichtliche Listen nicht.



  • @mib2berlin said in "ewige" Ladezeit nach Öffnen von Vivaldi und Einstellungen:

    https://www.ghacks.net/2017/02/13/how-to-speed-up-the-vivaldi-web-browser/

    Wenn man wirklich alle vorgeschlagenen Änderung vornimmt, kann man gleich Chrome an Stelle Vivaldis benutzen. Es bleibt ja praktisch nichts mehr übrig was Vivaldi zu Vivaldi macht...

    Denke allerdings nicht dass das alles nötig ist.



  • Ok. Das Löschen der Downloadhistorie scheint zumindest auf den ersten Blick etwas gebracht zu haben.

    Was mir grad eben (auch) aufgefallen ist: öffne ich unmittelbar nach dem Programmstart eine Lesezeichenliste (ich habe in der Lesezeichenleiste mehrere Ordner ... ihr wisst, was ich meine), fehlen von allen Lesezeichen die Icons. Sobals die Platte nicht mehr rödelt, sind schlagartig alle Icons da und ab diesem Moment kann ich den Browser auch nutzen.

    Und ja, eine SSD ist natürlich deutlich schneller. Weis ich. Der Verweis darauf ist aber im Moment ungefähr so sinnvoll und hilfreich wie dein lokaler Wetterbericht ... nichts für ungut :)



  • Ich habe zur Zeit auch nur einen nicht mehr taufrischen Rechner und das gleiche Prob wobei es eher weniger ein Prob der Anzahl der offenen Tabs, sondern eher an der Anzahl installierter Erweiterungen liegt wobei für jede wohl ein eigener Prozess gestartet wird, die übrigens nach Beenden des Browsers nicht geschlossen werden was auch schon länger ein Problem ist.



  • Ergänzung: ich habe ein Win 10 System 64 bit, keine Ahnung ob das bei Linux auch ein Problem darstellt Ich glaub das sollte man hier immer angeben damit eben keine widersprüchlichen Posts auftauchen.



  • Hi stevehh, copy paste mal vivaldi://chrome/settings/search#hardware
    in das Adressfeld.
    Dort kann man die background Prozesse abschalten.
    Mit meinen 3 Erweiterungen läuft Vivaldi auf meinem Alt Laptop sehr gut.

    Opensuse Leap 42.1 x86_64
    CPU Intel T4200 4 GB
    GPU Intel GN 965
    xf86-video-intel 2.99.917-6.1
    Vivaldi latest snapshot

    Gruß, mib



  • Seit dem ich die Downloadhistorie immer leere, hat sich "mein" Startproblem erledigt ... wobei das natürlich keine wirkliche Lösung ist (sowohl mein FF als auch der Chrome haben jeweils eine DL-Historie, die quasi bis zum Entstehen des Universums zurück reicht ... und keinerlei Problem damit).



  • @wolkenkrieger said in "ewige" Ladezeit nach Öffnen von Vivaldi und Einstellungen:

    Seit dem ich die Downloadhistorie immer leere, hat sich "mein" Startproblem erledigt

    Melde das doch bitte als Bug an Vivaldi. Ich fand noch keinen im
    Bugtracker.


    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report every bug seperately at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    If you use any extensions please give information which ones you use.
    If you have a URL or a own testpage which can checked, add it to the bugreport.
    If you have own testcase files (HTML, CSS, JS etc.) add them to the confirmation mail you get after report.
    If you have a screenrecording video, you can attach it to give the developers a hint how this might happen or look like.
    You will get a bug confirmation mail and in a reply to this mail you can add more information and files as attachments for the testers and bug tracking team.

    Thanks in advance for helping us to make Vivaldi better!



Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.