Vivaldi not playing some gifv files



  • This is probably related to https://forum.vivaldi.net/topic/10686/video-and-gifvs-does-not-work-after-1-3-582-3-64-bit-update but I wanted to see if there's any update about this.

    Here's an example of a file that doesn't work for me. I see a quick snapshot of the image and then the pag goes white:
    http://i.imgur.com/eYTBvRU.gifv

    I'd say it happens 90% of the time and it's bad enough that I don't even bother opening some links with vivaldi but have to copy and paste in firefox.

    Thanks!



  • @llaen Your example works for me (and so do all the "problem" links on the old thread).

    Vivaldi 1.8.770.25 (Official Build) dev (64-bit) on Mint 18.1 KDE.

    As mentioned on the old thread, what does vivaldi://gpu show ( section "Graphics Feature Status" )?



  • I'm on 1.7.735.46.
    Here's the output for Graphics Feature Status:

    Canvas: Hardware accelerated
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Enabled
    Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
    Rasterization: Software only. Hardware acceleration disabled
    Video Decode: Software only, hardware acceleration unavailable
    Video Encode: Hardware accelerated
    VPx Video Decode: Software only, hardware acceleration unavailable
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated


  • Vivaldi Translator

    I'm not into GIFV format investigation. But, as far as I understand that's not real format like real GIF. Site like Imgur or Gfycat use a renamed HTML5 MP4 video without playing sound, then call it GIFV. A lot of people seem just mistakenly think they're a new format High Definition GIF.

    Anyway,
    That http://i.imgur.com/eYTBvRU.gifv doesn't play for me at first too. And my DevTools Console shouts that mp4 being "block". Only after I disable all my extensions the file just play. Currently, I don't have time to investigate which the culprit on my side.

    Update:
    Ugh, faster than I thought.
    On my side it's "Disable HTML5 Autoplay" extension was the cause.


  • Moderator

    You need some chrome-codecs-ffmpeg package to play all videos.
    See https://gist.github.com/ruario/bec42d156d30affef655



  • Gwen-Dragon has already provided the solution but FYI, the file being played downloads as an mp4 and can be opened in VLC to show the codec (h264) needed.
    0_1489596202488_050.jpg



  • @CantankRus You're right. It's h264 support that's missing.

    Unfortunately installing chrome-codecs-ffmpeg on my system (opensuse; the package is chromium-ffmpegsumo) was a little more finicky. It required downgrading chromium to v54 and even then it didn't work.

    ruario's latest-proprietary-media.sh script didn't seem to make a difference either.
    I'll have to fiddle with this some more.

    Thanks for all the great pointers!



  • @llaen
    Just another note... vivaldi-stable is using chrome v56 while vivaldi-snapshot is using chrome v57.
    vivaldi://system


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.