Altering the url and hitting enter does a search



  • Let's say I'm visiting a page like:

    www.example.com/topic/12345

    and I modify the url in the address bar to

    www.example.com/topic/12346

    and hit enter on my keyboard. Vivaldi does a search on Google with the whole url instead of redirecting me to the new url. This is annoying since my job requires me to do this kind of actions constantly.


  • Moderator

    @umutk I can't replicate your issue with Vivaldi 1.8.770.9 on OS X 10.11.6. What versions of Vivaldi and macOS are you running and are you using any extensions?


  • Moderator

    @umutk One more thing... does your Mac have a US keyboard or an international keyboard?



  • Vivaldi version 1.7.735.46 and it says I'm up to date.

    Os X version 10.12.1

    Also please see the screenshot as how it automatically assumes I want to make a Google search as I type into the address bar and there's already a URL in it. Although the Google search below is not highlighted, when I modify the URL and hit enter, it directly searches on Google. I'm using a US keyboard by the way.

    screenshot


  • Moderator

    You're currently running an up-to-date Stable/Release version of Vivaldi.

    I'm currently doing tests with the latest Vivaldi Snapshot but I'll try to see if I can replicate this with the Release version on El Capitan. However, I also edit URLs routinely and don't remember ever running into this issue.

    I also can't think of an obvious reason why this may be happening. However, it could be something specific in your settings, a profile issue, an extension issue, or something specific to macOS Sierra. I believe that we've ruled out a non-US keyboard or non-US version of macOS.

    Is anyone else running into this problem on macOS 10.12?


  • Moderator

    @umutk I tried but was unable to replicate this issue on a clean "out-of-the-box" install of Vivaldi 1.7.735.46 on OS X 10.11.6. Hopefully someone running macOS 10.12 can do a quick test as well.



  • actually it isn't confined to MacOs.
    I have the same annoyance running Vivaldi under ubuntu 16.04
    Keyboard set to polish, but "enter" does the same thing no matter what the character map i think.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.