Ghost Platform - Using ctrl-s to Save

  • I just started vivaldi after switching from Firefox and have to say the I'm very impressed. This is amazingly faster on my desktop, and supports Ctrl + Tab MRU switching which was the big reason for not using chrome/chromium.

    That being said, I just noticed that if I use ctrl + S to save my progress when editing a post in the ghost blogging platform, I get an error message from the server, and a dialogue box pops up to try and save the page to my computer as shown below:

    alt text

    In firefox and chrome, I believe it would somehow override the default behaviour where ctrl-s would save the page, and it would just activate the "save draft" functionality within the web application.

    Is it possible for me to change a setting to get this behaviour back?

  • Some time ago someone wrote that they weren't able to use F2 in a spreadsheet web application. I tried it with Google Sheets and that site overrode Vivaldi's existing F2 key binding succesfully. But when I try it now with 1.7 Stable, F2 fires both the spreadsheet's cell editing and Vivaldi's Quick Commands dialog. Clearly there's something wrong here.

    It seems intuitive that web pages shouldn't just be allowed to override any keyboard shortcuts they please by default. But that raises the question, how to define which sites are allowed to override and which keys? There's already a feature called Site settings, but it doesn't seem to have this particular setting. Some people (most?) rarely use any keyboard shortcuts and would probably like to allow most keys and key combinations to be overridden at all times.

    Vivaldi's shortcut keys can be changed in the Keyboard section of Settings.


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.