Minimize/Maximize



  • Anyone able to do this? Clicking on the icon does nothing.
    Using Linux Mint 17.3 on a ThinkPad T61.


  • Moderator

    @nypaulie said in Minimize/Maximize:

    Clicking on the icon does nothing.

    On which icon? In the window title bar?



  • Sorry for not being clearer... in the upper right you have 3 icons, a hyphen, a rectangle and an "X". It's the rectangle one that does not respond. I use it to get a resizable window. I guess my subject was wrong, the hyphen is the min/max icon.



  • Does the icon change at all when you click on it?
    You should see an an outline around the top right hand corner when maximized.
    Maximized
    0_1487726047620_171.jpg

    Unmaximized
    0_1487726110290_172.jpg


  • Moderator

    @nypaulie: Are you quite sure the rectangle does nothing? Does it change from an overlapped rectangle to a plain rectangle or vice-versa? If so, the "restored" condition of the window is that it is stretched to match the edges of the screen on all sides and, from that position, you can actually grab an edge and make it smaller.

    On my Mint 18, it behaves as expected. The Minimize, restore and maximize buttons do what they are supposed to.



  • Actually it does Not do nothing. Holding down the mouse button keeps a darker red "background box" showing, but does not change the rectangle from a single one to one with another behind it diagonally to the upper right as your Maximized graphic shows.



  • I am not sure if this works in linux as in windows but does double clicking the area between + (for open new tab) in the tabbar and the trashbin change the min/max icon and the size of your window ?

    I coloured the area I meant in a discreet green xD

    0_1487765886980_min max.png



  • Double-clicking in the area you've colored green does the same thing as single-clicking the "+", that is to open a fresh "Start Page". Does what you suggest in Windows do for you what I am trying to achieve with the middle "rectangle" icon?



  • Do you have another window manager available?

    The minimize/maximize button works for me with Fluxbox but it doesn't change its appearance.



  • @aesouza No I don't but I'm willing to try one. I did a quick search and found some instructions for installing alternatives and how to select them (startup/login window). Can you recommend a good link for some help? Using Linux Mint 17.3 Mate right now with (I think) gnome. Thanks for your help.



  • @nypaulie Well, if your issue is only the minimize/maximize button with Vivaldi, it may not be worth installing a new window manager just for that! You could just toggle your window using Alt+spacebar,x.

    But Fluxbox is pretty small with just a few dependencies. Installing Fluxbox via your software manager will provide you with an option to choose your desktop at the time you login.



  • @aesouza said in Minimize/Maximize:

    @nypaulie Well, if your issue is only the minimize/maximize button with Vivaldi, it may not be worth installing a new window manager just for that! You could just toggle your window using Alt+spacebar,x.

    But Fluxbox is pretty small with just a few dependencies. Installing Fluxbox via your software manager will provide you with an option to choose your desktop at the time you login.

    You're right, not that important... BTW, I have no problem with Max/Min. The "-" icon in the upper right works fine... if it didn't I could always just right-click on the bottom toolbar corresponding section to do that. My problem small that it is is not being able to re-size the window. Sometimes I like to be able to see what other apps are doing. Thanks for you help!



  • @nypaulie Yep, double clicking does the same as when I single click on those icons



  • @nypaulie
    This wmctrl command will toggle the maximized state of the focused window.
    wmctrl -r :ACTIVE: -b toggle,maximized_vert,maximized_horz
    You would need to install wmctrl and bind the above command to a shortcut key.



  • @CantankRus said in Minimize/Maximize:

    @nypaulie
    This wmctrl command will toggle the maximized state of the focused window.
    wmctrl -r :ACTIVE: -b toggle,maximized_vert,maximized_horz
    You would need to install wmctrl and bind the above command to a shortcut key.

    I created a launcher with your code for the command and added it to my taskbar. With Vivaldi as the window in focus, I ran it I saw the icon go from the original single rectangle to a double one. Clicking on this gave me the sizeable screen I want. The icon toggles now until I shut down. After a reboot I need to run that command from my taskbar launcher just once and again I have the toggling I want.
    Thanks a million for this terrific tip. BTW, my system had "wmctrl" already installed.



  • @nypaulie
    No problem... been using wmctrl and xdotool for years. Don't use the window buttons.
    No need to adjust for different window managers.
    I set easystroke mouse gestures to run commands.

    1. Minimize xdotool windowminimize $(xdotool getactivewindow)
    2. max/unmax wmctrl -r :ACTIVE: -b toggle,maximized_vert,maximized_horz
    3. Unmax and resize to screen centre
      wmctrl -r :ACTIVE: -b remove,maximized_vert,maximized_horz && wmctrl -r :ACTIVE: -e 0,485,250,814,484

    @aesouza's tip of using Alt+spacebar, x might achieve the same result of fixing the max toggle as well.



  • @CantankRus Thanks again... this still leaves a (hate to say it) bug in V. OK for those who are not afraid of terminal commands, etc. but not so good for the less literati.



  • For what it's worth - i prefer dragging windows to the top screen edge to snap to maximize. Less precise mouse movement required.

    In Mint Cinnamon, this may give a half-screen tiled window, as this "feature" is enabled by default.
    To change this to maximize, go to the "Window Tiling" under Preferences in the main menu and Toggle the "maximize on window snap" switch



  • i've always had this as well on linux, i've found just pulling the top of the browser down unmaximises it. then i just close the browser in its unmaximised form so when i load it up again the browser is not full-screen when pressing the maximise icon it goes full-screen and only then im i able to fully use the unmaximise icon.

    [hope that made sense]



  • @ultraviolet said in Minimize/Maximize:

    i've always had this as well on linux, i've found just pulling the top of the browser down unmaximises it. then i just close the browser in its unmaximised form so when i load it up again the browser is not full-screen when pressing the maximise icon it goes full-screen and only then im i able to fully use the unmaximise icon.

    [hope that made sense]

    Yes, makes total sense... I figured that out too by "experimenting". Thanks!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.