Fedora 25 and h.264 support



  • Hello all. I have recently bumped into vivaldi browser and tends out to become my default browser. However there is one remaining obstacle which i can't seem to over come and that is the ability to play h.264 videos. For example, when i go here:

    HTML5 tests - video

    i can watch both the WebM and the Ogg/Theora videos, but not the H.264/MP4 one.

    From what i understand this is a common problem in linux and in some distros can be tackled installing some "chromium-ffmpeg" packages from their repositories. However in Fedora there is no such package, at least available through dnf.

    Trying to find a solution i bumped into this guide:

    How to enable HTML5 MP4 (H.264/AAC) video and MP3 audio in Vivaldi for Linux, via an alternative FFMpeg library

    according to which i tried to download and compile from the chromium source the ffmpeg library, if i understand correctly. However i failed to do so, since this command:

    ./build/gyp_chromium --depth . -Dcomponent=shared_library -Dffmpeg_branding=ChromeOS -Dclang=0

    gave me this result:

    Updating projects from gyp files...
    /bin/sh: cups-config: command not found
    gyp: Call to 'cups-config --api-version' returned exit status 127 while in /home/odorf/Downloads/ffmpeg-beta/chromium-48.0.2564.109/printing/printing.gyp.
    Package libpulse was not found in the pkg-config search path.
    Perhaps you should add the directory containing `libpulse.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'libpulse' found
    gyp: Call to 'pkg-config --cflags libpulse' returned exit status 1 while in /home/odorf/Downloads/ffmpeg-beta/chromium-48.0.2564.109/media/media.gyp.
    Package xtst was not found in the pkg-config search path.
    Perhaps you should add the directory containing `xtst.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'xtst' found
    gyp: Call to 'pkg-config --cflags xtst' returned exit status 1 while in /home/odorf/Downloads/ffmpeg-beta/chromium-48.0.2564.109/build/linux/system.gyp.
    

    I am not a power user, but i understand that i miss some dependencies or at least some system configuration which i don't know how to fix.

    My vivaldi://about/ is this:

    Vivaldi	1.7.735.46 (Stable channel) (64-bit)
    Revision	b5bc5a3efa32f49a389ebf766e3aa3c5215b6a20
    OS	Linux 
    JavaScript	V8 5.6.329
    Flash	24.0.0.194 /home/odorf/.config/google-chrome/PepperFlash/24.0.0.194/libpepflashplayer.so
    User Agent	Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.88 Safari/537.36 Vivaldi/1.7.735.46
    Command Line	/usr/bin/vivaldi-stable --always-authorize-plugins --disable-translate --enable-blink-features=ResizeObserver --mark-non-secure-as=show-non-secure-passwords-cc-chip-and-form-warning --flag-switches-begin --ignore-gpu-blacklist --flag-switches-end
    Executable Path	/opt/vivaldi/vivaldi
    Profile Path	/home/odorf/.config/vivaldi/Default
    

    My vivaldi://plugins look like this:

    0_1486846060510_b0f27596-5faf-4942-bb66-3be203509caa.png

    in case this can be of help.

    In case i am double posting, i am sorry, but i spent some time searching and trying various things before, to no result. I would really appreciate some help here. Thank you for your time





  • Hm, okay. This actually worked. Although i have no idea what has done to my system, for how long it will last, whether it is fedora's or vivaldi's issue and if it's actually reasonable to run code written for debian on fedora.

    However, thank you very much for your reply. Everything seem working now :)



  • @odorf wrt how long it'll last....i have no idea how your package management system works, but on debian when a package is upgraded, it is removed first. this means the ffmpeg library the script installed gets deleted. so we have to rerun the script when we upgrade vivaldi. i just set a cronjob for it


  • Vivaldi Translator

    @odorf
    That @Gwen-Dragon script replace Vivaldi default libffmpeg.so to the one come from Ubuntu repo, which built with non-free flags.

    That library most of time just fine to be use across distros. Just don't over it to GPL guy.

    The library versioned build. So, it supposed to be age depended to Chromium major version Vivaldi based on, currently 56.0.2924.88 for Stable & SnapShot.

    For some reason my Linux/Debian sid Vivaldi seem doesn't need that script anymore. h264 just up & running. I must did something somewhere else, too lazy to investigate, it's not broken.


    Anyway, I'm impress that you actually opt-in to try to "build your self", even if you said you are not power user. :grin:

    That error message "cups-config" mean you need cups development files. I don't use Fedora, so I don't know what's the package name.

    It part of Chromium build dependencies. There are more Chromium build dependencies obviously.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.