1.7 regression for Inoreader.com (broken scroll bar)



  • This problem coincided with 1.7 here. Confirmed that it happens on clean install too.

    If you have a long enough list of subscriptions with unread articles such that there's a scrollbar, then hovering the mouse over the scrollbar will cause the bar to flash rapidly.

    Clicking blank space beneath the scrollbar will not "page down" as it normally would (and likewise will not page up when going in the other direction).

    The only way to use a mouse to navigate down the list is to use the wheel.

    This video shows the flashing when hovering, how nothing happens when clicking, and finally shows scrolling working by using the wheel:
    https://www.screencast.com/t/UHuZtE9PUMzl



  • I'm using Vivaldi 1.7.735.39.

    After logging into Ino, none of those problems exist for me.

    I can hover over that scrollbar on the right side (when I have a lot of unread subscriptions), and it doesn't flash. And clicking on that blank space takes my scrollbar up or down, depending on which blank spot I click on.



  • @paulri Interesting, and puzzling, as I even tested this in a VM with a brand-new Vivaldi.

    Perhaps the OS? Latest W10 build here in both places I tested. I can test some other scenarios.

    I also discovered it happening in Opera 44, so not strictly Vivaldi. Definitely not Chrome though, and not V 1.6. Confused!



  • Win 10, fully updated.

    I thought i was on the dev channel, but I didn't see anything on the Vivaldi downloads page about two different channels. I put in my browser build so you could compare it with yours. Not sure if this matters or not.

    EDIT: OK, I just saw a link for a Snapshot build, which is what I have. All of which is to say, why don't you try this, to see if you still get that glitch: https://vivaldi.com/blog/snapshots/vivaldi-1-7rc-1-vivaldi-browser-snapshot-1-7-735-36/ Having said that, I'm not sure if the version you have is actually newer or older than that, so check in Help/About menu to see what build you have.



  • @paulri I can try RC1, but did you mean that you actually still have that? Because RC2 (all but identical to RTM, which is what I have) should have installed by now:
    https://vivaldi.com/blog/snapshots/vivaldi-1-7rc-2-vivaldi-browser-snapshot-1-7-735-39



  • @rseiler Yes, I meant that I have that installed. If you already have RC2, then don't worry--you have the newest version.

    Perhaps RC2 introduced a regression; perhaps there is just something (an extension, by any change---I'd try disabling any that might have an effect, like NoScript) that is on your system. But no, if you already have RC2, then forget my link.



  • @paulri Any 1.7 shows the problem. And since Opera does too, my first guess would have been that it's a Chromium 56+ thing--except Chrome doesn't show the problem.

    Anyway, if you continue not to see it, my guess is that it's something about how we have Inoreader itself setup.

    I really don't think it can be anything about the system here, since I'm testing on my PC and in VMs (with brand-new Vivaldis).


  • Moderator

    @rseiler: Chrome having a patch, bugfix or workaround for something they introduced in Chromium 56 doesn't mean it's not a 56 problem. It just means that because they created the problem, they had advance notice and were able to patch Chrome, while leaving all other Chromium-based browsers to figure it out on their own. That's pretty much their modus operandi.



  • @Ayespy Ah yes, good point. That's probably what it is, since I was grasping at it being an Inoreader setting.

    I don't have any other 56+ browsers to test with aside from Chrome, Vivaldi, and Opera (which is actually 57, since it's the dev version) to further drill down on this.

    It's a little surprising that this hasn't turned up anywhere else that we've heard about, since it's hard to believe, if that's the problem, that it affects just one site.



  • FYI
    See the flickering in Vivaldi: 1.7.735.46
    Don't see if add Inoreader.com as web panel.

    Don't see in chromium-browser: 55.0.2883.87
    Do see in chromium-browser: 56.0.2924.76



  • Inoreader responded:

    *Thanks for the report. We saw that and will see what can be done in order to fix this behavior.

    Meanwhile, you can enable the "Always show tree pane scroll bar" option available in Preferences -> Interface - Tree pane. Which will fix that.*

    So that explains why @paulri wasn't seeing the problem and at the same time offers a workaround.



  • They've now worked around the problem by switching from a CSS implementation to JS.



  • Thanks for bringing my attention to Inoreader.
    Don't use facebook, twitter, instagram and the likes so find Inoreader's interface excellent for finding interesting articles to while away the time.

    P.S I don't use scrollbars so enabled chrome://flags/#overlay-scrollbars
    Scrollbars are invisible until you middle mouse scroll.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.