RAM a Vivaldi



  • Komputer z 2GB RAM, niestety Vivaldi nie zwalnia pamięci po zamknięciu zasobożernych kart; np.Twitter...
    Dlatego nawet po dosyć krótkim czasie komputer "muli".
    Czy jest jakiś sposób na to, Opera, Slimjet, nawet Chrome, radzą sobie z tym.


  • Moderator

    A sprawdź jak wygląda zużycie pamięci w wewnętrznym Menedżerze Zadań przeglądarki (Menu > Narzędzia > Menedżer zadań) i czy tam nie trzeba by zamknąć jakiejś karty. Mam tablet z 2 GB RAM na którym używam Vivaldi i chodzi w miarę OK, choć przyznać muszę, że nie korzystam z niego na co dzień i nie mogę na 100% powiedzieć, że wszystko chodzi na nim płynnie...

    Możesz też spróbować z opcji hibernacji jednej bądź wszystkich kart w tle, żeby zwolnić trochę zasobów.



  • @pafflick W Menedżerze Zadań nic nie siedzi, sądziłem że jest coś do zmienienia we flagach.


  • Moderator

    Zrób sortowanie po ilości pamięci i zobacz który proces / karta zajmuje jej najwięcej. Być może jest jakiś wyciek i przez to RAM się zamula. Spróbuj też porównać ilość pamięci zajętej przez Vivaldi wg. wskazań Menedrzera Zadań przeglądarki z tą którą pokazuje Menedżer Zadań systemu. Jeśli jest duża różnica, to znaczy, że jest jakiś bug w przeglądarce...



  • alt text

    Tak to wygląda po ok. pół godzinie z Vivaldi (ost. stable), oglądany jeden filmik na LiveLeak, zamknięta właśnie została karta z Twitter i wykop.
    Linux Mint


  • Moderator

    @lemari W Menedżerze Zadań Vivaldiego nic nie wzbudza podejrzeń (choć ilość wtyczek ma niewątpliwie ujemny wpływ na wydajność przeglądarki), tak jak mówiłem, trzeba by to porównać ze wskazaniami z Menedżera Zadań w systemie, czy są jakieś rozbieżności (jakieś procesy-zombie w tle itp.). U mnie na Win10 Menedżer pokazuje w aplikacjach 180 MB a w procesach w tle 880 MB. W Vivaldim pokazuje trochę mniej, bo w sumie nieco poniżej 1 GB. Później jak znajdę chwilę zajrzę z ciekawości na tablet, gdzie mam o 14 GB RAM-u mniej, ile tam Vivaldi pamięci zajmie...



  • This post is deleted!



  • Moderator

    @lemari Spróbuj przejrzeć porady z poniższych linków, może któreś z nich pomogą Ci w zmniejszeniu zużycia zasobów w Vivaldim:
    http://www.ghacks.net/2017/02/13/how-to-speed-up-the-vivaldi-web-browser
    https://forum.vivaldi.net/topic/13474/my-settings-tweaks-to-speed-up-vivaldi

    Nie próbowałem żadnego z nich, bo u mnie działa to na zadowalającym poziomie, ale może akurta coś z tego Tobie się przyda...



  • @pafflick Dzięki, nic przydatnego tam nie znalazłem.
    Tak zwalnia pamięć Slimjet czy też Opera, po zamknięciu karty.
    Z Vivaldi tak się nie dzieje, pamięć nie jest zwalniana.

    alt text


  • Moderator

    @lemari Hmm, korzystałem ostatnio trochę z Vivaldi na tablecie, gdzie też mam tylko 2 GB RAM i zazwyczaj wygląda to tak, że Vivaldi po dość krótkim czasie hibernuje karty w tle i dzięki temu w miarę płynnie działa (choć demonem prędkości też na pewno nie jest). Ty masz zupełnie inny OS, więc ciężko jest mi to nawet porównać. Nie wiem czemu tak się dzieje. Musiałbyś zgłosić to na https://vivaldi.com/bugreport/ ale musiałbyś podać jakiego używasz sprzętu i też nie wiadomo, czy developerzy będą mieli na podorędziu coś, żeby to od razu przetestować i odtworzyć... :/



  • @pafflick Chodzi o Linux Mint, ciekawe że tylko Vivaldi tak się zachowuje, inne "chromopodobne" nie.
    Widzę że nikt nie podłączył się do tematu, może to odosobniony przypadek. Może sprzęt już za słaby.
    Niemniej dziękuję za zainteresowanie.
    pozdr.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.