Image rendering issue



  • Hey guys,

    I've been using Vivaldi for some times now, and the new 1.7 version causes some images rendering issues on my computer. I got it since the beta but wait for the release in order to see if it's gone, but now I can say it's not.
    Some images are rendered with a completely wrong level of contrast, the seems burnt at some point. Any ideas if it just a wrong setting on what ?


  • Moderator

    Do these images contain a ICC color profile?

    Please, can you show us a example?



  • Normal photo :
    alt text
    As seen in Vivaldi (no ICC profile, it's just a photo from my FB timeline) :
    alt text


  • Moderator

    Please give us a URL of the photo!



  • That's what I've done, do you mean I should have given URL and note displayed photos or do you want the URL of the real photo ?



  • @Hazardous Are you saying that both photos in this thread look the same to you?
    The first one looks fine to me - the second is bad :confused:



  • @TbGbe No, I'm saying the first one is coming from Microsoft Edge, Firefox or any other browser, and the second is coming from Vivaldi1.7



  • @Hazardous Well I'm viewing them both in Vivaldi 1.7.735.46.
    First looks fine here or if opened in new tab.
    Just realised you're on Windows whilst I'm on Linux (if that makes a difference).

    Still, have you checked with a clean profile (to eliminate extensions etc)?
    Just rename the Default folder
    https://forum.vivaldi.net/topic/10388/refreshing-or-cleaning-your-profile



  • the 1st is a JPG
    s23.postimg.org/3q8l50ynf/cat2.jpg
    the 2nd is a PNG
    s27.postimg.org/57rbw0c1f/cat.png
    they are NOT the same file
    I suspect there is something that gives you a different file, any extension in use?



  • @iAN-CooG In fact, I didn't use the same way to extract file, but I did it again, and same result.
    I just tried the "refresh" profile method given bye TbGbe, same result.

    I tried with the same build (1.7 x64) on another computer under Win 7 x64, no problem.



  • You should be more clear in exposing your problem.
    Are those files the problem or have you altered them in some way to show how it looks to you?
    It's a problem only on one computer but not on another, using the same Vivaldi version, or it's reproducibile on both computers?
    Give the exact link to the image to the devs, not some altered image (it's clear that the png is not the original jpg but altered) and submit a bug report if you think it can be reproduced.


  • Vivaldi Translator

    Maybe @Gwen-Dragon ask the original URL the photo reside.

    The one reside in https://s27.postimg.org/57rbw0c1f/cat.png (which supose to be original) looks fine here.
    While in https://s27.postimg.org/57rbw0c1f/cat.png is obviously bad.
    We assume those are not screenshot.

    And downloading the first one which is a JPEG. It does contain ICC profile.
    XnViewMP report;

    Color Profile	
    Description	sRGB IEC61966-2-1 black scaled	
    Model           IEC 61966-2-1 Default RGB Colour Space - sRGB	
    Copyright    Copyright International Color Consortium, 2009	
    

    The second picture might be a screenshot?
    Because it's in PNG.



  • Here is the URL of the original image, if you can see it : image

    Those two I posted are screenshots of Edge and Vivladi (the bad one).

    I don't know if it can be reproduced as long as I don't know what's the problem (maybe something on my computer).



  • @Hazardous I see it perfectly fine in Vivaldi 1.7 (Win7 32bit)


  • Vivaldi Translator

    @Hazardous
    Same. No Problem here.
    And this one also have ICC profile. Which mean the one you post 1st is the original.



  • You see the two pictures exaclty the same as I do using Edge and Vivladi on my first computer.
    Is there any new rendering engine or something that I can try ?



  • @Hazardous So it seems that the picture displays OK for you on Windows 7 PC but not on another computer (guessing Windows 10 because you mentioned EDGE browser).

    Maybe @Gwen-Dragon was referring to this (old) post (referring to monitor setup)
    https://forum.vivaldi.net/topic/5952/profile-icc/



  • I think we got something !
    This test from the thread you linked seems to prove that my system running Vivaldi (and I'm seriously asking myself why) is not supporting v4 ICC profiles.

    Why does it works with others browsers, mystery...

    EDIT : this test is saying ICC v2 and v4 is ok...



  • @Hazardous said in Image rendering issue:

    I think we got something !
    This test from the thread you linked seems to prove that my system running Vivaldi (and I'm seriously asking myself why) is not supporting v4 ICC profiles.

    Why does it works with others browsers, mystery...

    EDIT : this test is saying ICC v2 and v4 is ok...

    My system gives the same results as yours (including your edit).
    I'm now confused as to why you see the photo differently.

    Both "tests" are pretty out of date, so not sure how valid the results are.
    Hopefully an "image handling guru" will turn up with some advice.



  • Well, I hope someone can help, to resume, here is some infos :

    -I have some images with wrong display with Vivaldi, and no problems with other browsers. The two images above are showing how it looks like on my computer.

    • Tried on another computer, with Win 7 x64 and Vivaldi 1.7 x64, no problems.
    • I'm running Win 10 x64 (1607) and Vivaldi 1.7 x64.
    • I tried Vivaldi 1.7 x32 : same results.
    • On Vivaldi 1.6, no problems.

    Edit : another test with different results on VIvaldi and Edge for exemple
    This one is good for Vivaldi


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.