Occasionally address bar not focused when new tab is opened.



  • After upgrade to latest version, sometimes when I open new tab, the focus is not in address bar.

    I am using momentum extension (https://chrome.google.com/webstore/detail/momentum/laookkfknpbbblfpciffpaejjkokdgca), so it might be related but before upgrade it was OK, it was always focused.

    I press CTRL+T new tab opens with "vivaldi://newtab" in address bar (it is set this way because I want to see the momentum content when opening new tab) and I see momentum content in the new empty tab and address bar is focused and the text is selected so I can just start typing address or search... everything OK.

    Except that sometimes with exactly the same steps the focus is lost and I have to click to address bar and select the text... It is slightly annoying.

    Here is my vivaldi version info:

    Vivaldi 1.7.735.46 (Stable channel) (32-bit)
    Revision b5bc5a3efa32f49a389ebf766e3aa3c5215b6a20
    OS Windows
    JavaScript V8 5.6.329
    Flash (Disabled)
    User Agent Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.88 Safari/537.36 Vivaldi/1.7.735.46
    Command Line "C:\Users\urza\AppData\Local\Vivaldi\Application\vivaldi.exe" --always-authorize-plugins --disable-translate --enable-blink-features=ResizeObserver --mark-non-secure-as=show-non-secure-passwords-cc-chip-and-form-warning --flag-switches-begin --flag-switches-end
    Executable Path C:\Users\urza\AppData\Local\Vivaldi\Application\vivaldi.exe
    Profile Path C:\Users\urza\AppData\Local\Vivaldi\User Data\Default
    Compiler MSVC 2015


  • Vivaldi Translator

    @urza23
    Isn't that expected?
    Momentum default install has input box on its newtab page. That thing steal focus.
    If that not steal focus before current Vivaldi version that might be a bug on Vivaldi.

    I don't know if that behavior is famous or what but any pages that have input box on it usually steal focus. Firefox newtab page is old good example.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.