History Panel enabling 1.7


  • Vivaldi Team

    Thread to discuss enabling of History Panel



  • Noooo, don't disable the history panel :o
    But thanks for the warning, not gonna update :)


  • Vivaldi Team

    @luetage: You can still enable it from vivaldi://experiments/ :)



  • @Aronand That's good news, you made me update. Or should I rather say you tricked me into it :o
    After checking new history page in experiments and restarting the browser, the history icon isn't visible in panel. Right clicking the panel shows that History is unchecked, but clicking on it does nothing :'/


  • Vivaldi Team

    @luetage: Hmmmm, have you tried re-launching the browser?


  • Vivaldi Team

    @luetage: Double checked it myself, after turning it on, a restart is required for it to show :) If not then something is def wrong :D



  • @Aronand Restarted three times, still can't check history panel in right click menu, although its there. What works is the "history in the making" page, looks great.

    Maybe it's an osx issue, who knows.

    history panel



  • @aronand: I restarted PC too. And not working. Win10. 32bit version.


  • Vivaldi Team

    @nsheep: Folks, lets bring this convo over to the forum, if either of you could open a post there we can keep it going there. As this feature isn't in 1.7 its not really relevant at all, just to keep the comment section on topic :D


  • Vivaldi Team

    Aight, I moved all the comments here, now lets see if we can resolve this issue


  • Vivaldi Team

    So, what I do step by step

    open vivaldi://experiments

    Check the box for "New History Page"

    Restart Vivaldi

    Thats what I do, and with these steps I get both History in the making, and the History Panel
    I've done this now both on w10 and Mac, buuuuut, I've done it with a clean profile, there might be something messing it up for you guys from the update. Could you please try again with a clean profile? If you don't know how, we can go trough that quickly too :)



  • At this point I don't know how to resolve it, but don't sweat it, it's no big deal.



  • @Aronand I can confirm that it works with a clean profile. Although I reset my profile so many times already, not gonna do it again for this. It's a major pain if you have custom browser modifications going on. So I'm back on the dysfunctional one once again (=



  • @Aronand said in History Panel enabling 1.7:

    I've done this now both on w10 and Mac, buuuuut, I've done it with a clean profile, there might be something messing it up for you guys from the update.

    I did the exact same steps on Linux (Mint 18.1 KDE).
    It worked for me on a profile that has been through all the 1.7 snapshots.
    I do not have customised CSS installed.

    Note: I would start looking at extensions if there are problems.
    I (only) have uBlock Origin, HTPPS everywhere, IMtranslator and Youttube Plus installed.


  • Vivaldi Team

    Myeah, will be impossible to fix, if it is a bug, without knowing what causes it, atm almost anything could, but I suspect either settings/checkboxes or extensions atm, I'll do some testing and see if I can find the cause.



  • EDIT: after correctly typing the address for the experiments page i get it shown now. ^^ listed there are two things, the hue thing and the new history page. is the history panel a subfeature of the new history page? cause the new history page was in there long times, right?

    ORIGINAL: for me it's not even possible to open the vivaldi://experiments page. what am i doing wrong? or did i miss to change some additional setting before? i am on the latest snapshot. greets and thx, sUsH667



  • @sUsH667 said in History Panel enabling 1.7:

    what am i doing wrong?

    What are you doing :grin:

    As @Aronand stated:
    Use Snapshot 1.7.735.39
    Enter vivaldi://experiments in the Address/Url bar and then press enter.
    (note: it does NOT work using select/go to link)

    If this doesn't work, try with a clean profile (just rename Default folder to check it).



  • Thank you Vivaldi Team for History Panel. I like it. :thumbsup:
    After updating my Vivaldi v1.6 stable browsers to v1.7 stable on w10_x64 (vivaldi win32bit), LM-18.1_x64 (vivaldi _amd64.deb) and LM-18.1_i686 (_i386.deb) this panel worked on LM-18.1_i686 only. On all three systems I'm using same extensions.

    For w10_x64, and LM-18.1_x64 it worked after setting up new user profiles.

    Unfortunately this was kind of hassle, copy over search engines from old User profiles resulted each without History Panel button, but right-click on sidepanel showed an entry "history panel".

    So, set up new profiles for those (with all the hassle of reinstalling extensions and refining preferences) and setting up all search engines a new did the trick eventually. Obviously there's a problem migrating search engines Vivaldi v1.6 to v1.7.


  • Vivaldi Team

    @sUsH667 The history panel and History in the making is currently under the same feature in experiments yes :) This is done because 1 does not work without the other, most likely :)



  • @Aronand ok, got the history in the making history page now showing up, but i have the same problem someone else wrote already, i can't activate history in panel. it is l isted there, but when i try to activate it, nothing happens. is deleting my complete user profile the only way to get it working? greetz n thx for your help, sUsH667


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.