Can't disable PDF opening



  • I'm using the Vivaldi Browser for some days and a problem did arise: PDFs are opening now in a new tab, instead of downloading (as they were until now). I didn't change any configuration and the Chromium PDF Viewer in vivaldi://plugins is disabled (as it already was).

    Anyone has any ideas? Thanks in advance!


  • Vivaldi Translator

    @Segala
    On what site?

    I test with random pdf I could find with search engine. When I disable both "Chromium PDF Viewer" in vivaldi://plugins as you did, any pdf request for download.
    Try disable-enable that Chromium PDF Viewer.



  • @dLeon,
    on every site. It was working fine (no opening, just downloading). Then it began to open in the browser itself. Then it was working fine again. But now the problem that made me leave Chrome started: in vivaldi://plugins, the Chromium PDF Viewer is grayed and says "Disabled by enterprise policy".

    Any ideas? Btw, thanks for your answer. Best regards!


  • Vivaldi Translator

    @Segala
    Visit vivaldi://chrome/settings/content & scroll to bottom.
    There's a PDF Document setting that suppose to be uncheck.

    If still fail, and you use extensions try to disable them all to test.

    If still fail, try clean profile.

    If still fail, I'm curious to that message

    "Disabled by enterprise policy"

    By Google about it, I've got a feeling that's more Windows/Mac problem.



  • @dLeon, thanks again!

    I was not aware of the vivaldi://chrome/settings/content part, but unchecking the PDF bullet worked. Well, in fact it made avaialable again the Chromium PDF Browser and then I was able to disable it.

    By now, everything works like a charm! But Vivaldi is presenting the exact problem that made me left Chrome, i.e. a bizarre and unsolving PDF issue.

    Btw, I'm working on Kubuntu 16.04LTS. And yes, I'm also curious about the "Disabled..." message.

    Again, thanks a lot for your help. Best regards!



  • Well, well...the plot thickens. Since yesterday, Vivaldi was initializing with the "View PDF in external viewer" checked (in vivaldi://chrome/settings/content) and with the Chromium PDF viewer cancelled (the "disabled by enterprise policy" issue).

    Although annoying, I was able to uncheck the first and the setting the second and things worked. However, as of today, I do that and PDFs still get opening in the external viewer.

    Reading again your answer, I must comment that there are no extensions installed but I don't know what a clean profile is.

    Any ideas?


  • Vivaldi Translator

    @Segala
    Clean profile = user profile like 1st install.

    After closing Vivaldi. Make sure really close, sometime Vivaldi linger a bit longer. You can run pgrep vivaldi in your favorite console.
    Rename $HOME/.config/vivaldi(-snapshot) folder to (say) vivaldi~
    Moving the folder somewhere else also work.

    When you start Vivaldi again, new clean profile will recreate. Test again.



  • I tried this one

    I got this dialog window:

    0_1487049014878_20170214103728.png

    When I did the same in Chrome, it opened the pdf file straight away.


  • Vivaldi Translator

    @aesouza
    The link you provide broken. Might be forum safe guard for binary file access.

    I find that same file from unec.edu.az from search engine. my Vivaldi directly open it.

    I'm really lost.
    What happen to Vivaldi on your system?



  • @dLeon said in Can't disable PDF opening:

    @aesouza
    The link you provide broken. Might be forum safe guard for binary file access.

    I find that same file from unec.edu.az from search engine. my Vivaldi directly open it.

    I'm really lost.
    What happen to Vivaldi on your system?

    Yes, sorry about the bad link. I left an extra space in there. That makes the link look like this (without the leading ==):
    ==https://forum.vivaldi.net/topic/14158/can-t-disable-pdf-opening/unec.edu.az/application/uploads/2014/12/pdf-sample.pdf

    I can't fix that now since the post is older than 5 min but it should be this (without the leading ==):

    ==http://unec.edu.az/application/uploads/2014/12/pdf-sample.pdf



  • @dLeon and @aesouza,

    Well, I think we have a smoking gun: Google search. Or Google in general, afaic.

    I started Vivaldi with a fresh profile and when trying to download it prompted me, for the first time, the pop-up asking me what to do with the PDF file.

    It was working just fine until I made one adjustment, one that I made even before trying Vivaldi before: changing my default search engine to Google. After doing that, same old behaviour: PDF opening on external viewer, the "Disabled by enterprise policy" issue.

    New fresh start and everything working just fine, with another search engine. I'm sad to notice that, but it seems Google is spiraling out of control.

    Do you have the same results over there? Best regards!


  • Vivaldi Translator

    @Segala
    Never happen to me.
    I use a few of Google services a lot.

    If outside network could change things to your system without asking then that's definitely evil.



  • Seems to be another file association setting in play here, which is set when you choose to open a pdf in your OS default application.
    vivaldi://chrome/settings/search#auto-open

    Testing using this procedure worked for me.

    1. Goto vivaldi://chrome/settings/content and disable "Open pdf files in default pdf viewer".

    2. Goto vivaldi://chrome/settings/search#auto-open and hit the "Clear auto-opening settings" box.
      Only shows when there is a file association.
      0_1487123701463_167.jpg

    3. Restart Vivaldi

    4. Goto vivaldi://plugins and disable pdf viewer.



  • @CantankRus
    You can disregard the above because for some reason "Open pdf files in default pdf viewer" is enabled again on Vivaldi restart and you're back in the loop. :cry:



  • Confirm. Same here. Anyone got a work around?



  • I've been trying to get PDFs to show up in okular so I can do a quick check that it's OK. I would then save it, close the viewer and carry on browsing. So I'd be interested to know how to get external pdf viewer working (not Chrome!).



  • Hi, I don´t touch vivaldi://chrome/settings at all.
    Disable both pdf viewer in vivaldi://plugins and use following settings in download.

    0_1487188193425_c144d772-0bde-4250-a5b1-54594b48e2a4.png

    After click open in download dialogue Okular start.

    Cheers, mib

    Opensuse Leap 42.1 x86_64
    CPU Intel T4200 4 GB
    GPU Intel GN 965
    xf86-video-intel 2.99.917-6.1
    Vivaldi latest snapshot


  • Vivaldi Translator

    @petev
    That's opposite topic. This post about people got problem to PDF need to be download instead opening in browser.

    And it could easily possible if Vivaldi finally has MIME handling like old Opera. I believe someone already request this in Feature requests for 1.8 / 1.9
    Or obviously try to find Chrome extension which do that.



  • @CantankRus This completely solved the problem for me. On Mac OS. Thanks!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.