[Solved] Local file won't display as Homepage



  • The home page settings seem to allow only url's. I'd like to set my home page to a local jpg file.


  • Vivaldi Translator

    @rhubarbpieguy
    You need to write it like this;
    file:///path_to_your_image/image.jpg

    Anyway,
    Why not use Start page background image setting?



  • @dLeon said in Home page allows only url's.:

    ou need to write it like this;
    file:///path_to_your_image/image.jpg
    Anyway,
    Why not use Start page background image setting?

    I had entered the path as you describe without success. However, it appears url's don't work either. If I click on the Home icon the home page displays (local file or url), however, it does not display on startup, which is how I'm used to home pages working.

    Your Start Page suggestion sounds good and I hadn't noticed the option. However, that also fails to bring up the image. I entered it in the custom pane and checked 'Show Background Image.' The image I want displays in Settings but it doesn't come up when starting Viraldi.


  • Vivaldi Translator

    @rhubarbpieguy
    If you open newtab the image still doesn't show up?
    If it doesn't, what is show up?



  • @dLeon said in Home page allows only url's.:

    If you open newtab the image still doesn't show up?
    If it doesn't, what is show up?

    The image does display with [Ctrl T] but is covered with what i assume are 'Speed Dial' options. I never use 'Speed Dial' but assume I can nuke them.


  • Vivaldi Translator

    @rhubarbpieguy
    For Start Page method
    Because CTRL-t already return Start Page + your image.

    Set Startup settings > Startup with > to Start Page.
    This will make Vivaldi start only with your Startpage + image.
    This if you don't want to start with your last session tabs loaded on start.

    The Add Speed Dial button can be turn off in Start Page Settings > Speed Dial Layout > untick Show "Add" Button.

    For Homepage method
    With Homepage on Startup settings point to file:///path_to_your_image/image.jpg,

    • Set Startup settings > Startup with > to Homepage
    • Set Tabs setting > New Tab Page > to Homepage


  • @dLeon said in Home page allows only url's.:

    For Start Page method
    Because CTRL-t already return Start Page + your image.
    Set Startup settings > Startup with > to Start Page.
    This will make Vivaldi start only with your Startpage + image.
    This if you don't want to start with your last session tabs loaded on start.
    The Add Speed Dial button can be turn off in Start Page Settings > Speed Dial Layout > untick Show "Add" Button.
    For Homepage method
    With Homepage on Startup settings point to file:///path_to_your_image/image.jpg,

    Set Startup settings > Startup with > to Homepage
    Set Tabs setting > New Tab Page > to Homepage

    Other than unchecking the 'Add Speed Dial' box, I had your suggested settings for Homepage and Start Page. Unchecking 'Add Speed Dial' did solve the Speed Dial overlay problem.

    I just can't get Vivaldi to default to either at startup. This is a stretch, but I should mention I'm using '--no-sandbox' and '--user-data-dir' when starting Vivaldi.


  • Vivaldi Translator

    @rhubarbpieguy
    Those parameters seem un-related at all. I never personally dare to test/use --no-sandbox.
    Could I assume you already tried starting Vivaldi without them?

    Retrace steps above with clean profile & without any further tweaking.



  • @dLeon said in Home page allows only url's.:

    @rhubarbpieguy
    Those parameters seem un-related at all. I never personally dare to test/use --no-sandbox.
    Could I assume you already tried starting Vivaldi without them?

    Retrace steps above with clean profile & without any further tweaking.

    Success! I apparently had a corrupted profile. I deleted it and can now display in HomePage or Start Page on startup.

    I still start Vivaldi with --no-sandbox and --user-data-dir so I can store my profile in a location of my choosing.

    On a related note ... I should amend the topic title as it's not accurate. However, I see no method to do so. Is there a way?



  • @rhubarbpieguy: Tell me how you'd like to title it, and I'll fix it for you.



  • z@Ayespy said in Home page allows only url's.:

    @rhubarbpieguy: Tell me how you'd like to title it, and I'll fix it for you.

    Hmm, no title's perfect, but I'd prefer "Local file won't display as Homepage." And I don't know if it's done on this board, but perhaps [solved] should be added.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.