Snapshot 1.0.380.2 - Bug fixes and new Settings



  • Yes, right now I'm back to using Opera temporarily because Vivaldi is just super unstable for me. Some mouse clicks I did in the address bar caused the browser to close . . . there are a few things I want, like the Alt button to not trigger mouse gestures, and for the browser to actually be stable, and I would love to use it again.



  • Right now, the address bar is slow on it's suggestions, which wasn't much of a problem in previous snapshots. It's slow to autosuggest websites, and the autosuggest most frequently visited sites such as google.com doesn't work because as soon as you type "g" it'll type goal.com, not google.com, and I've never been to goal.com. This is even with "always prefer bookmarks" disabled. The behavior is really finicky, unlike a few snapshots ago, and RAM usage is going up, not down(I have one process that is about 750MB of RAM, and others that take up 100-200MB of RAM). I also want the the option to disable the Alt key for both menu and mouse gestures, so that the page doesn't go back when I'm pressing Alt and moving the mouse at the same time(because I have Alt set for a lot of keyboard shortcuts). New Opera doesn't do this behavior, so I'm hoping the next snapshot will fix these things.



  • one simply can't complain about using free RAM as far as the memory is free.
    The (other) problem is how Vivaldi can free the RAM it runs when other program need it and Vivaldi doesn't…

    Though, I have to admit that address bar suggestions are not optimized at all. (time to time I even have to reopen a blank tab just to get any of my history suggestions)



  • Yes, I understand what you're saying about the RAM. I just mentioned it because it looks like RAM usage is going up and up. In Windows 10, I mostly just use my web browser. I might open up other programs here and there and then close them, but my web browser is usually open all the time. So Vivaldi, being the only program open a lot of the time, looks like it's taking up more and more RAM. That 750MB process used to only be a 400-500MB process, and that used to be 200-300MB. I can also see that the process is usually Facebook taking up that much. So it could be FB, but I think Vivaldi is doing that. Remember that they also just recently upgraded the Chromium 48 a few times, and they were on 47. And that we're still in Beta, so it's not fully optimized yet. While I do have free RAM to spare, I'm sure it's still possible to optimize the RAM usage they currently have.

    And on the address bar, they seriously do need to fix that issue with the bookmarks suggestion thing and optimize the whole thing. When I use Opera or any other browser, it's instantaneous and doesn't suggest bookmarks, but my most used sites. But we're on the first version of Vivaldi, so they're still getting things right and I know they will get there.



  • Windows 10 64bits , o vivaldi depois de uns minutos congela , e não a mais como navegar,só reiniciando o navegador 😞



  • a versão que não trava é 1.0.344.37 (Beta 2) 64 bits



  • I'm not able to watch videos on Facebook.

    Mac OSX El Capitan



  • after all what is the latest version?



  • 1.0.344.37 (Beta 2) or 1.0.380.2 ?


  • Moderator

    1.0.380.2
    Snapshots progress in between Beta versions, and if you have a Beta installed, it only detects the next Beta. In the meantime, a TON of progress is being made in snapshots between Betas. If you install a Snapshot, it detects, and offers updates to, all of the snapshots on the way to the next major version.



  • Same here. And sometimes I have to reboot the computer and even so appears a message saying "Windows can't access specified path/file - maybe you don't have the required permissions to do this". After several reboots, Vivaldi starts and runs well, until next fail/crash/freezing…

    W 10 x64, Viv x64



  • Update:

    Feature request: Theme based context menu, bookmark dropdown, settings window

    Bug: Sometimes vivaldi just does not load the page. when I hit enter on the url, refresh , it just does not do anything. The url bar color stays in light grey (dark theme). At this time I have to close the tab and open a new tab, paste+enter the url. vivaldi loads the page without any problems. Had this bad experience often.
    Win7x64-Vivaldix64



  • thank you



  • can confirm the bug



  • Add to settings default zoom level please!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.