Snapshot 1.0.303.22 - Further stablization



  • Nice one. 🙂


  • Vivaldi Translator

    I know.
    But 1) a full sentence would have been welcome and 2) they don't forget.
    Beyond that, there is CPU to optimize, IO, GPU usage, RAM usage, network usage… Writing "CPU" each time is useless.
    He could even enhance his comment by describing specific scenarios when high CPU usage occur.

    Writing only "CPU" is like commenting on a car manufacturer blog and saying "Wheels".



  • I have a little request about url bar suggestions. It needs to be more adaptive. Example: let's say I have been visiting interestingsite.net for quite some time, but they changed domain name, so now I have to visit interesingsite.com (they did not renew .net domain name so no redirect). Right now Vivaldi will always suggest .net with no way to change that behavior. Also, if I added to bookmarks site interesingsite.net/something url bar will suggest that address, event thought I always type interestingsite.com or .net



  • Confirming the problem on win10 x64.



  • I understand and I know what you mean. 🙂



  • I'm gonna bet on 3 to 5 more. The amount of bugs fixed er snapshot varies, and there are always some regressions between each launch. But I believe we're not two far from the Beta, so, maybe by next month! 😃



  • And I will give an example:

    Most of the time Vivaldi is running high on CPU. It's the only program that uses 100% of my CPU - granted, it has only one core, 3.1GHz, but still, for a single program -, although it usually peaks at 80% most of the time.

    This happens mostly when i'm either running a video or trying to open older tabs the browser stopped rendering so it could render newer tabs. An example of this occurrence would be if I opened about 10 deviantArt tabs (it suffers more slowdowns from websites that have heavy images), and then tried going back to my Vivaldi Blog page, the heavy CPU usage would occur. And I could even close all 10 dA tabs before switching back to the Vivaldi Blog, it would still consume loads and loads of CPU juice!

    I believe my example will suffice.



  • Never happened to me before, in any build I've had (and I've had all of them since day 1).

    Windows 7 64x, Vivaldi 64-bits.



  • I remember seeing somewhere that it was indeed intended. But they should put an option to apply other command to the button (double click or not), or to remove it for good.

    I, personally, have no use for that button, and I might end up closing the browser by mistake. I certainly don't want that to happen.



  • BUG since 2 Versions (Windows 7): Opened search combo goes into the wrong direction on bottom of the page - it goes down and shows only one entry - due to having no space to go down it should go upwards and show all entries



  • Is the auto update feature broken now? I didn't get any notification for build 1.0.300.5 and so I manually downloaded and installed it. Now I'm on that build, and when I do "Vivaldi > Check for Updates . . . ", nothing happens. I'm on Mac OS 10.11 .


  • Moderator

    Works fine in Windows. Don't know about Mac…



  • Win 7 64 bit, 8 Gig, 32 Viv

    Bug or just mine? In auto-fill password on adding a new site it takes my Username but NOT my password.
    Don't get popup to add new password, old saved passwords work fine. Looked in settings>privacy>passwords not in listing.

    Also a hover above bookmark URL in panel to show full cutoff name would be nice also.

    I found new item for me the Bookmark in address bar turns blue if already bookmarked, don't know how long it has been that way but a small thing but GREAT feature.

    Still don't see sound indicator on tab if playing, thought that was great also. Hope it returns.

    PS: Since this is first build I can actually use I'll try to post feature request in forum section. I just had possible bug…so I thought I'd add all sorry.

    You are going to have a FLOOD of browsers copying you as you did in OLD Opera < 12.


  • Moderator

    Sound icon is working fine here on Windows 10.

    The password thing is weird. I've not seen it.

    Yes, the blue bookmark thingy has been around for about 10 builds now, if I remember correctly.


  • Moderator

    IMPROVED EFFICIENCY: There's nothing about it in the changelog, but I note that the browser is opening faster and using less memory to do it. ONE of the reasons appears to be that tabs from the prior session are not loaded until you click on them. Good move.



  • Yay, I love the new build!



  • OMG, has lazy tabs loading been implemented already?



  • Maybe because Vivaldi is installed on an encrypted VeraCrypt drive, though I don't see why that should prevent renaming and deletion of the files. It doesn't prevent installation.


  • Moderator

    Sure looks like it. On startup at least…



  • @D0J0P:

    That's okay, Ruario. Don't worry too much about it. Is there a way to get the 64bit version out right away! How does that work?

    And how many snapshots you figure till the Beta comes out?

    I have one solution. By using time machines. I recommended using DeLorean car. Start the time before Ruari cancel the build for Windows 64 bit. If I'm correctly, you back to that time, you can give a some message, mention him on twitter reminds him do not touch the cancel button, may be you will regret it later bro. Huhuhuhuhu…Just my 2 cents. #BacktotheFuture


Locked
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.