Snapshot - Fixes to typed history, keyboard shortcuts for web panels and visual polishing

  • I've had this issue in Opera, too. Opened 200 tabs in a private window quite fast, and the last few won't load anything at all. Just blank. I think that's a chromium issue. Not sure if using 64 bit builds would help (well, Opera doesn't offer them and I'm not running Vivaldi daily yet) but it certainly seems like a possibility.

  • - Ambassador -

    On Linux, there is a package that includes proprietary codecs : chromium-codecs-ffmpeg-extra. It provides us with a ffmpeg built with support for h264 (and the rest). You can get it directly from the servers of Ubuntu :

    The link you give with crbug return a 404.

    For the codec list, since the change to ffmpeg, V return a different result to the JS test HTMLMediaElement.canPlayType(). It responded before with an empty string which was understood as "No", while now, they respond with a "Maybe", which is wrongly interpreted by Youtube as a "Yes".
    So the main issue is that no further tests are done by YT when they see a "Maybe" (but they should do them), and that they don't fall back to webm/flash.

    They don't misadvertise the codecs list. "Maybe" is a good description, as they don't know. The issue come from the websites not following the specs.

    The on my site work on any distro, yes. It's not cleared up because there is still a small doubt, but they should. Their only dependancies are,,,, All of which are also dependancies of Vivaldi, so there is no issues here.

    As for the part of the replacing FFmpeg, there are a lot of issues here, including legals ones, for not delivering the full (h264 inclusive) ffmpeg lib.

    If you want to write directly to me, you can by using my pseudo 🙂

  • Nope, doesn't work. 'all users' is greyed out. When I change the folder to, for example 'desktop' then Vivaldi changes it to 'program files/vivaldi'. After that I can change to all users, but the problem persists. Should have something to do with permissions in windows 10, but can't find out what.

  • BUG: Some Web Panel favicons still does not appear or load properly or none at all. eg. and others…
    BUG2: VB-9434. -> annoying bug on Mac.

    Please make scale properly as a Web Panel. Or at least make it possible to resize individual panels so it's not a one size for all thing. 😃
    Thanks for the release!

    -OSX 10.10.5

  • is the amazon wishlist button a bookmarklet? It doesn't work
    (you can "install" it but it opens a blank new tab, when you want to use it)

  • Found it: VB-9113
    Also I have opened a topic about it:

  • Moderator

    Known. Being worked on.

  • Moderator


  • Unfortunately, my knowledge is apparently insufficient here. I am totally unable to get Chromium built with H.264 support (I can't get the boxes on the YouTube page to check themselves, like they do in the new Vivaldi snapshot).

    Additionally, I have tried building FFmpeg with H.264 support from Chromium's tree. It works identically to Vivaldi's shipped FFmpeg (read: many unviewable videos) when the build is branded as "Chromium" and it crashes the tab for many video-containing pages when built as "Chrome" (read: the H.264 support seems broken, but Vivaldi doesn't ship with debugging symbols to try to figure out what's actually going on). However, with some patience, YouTube videos will start playing without audio this way.

    This feels more and more like a Vivaldi issue, the more I poke at it. It may be saying "maybe", but I can't get the failing pages in my current test suite to show a MEDIA_ERR_SRC_NOT_SUPPORTED or similar in the Developer Console. This would be a prerequisite for falling back to another media type. If the page can't tell why the video is failing, it's just going to fail, which seems to be what we're seeing now with YouTube and others not loading the alternative representations we would have received in the previous snapshot. "Maybe" doesn't work when the page does not know that a source is unsupported. Even the fairly robust Kaltura player fails now:

    As this seems unresolvable by the community (unless someone else takes the initiative to figure out WHY the Chromium FFmpeg branded as Chrome cause Vivaldi to fall over), I'd like to humbly request that the Vivaldi team reconsider advertising proprietary codec support (at least on Windows, and maybe OS 😵 until such time as it's actually possible for users to enable it, or Chromium bug 21318 ( ) is resolved.

    I'm also somewhat irritated that almost everyone I've gotten converted to Vivaldi is telling me now that " <insert video-playing="" site="">has stopped working! Help!" 😞 There is literally nothing useful I can tell them to make it work.

    Cqoicebordel, it may be worthwhile to list that the .so you provide came from Ubuntu. IIRC, the Vivaldi RPM and DEB deliver binaries differing in required GLIBC versions, so the Chromium FFmpeg also may. As I'm not running it on Linux at the moment (as evidenced by having rebuilt Chromium on Windows a few dozen times in the past 24 hours…), I cannot verify that at this time. But it may save a non-Debian/Ubuntu user some grief if they can quickly identify a potential reason for "it doesn't work!" And I'm quite aware of the issues with providing a fully-enabled FFmpeg; I never offered a DLL, but I would have provided instructions as to how someone in a more legally-generous location could have built and used it if I was successful.

    Maybe soon, I'll finally figure out how to see how a Debian package is built so I can build the same way on Windows, if they are doing something special. Of course, there may be a .spec (which is trivial to read) if I can find an SRPM of the replacement library...

    For the record:

    C:\...\chromium\src> python build\ --depth . -Dcomponent=shared_library -Dffmpeg_branding=Chrome -Dtarget_arch=x64 -Dproprietary_codecs=1
    C:\...\chromium\src> ninja -C out/Release_x64 ffmpeg

    But that yields an ffmpeg.dll that Vivaldi hates, but it seems like it should work fine. YouTube eventually plays without sound and many tabs will crash, even if it's obvious they have embedded media. Not necessarily an improvement over videos simply not playing. (For the record, an X86 build goes directly into out/Release. The 32-bit result is untested by me as I only have 64-bit Vivaldi readily accessible right now.)</insert>

  • - Ambassador -

    Thank you for so much nice work again. It's a huge job and when I look through the setting page I can see how much you have done already. So much remains to do … so hang in there and keep up the good work!

    But I have one small complaint; thanks to your memory management improvements I am now back to my old sin of having way too many tabs open at once :-(.

  • Vivaldi Team

    Do you have a list of urls where you have a problem getting a favicon? works fine here. Perhaps because the icon has been cached earlier on my machine and installs immediately when the panel is set up (otherwise we wait until the panel content has been loaded so the icon can be fetched via the page itself).

  • @3630:

    Nope, doesn't work. 'all users' is greyed out. When I change the folder to, for example 'desktop' then Vivaldi changes it to 'program files/vivaldi'. After that I can change to all users, but the problem persists. Should have something to do with permissions in windows 10, but can't find out what.

    Run the installer as administrator and pray that the greyed out option can be selected.

  • When will the final version of Vivaldi

  • When you delete a bookmark from the express panel browser should ask for confirmation.To avoid wrong actions. Or even remove the delete button and remove the possibility to make a correction mode only

  • I don't know if it's the best place to post this, but… How about adding the release date next to the build number on "About" page? It's hard to keep up with the frequent updates on Linux without automatic update...

    Thank you so much, you guys ROCK!

  • Well, it just does not work at all and it seems to be a known issue. Should we still report it? Does anybody know the bug number?

  • - Ambassador -

    The order is correct on the View menu.

  • I had problems with inoreader and instagram for a while. Seems to work now. But and still doesn't load their favicons for some reason. Haven't tried a clean install. Got many things set up so I can't really do one though. They won't even load on my Windows machine. I'll try to keep adding other URLs to test

Log in to reply

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.