Start von Vivaldi dauert sehr lange - ist das normal?



  • Hallo.

    Nach längerem Test bin ich nun endgültig auf Vivaldi als Standardbrowser umgestiegen (auch dank der Vivaldi Hooks). Aber eine Sache nervt ziemlich: der Start dauert sehr lange - ca. 15 Sekunden. Mit den gleichen Erweiterungen dauert es bei Chrome nur ca. 7 Sekunden, Opera startet noch schneller. Danach geht dann zum Glück alles rasend schnell und flüssig.
    Selbst ein "nacktes" Vivaldi (ohne Hooks und Erweiterungen) brauchte über 10 Sekunden zum starten. Ist das normal oder kann man das irgendwie optimieren?



  • Mein Vivaldi braucht 5 ohne Erweiterungen, 10-12 Sekunden mit 10 Erweiterungen.

    Da bei Vivaldi die Oberfläche und manche internen Features zwecks besserer Anpassbarkeit mittels Javascript erzeugt werden, dauert das starten etwas länger als die maschinencodierten bei Opera oder Chrome.

    Hängt vielleicht auch davon ab, wie schnell dein Rechner und Betriebssystem ist.



  • Hmmm - schade. Ich hatte gehofft, es läge an einer Einstellung.
    Wenn wenigstens schon mal ein leeres Fenster aufgehen würde, das sich dann nach und nach aufbaut - so würde es "gefühlt" schneller gehen ...
    Aber vielleicht tut sich in Zukunft ja noch was in Sachen Startgeschwindigkeit!?



  • Hi, es wurde im Form gemeldet das der Start länger dauert wenn die Liste im Download Panel lang ist.
    Ich lösche die immer zügig und kann das nicht bestätigen aber testen kann man das ja mal.
    Mein uralt Laptop startet Vivaldi in ca. 7 Sekunden, allerdings von SSD, 15 finde ich schon ziemlich lang.
    Es war auch noch ein Thread mit anderen Einstellungen, finde ich bloß nicht mehr. :(

    Gruß. mib



  • Danke für den Tipp! Downloadpanel leeren hat leider nichts gebracht. Auf einem Uralt-Laptop habe ich es jetzt auch installiert - Start dauert "nackt" auch ca. 10 Sek.
    Mit 12 Erweiterungen sind´s dann ca. 15 Sekunden. Geht wohl aktuell nicht anders ... :cry:



  • huiuiui, 15 Sekunden im Vergleich zu 7, was man da alles machen könnte. Und ich dachte beim Lesen des Titels, dass es hier um Minuten geht ;)
    Mal im Ernst, ich starte Vivaldi einmal am Tag, was sind denn da +8 Sekunden? Zumal das ja (wie man sieht) auch an x verschiedenen Faktoren hängt. Natürlich nervt es evtl. dich persönlich aber ich finde, da gibt es sinnvollere Features, die Programmierzeit benötigen :thumbsup:



  • Stimmt schon. Aber wenn 15 Sek. lang nichts passiert, kommt einem das wie eine halbe Ewigkeit vor.:wink: Erst recht, wenn man es von Opera / Chrome anders gewohnt ist. Allerdings kommen dort dann einige Sekunden dazu, bis meine Startseite aufgebaut ist. Im Endeffekt ist es dann nur noch gefühlt ein großer Unterschied.
    Aber es gibt sicher Wichtigeres ...



  • @chrisly Ich lösche einfach ab und zu das Cache Verzeichnis wenn es zu groß wird (und es kann manchmal bei meiner Art von Nutzung mit meistens deutlich mehr als 50 gleichzeitig offenen Tabs gigantisch groß werden), das beschleunigt zumindest bei mir den Start.

    Nur so zum Vergleich:

    Aktuell ist mein Cache Verzeichnis ca 900MB groß - was natürlich das öffnen einzelner Seiten stark beschleunigen kann, wenn man immer wieder die selben Sites aufruft - aber diese 900MB müssen natürlich beim Start auch verarbeitet werden (nicht unbedingt geladen, aber zumindest geprüft) und alleine die Festplatten-Geschwindigkeit setzt da schon Grenzen.

    Das Backup meiner Nutzerdaten, welches ich regelmäßig mit einem kleinen CMD Script erstelle (siehe hier: https://forum.vivaldi.net/topic/13712/einstellungen-sichern/3 ) ist dagegen nur ca 40MB (gepackt) groß und außer einigen Cache Sachen ist alles wichtige enthalten.

    Entpackte 80 MB im Vergleich zu 900 MB machen schon einen kleinen Unterschied :D



  • @Gwen-Dragon
    Das wissen die Wenigsten, wie Javascript arbeitet. Das spielt sich (fast) alles auf dem heimischen PC ab. Ich habe mir jetzt einen NUC von Intel angeschafft mit SSD-Platte und 4k FS-Gerät als Monitor. Da geht die Post ab. Da erscheinen meine sechs Vivaldi Fenster in weniger als einer Sekunde. Und das über meine lahme Wifi-Schnittstelle!

    Was jedoch nervt, daß der Vivaldi-snapshot sich nur mit Tricks als Default-Browser einstellen läßt. Und da meckern doch einige User/Entwickler (Jon von Tetzchner) wegen W10, daß nach Updates sich der Edge immer wieder als Default-Browser einstellt, wobei sich das sicherlich auch in der Registry ändern läßt!
    Da sich bei der Vivaldi-stable Version seit geraumer Zeit nichts mehr tut und ich die nicht beseitigten Bugs satt bin, werde ich diesen generell dem Snapshot opfern.
    Wie dem auch sei : Nach Opera 12 ist das bislang der für mich beste Browser, der im Internet angeboten wird.
    Man muß sich eben nur einarbeiten. Aber unter dem Os Linux kein Problem :grin: .



  • @harrygrey said in Start von Vivaldi dauert sehr lange - ist das normal?:

    Da sich bei der Vivaldi-stable Version seit geraumer Zeit nichts mehr tut und ich die nicht beseitigten Bugs satt bin, werde ich diesen generell dem Snapshot opfern.

    Dass sich deiner Meinung nach bezüglich einer weiteren stabilen Vivaldi-Version nichts tut, liegt einfach daran, dass erst interne neue Builds auf Fehler getestetet werden.
    Wenn keine gröberen mehr gefunden werden, dann werden sie als öffentliche Snapshots freigelassen, damit mehrere Anwender diese Builds auf eventuelle Fehler testen können.

    Ist dann eines Tages alles soweit in Ordnung, kommt eine finale Version heraus.
    Ein Snapshot ist daher eigentlich nur zum testen und zum melden von eventuell gefundener Fehler gedacht.



  • @Alexs
    Das habe ich mir schon gedacht, aber es dauerte mir etwas lang. Und es waren ein paar Sachen im Snapshot, die mir das Leben leichter machten. So muß ich dort z.B. beim Eingeben des persönlichen Schlüssels (Master-PW) nicht mehr auf die Eingabe klicken, bis Vivaldi soweit ist, daß er mich in dem Fenster bleiben läßt.
    Ich vergleiche immer noch mit Opera, der für mich die meisten Features hatte, die mir nützen. Es fehlt da noch hier und da eine Kleinigkeit. Aber dafür gibt es auch einige Extras, die Opera wiederum nicht hatte.
    Jetzt kam gerade ein Update von Snapshot, was einen Bug beim Composer aufdeckt: Obwohl ich explizit den Snapshot als Prewiew Browser eingestellt habe, wird der Composer gelöscht. Laß' ich auch so, da ich besser mit dem Dreamweaver über PlayOnLinux klar komme.
    Freue mich auf die finalen Versionen.
    Leider kann ich für XP, was (noch) bei uns läuft, nur eine ganz "alte" Vivaldi-Version nehmen. Ist halt so.



  • Mit meinem I5 4670K @ 3,8 GHz, 16 GB Ram und einer SSD dauert das starten von Vivaldi Snapshot 1.8.755.3 x64 mit 4 Addons (uBlock, Poper Blocker, Hola und Stylish) 2 Sekunden !



  • @ncc1977d Auch nach einem OS Kaltstart? Denn wenn aus der Auslagerungs- bzw. Hibernierungsdatei geladen wird, geht alles schneller.

    Nach einem OS Kaltstart ohne Hibernierungsdatei benötigt Vivaldi für den Start mit einer 80+ Tab Sitzung, einer gefühlten Milliarde Lesezeichen und Notizen usw. ca 8-10s (keine SSD, aber sehr schnelle HDDs). Wenn ich Vivaldi dann schließe und erneut starte jedoch nur noch 2-3 (da wahrscheinlich das meiste noch im RAM ist, speziell die mitbenutzten System DLLs) und nach einem OS Warmstart (also mit Hibernierungsdatei) 3-4s.



  • @QuHno
    Bei mir sind Auslagerungdatei und Hibernation ausgeschaltet... ;-)



  • Sorry I replied in English, but I understand you anyway.
    After having cleared all cookies etc. using CCleaner, I used the stopwatch on my mobile phone to measure the startup time with Vivaldi.
    My startpage is https;//www.google.com/ncr
    I am behind a VPN service in China .... (which slows things down a bit)!
    It loaded so fast (less than 2 seconds) that I barely had the time to stop the stopwatch!
    Obviously it depends on the start-page you are using, but loading websites is definitely not a Vivaldi problem.
    I have been using Chrome for a long time and see no difference in speed between the two.
    So in your case it must be a different reason why Vivaldi starts slowly.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.