Problem with BACKSPACE and vBulletin 4.2.2 forums



  • Hello,

    I'm really enjoying using Vivaldi and this is probably the closest I can get to old-Opera in modern days.

    But there is one serious bug that I really really hate. When I post on forums there is a bug that occurs very often. I can't get behind the logic, but when I write a post in vBulletin forums and hit backspace to delete typo page goes back instead of deleting a letter discarding all the info I have entered. You can imagine how annoying this can be when doing something picky or long.

    I have tried Chrome on same forum and haven't experienced such a problem so I'm 99% sure this is Vivaldi-bug and I would be really glad if I could see it fixed.

    By the way, I'm using
    1.6.689.40 (Stable channel) (32-bit)
    Windows 7 (64-bit)

    Cheers!



  • This is a already known issue (see this for example)

    The "workaround" so far is to remove Backspace from the shortcutlist:

    • Open Vivaldi Settings (Alt+P)
    • Go to Keyboard
    • Open Page section
    • Go to 'History back' entry
    • Select only the 'Backspace' button in shortcut field
    • Hit Del
    • If you want assign a new shortcut or use the ones that are already there
    • Close Settings

    Not perfect but it works ; )



  • @wladymeer I think it's been fixed in the latest snapshot:

    Backspace and single-key shortcuts triggered on some HTML5 forms and forms with JS listeners (VB-15598)

    Can you try Vivaldi 1.7.735.11 and confirm whether it works for you? Just remember to install the Snapshot as standalone, as updating Vivaldi Stable to Snapshot (and vice versa) can sometimes break something in your profile.



  • It does not only happen on vBulletin. For me this happens all over the web, it even does it if I disable that shortcut. I'm on 1.6.689.40 on Windows 10 Pro. ctrl+left also triggers it from time to time. The main annoyance is that it is not predictable. It seems to happen randomly. I even tried disabling keyboard shortcuts altogether and still it happens from time to time. For awhile it didn't happen that often, but now (on a Xenforo forum) it happens quite frequently.

    Related:

    forum.vivaldi.net/topic/5018/can-t-use-backspace-when-entering-text



  • @meathim said in Problem with BACKSPACE and vBulletin 4.2.2 forums:

    For me this happens all over the web

    Even with the latest Snapshot as @pafflick mentioned?


  • Vivaldi Translator

    Can you try Vivaldi 1.7.735.11 and confirm whether it works for you?

    Ooooh, could this be solved? Let's switch the backspace navigation on again.
    Well, it certainly looks as if it's solved, at least for this forum, as well as for Outlook online.
    Great news.


  • Vivaldi Translator

    And I'll top that!
    The problem with passing key presses to the active extension has also been solved
    I'm so happy



  • @S_Paternotte Ah, nice to hear it works nwo for you!



  • Hello, 9 months passed, currently working with Vivaldi v1.12.955.36 and this problem is not solved. I still get ocassional rewind if I press BACKSPACE during my typing and it's quite frustrating as I enjoy using keyboard shortcuts.



  • @wladymeer 1.13 Snapshot did not help?.



  • @gwen-dragon I will install it now and see if it's solved. Thanks!



  • I don't know why this is set to resolved. I'm currently using the 1.13 snapshot and this bug still appears at least on one forum I know. I have a feeling there is no general way to fight this issue, other than changing the History Back keyboard shortcut (which is obviously the cleanest solution, and I do recommend it).



  • Where does this happen? In Admin Panel? I would like to check it.

    //EDITH: Tested now in 4.2.2. Demo.
    Can't reproduce with 1.13.971.8 x64 on Windows 10 x64 and standard settings.
    Tried it like wladymeer said.

    @wladymeer said in Problem with BACKSPACE and vBulletin 4.2.2 forums:
    but when I write a post in vBulletin forums and hit backspace to delete typo page goes back instead of deleting a letter discarding all the info I have entered.

    I tried it in a thread post, a blog post, a blog comment.
    in VBB 4.2.2 Backspace in editor or input field does not go back in history, it deletes character.

    I changed the editor modes

    • Enhanced Interface - Full WYSIWYG Editing
    • Basic Editor - A simple text box
    • Standard Editor - Extra formatting controls

    and backspace works fine in text fields or textareas.


    :tired_face: :coffee: I feel like hunting :ghost: :ghost: :ghost: and :bug: :bug: :bug: for hours now.

    Do you use a special VB 4.2.2 forum with some patches?

    Please, I really need a precise description how to reproduce, a GIF animation to visualize would be nice, and more information about your Vivaldi settings, extensions, modifications.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.