Searching via Quick Commands adding "+" to search results, breaking some search engines



  • I was trying to setup a custom search today on a site, and since it used a weird syntax, Vivaldi wouldn't do the normal song and dance to just add it, and I had to do it manually, which mostly worked. But I noticed that it was still behaving strangely. Every search I did had an extra plus sign + in it. This is easy duplicated by pressing F2 and just typing "g test" and hitting enter, and looking at what is in the address field. This doesn't happen if you search from the address bar or search bar.

    http://i.imgur.com/Vjyd5TO.png

    It doesn't break most search engines, but sites that use non-standard search engines, it is kind of a pain for. Is there a work around, or some alternative to %s as a variable I could use.


    Windows 7 x64

    1.7.725.3 (Official Build) (64-bit)
    

    Although I doubt this is build/system specific.


    Another poster was having a similar problem a long time ago, but never got any feedback or resolution that I could see.

    Re: Quick Actions search prepends '+' to search terms



  • @Saucermote Hi. I actually reported this as issue VB-18596 back in june 2016, and it doesn't appear to be fixed yet. It's quite annoying, and I don't know of any workaround.



  • I have same problem too.
    '+' is added automatically.
    In my case, this is happening only searching by F2 quick command.
    0_1491202968547_0ff060c2-fd78-46ac-bbe6-d2f421b1800f.png

    Linux, Ubuntu Gnome 16.04LTS
    Vivaldi: 1.8.770.50 (64bit)


  • Moderator

    I can see that the bug is fixed in a internal dev version.
    May be you get a fix in next Snapshot.



  • @Gwen-Dragon Thank you for information and fix of issue.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.