xdg-open with a URL opens an empty Vivaldi window



  • Hello,

    That's a pity, but on my Ubuntu 16.10 I cannot set Vivaldi as the default browser because other applications cannot open URLs with it: xdg-open just opens a new empty window.

    Is it only me or everybody is affected?


  • Vivaldi Translator

    @smartptr
    Run this in terminal xdg-settings get default-web-browser
    If it doesn't return vivaldi-[stable|snapshot].desktop. Your default browser isn't Vivaldi.

    Check mimeapps.list on;

    $HOME/.config (new place)
    $HOME/.local/share/applications (old place)

    These x-scheme handlers should be like this;
    x-scheme-handler/ftp=vivaldi-[stable|snapshot].desktop;
    x-scheme-handler/http=vivaldi-[stable|snapshot].desktop;
    x-scheme-handler/https=vivaldi-[stable|snapshot].desktop;

    Now those above would fix it IF your application call xdg handlers.
    If the application hard coded to search other browsers first or doesn't use xdg handlers at all, you're out of luck.
    I ever met one application that specifically search for Google Chrome first and use that if it installed. Forgot what. And I don't think I want to remember it.
    Example of application that seem doesn't use xdg handlers is XnViewMP.



  • Vivaldi-snapshot is the default browser accoring to xdg:

    $ xdg-settings get default-web-browser
    vivaldi-snapshot.desktop

    mimeapps.list is also properly filled.

    Still:

    $ xdg-open "http://google.com"
    Created new window in existing browser session.

    And what happens is indeed a new window, but with no url. Same thing happens when a URL is opened by another application.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.