Forum Email Notifications - Link Doesn't Point to Reply



  • When email notifications started working, the email provided a link to the specific reply (post). That way, you could click on the link and go right to the reply in the thread. Currently though, this link is missing (in both text/plain and text/html parts) in the email. All you have is a link that takes you to the beginning of the thread (topic).

    The reply (post) link is still present for replies to replies, just not replies to the thread itself.



  • Or, if it's too tough of a fix, at least make the link point to the last post in the thread instead of the first. It's a lot easier to work backwards to the first unread post in a 7-page thread than forwards.



  • Any acknowledgement from the forum devs? Just want to make sure they know.



  • Did you report the bug to Vivaldi devs?

    If you found a bug, please report the issue to the developers to fix it.

    How to do a bugreport for Vivaldi
    Report each bug seperately at https://vivaldi.com/bugreport/
    Describe the issue as precise as you can.
    Add some information about extensions you use.
    Add information about the operating system and version you use.
    if you have problems with video or audio give us information about your installed codecs and graphics card/GPU.
    Add a link to a testpage where the issue comes up and can be tested.
    After reporting the issue, you will receive a confirmation mail from the bugtracker.
    In a reply to this mail you can add more information and files (like screenshots or testcases) as attachments and it will be added automatically to bug report.
    If you have questions about the bug please ask in forum first and do not forget to post the VB-XXXXX bug number (you can find it in confirmation mail).

    Thanks in advance for helping us to make Vivaldi better!




  • forums.opera.com just started using NodeBB and they ran into this issue too. I posted about it on the forums and the NodeBB devs saw the issue and fixed it.

    https://github.com/NodeBB/NodeBB/issues/6027

    So, it's fixed in the next release.

    Looking at the diff, you can see that it's even a safe change to do right now.



  • @burnout426 Yeah, but why do you need an email. If you access the site with login, you get notifications of any new posts that have been made of a thread you are watching -- this links exactly to the new post, not the beginning of a thread.



  • @burnout426 said in Forum Email Notifications - Link Doesn't Point to Reply:

    forums.opera.com just started using NodeBB and they ran into this issue too. I posted about it on the forums and the NodeBB devs saw the issue and fixed it.

    https://github.com/NodeBB/NodeBB/issues/6027

    So, it's fixed in the next release.

    Looking at the diff, you can see that it's even a safe change to do right now.

    You don't even have to patch the file itself. You can just make the change right in the editor in the admin forum settings.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.