Enable password save for sites where autocomplete=off



  • OS:
    Distributor ID: Debian
    Description: Debian GNU/Linux 8.6 (jessie)
    Release: 8.6
    Codename: jessie

    Windows manager:
    i3 version 4.8 (2014-06-15, branch "4.8") © 2009-2014 Michael Stapelberg and contributors

    Browser:
    Vivaldi 1.6.689.34 (Stable channel) (64-bit)
    Revision 841b9a58130b84a3816d42023b714a2127e1e56f
    OS Linux
    JavaScript V8 5.5.372.32
    Flash (Disabled)
    User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.92 Safari/537.36 Vivaldi/1.6.689.34
    Command Line /usr/bin/vivaldi --always-authorize-plugins --disable-translate --enable-blink-features=ResizeObserver --flag-switches-begin --flag-switches-end

    I frequently login to a couple of our company intranet sites that require a user name and password. The Vivaldi password manager however does not ask me to save the password. I read that this could be due to the form attribute autocomplete being off. Is there a preferred way to force this in Vivaldi, or circumvent this behavior? I'd like Vivaldi to remember my login credentials for these sites. Firefox does work with regards to this.

    Cheers,



  • @naschoff -- Don't know if these will do the trick for you, but if you'd like to try:

    vivaldi://flags

    Force-saving of passwords Mac, Windows, Linux, Chrome OS, Android
    Allow the user to manually enforce password saving instead of relying on password manager's heuristics. #enable-password-force-saving

    Oh - i was going to give you another flag too, but it seems to be removed now in this version.



  • @naschoff
    The tip from @Steffie seems to work.
    Goto vivaldi://flags/#enable-password-force-saving and enable.
    After saving your passwords you could then disable again.



  • Thank you for the suggestion. However, I had already tried this without positive result. Even with this flag enabled, certain sites do not retain nor offer to retain the logon credentials.

    For both sites in question, Google Chrome does offer to retain, and properly retains the logon credentials. (Version 55.0.2883.87 m (64-bit))

    P.S. I restarted Vivaldi after enabling the flag.


  • Moderator

    The property autocomplete with value off in a login or input field is currently ignored in Chrome and Vivaldi.
    Vivaldi saves login+password after entering and login.

    Does Vivaldi stores intranet logins? Check chrome://settings/passwords
    Perhaps your intranet has a crazy (sub)domain.

    Which keyring do you use?



  • Then it might be related to something other than ignoring the property autocomplete=off.

    Checking chrome://settings/passwords, shows all the intra-/internet sites in question with all of the login+password combinations persisted as desired, for Chrome. For Vivaldi, they are missing.

    No crazy (sub)domains that I am aware of.
    Default keyring for Debian Jessie.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.