Still no sound ...



  • Re: No sound

    I have chromium-codecs-ffmpeg-extra, flashplugin-installer and pepperflash installed (kubuntu 16.04, latest beta version of Vivaldi. I do not have adobe-flashplugin installed. I think I got rid of it when it was giving my software update system (muon/apt) fits.

    Everything at http://www.quirksmode.org/html5/tests/video.html plays fine in Firefox and all of it plays in vivaldi - but with no sound.

    What do I need to fix?

    I read a bit at gist.github.com/ruario/bec42d156d30affef655, but it was mainly confusing.

    I thought that when I upgraded to 16.04, this stuff would work.



  • @josephj11
    Are you sure your sound system not muted?

    That ruario page introduce latest-proprietary-media.sh to download chromium-codecs-ffmpeg-extra. And how to build libffmpeg.so your self.



  • @dLeon Yes. I just opened Firefox on another desktop and all three samples play fine while there is still no sound on Vivaldi.

    I just ran the script and got libwidevinecdm.so but I don't see anything about telling Vivaldi about it.

    The solutions I have found say to install adobe-flash, but that wants to uninstall flashplugin-installer which Firefox needs. This seems to be the only (or at least the next) piece of the puzzle I'm missing.

    I'm still using Firefox because flashgot media along with DownThemAll is amazing at capturing streams. I use Vivaldi for everything else.

    I don't seem to get notified about replies. If I had known, I would have replied to this thread much sooner.



  • @josephj11
    If you have libwidevinecdm.so, Vivaldi suppose to be will create symlink to that library inside Vivaldi installation folder on startup. Vivaldi just use it. We can create the symlink our self if that's not the case.

    Vivaldi like Chromium use PPAPI Flash Plugin. They have nothing to do with Firefox NPAPI Flash plugin.
    The only reason I could think of why your trial to install adobe-flash asking to remove flashplugin for Firefox is, you grab the NPAPI installer.

    As side note, that http://www.quirksmode.org/html5/tests/video.html doesn't even need Flash nor EME CDM.

    Edit:
    Just cross my mind.
    You didn't forgot to check your Volume Manager?
    Some Desktop Environment, Pulseaudio or Distro like/still set to automatically auto mute sound.



  • @dLeon I just made a hard link for libwidevinecmd.so in /opt/vivaldi/lib . That didn't make any difference.



  • @josephj11
    And about Flashgot & DownThemAll.

    I already find/settle with some Chrome extensions combo to replace those Firefox extensions mechanism in Vivaldi & Chromium overall. What still missing is DownThemAll auto naming & target folder support.

    For the first time I'm actually take time to investigate/search for Chrome extensions that replace my addiction to some Firefox extensions so I could use Vivaldi. Say, I think I made it. Now, there's some Chrome extensions I hope available in Firefox or as fast/low resources in Chrome.



  • @josephj11
    That library symlink should go to "/opt/vivaldi" or "/opt/vivaldi-snapshot".
    Your sound problem not related to it anyway nor with Flash availability.



  • @dLeon Thanks. I was just following the instructions in the ruario link. What am I supposed to do instead?

    Since the quirksmode videos don't even need flash, what do they need that I don't have?

    BTW, I moved the .so as you suggested, but as you mentioned, it didn't help.



  • @dLeon Which extensions are you using instead of Flashgot/DownThemAll?

    I have tried screencastify, but it's not exactly what I want.

    Yes, those Firefox add-ons are addictive! I have DownThemAll set to add a number in front of the file name so that if a website reuses a download file name, it never causes a collision.

    It would be useful if we created a list of replacement techniques/add-ons for Firefox add-ons in Vivaldi - just like the sites which show which Linux apps can replace Windows apps.



  • @josephj11 said in Still no sound ...:

    @dLeon Thanks. I was just following the instructions in the ruario link. What am I supposed to do instead?

    Since the quirksmode videos don't even need flash, what do they need that I don't have?

    BTW, I moved the .so as you suggested, but as you mentioned, it didn't help.

    I think your just running around in bigger circles.
    I am using Ubuntu 16.04 and the three HTML5 test videos all play with sound.

    I also just tested by booting to a 16.04 live ISO and installing Vivaldi.
    If you have a live cd/usb test for yourself.
    The first video wouldn't play because it needs the h264 codec.
    The other 2 play with sound.
    Enabled the universe repo, updated sources and installed chromium-codecs-ffmpeg-extra and the first video plays.

    $ apt policy chromium-codecs-ffmpeg-extra
    chromium-codecs-ffmpeg-extra:
      Installed: 56.0.2924.76-0ubuntu0.16.04.1268
      Candidate: 56.0.2924.76-0ubuntu0.16.04.1268
      Version table:
     *** 56.0.2924.76-0ubuntu0.16.04.1268 500
            500 http://ftp.iinet.net.au/pub/ubuntu xenial-updates/universe amd64 Packages
            500 http://ftp.iinet.net.au/pub/ubuntu xenial-security/universe amd64 Packages
            100 /var/lib/dpkg/status
         49.0.2623.108-0ubuntu1.1233 500
            500 http://ftp.iinet.net.au/pub/ubuntu xenial/universe amd64 Packages
    

    As for flash all you need do is enable the partner repo, update sources and install adobe-flashplugin
    If it wants to uninstall other flash packages, let it.

    $ apt policy adobe-flashplugin
    adobe-flashplugin:
      Installed: 1:20170214.1-0ubuntu0.16.04.1
      Candidate: 1:20170214.1-0ubuntu0.16.04.1
      Version table:
     *** 1:20170214.1-0ubuntu0.16.04.1 500
            500 http://archive.canonical.com/ubuntu xenial/partner amd64 Packages
            100 /var/lib/dpkg/status
    

    You said you upgraded to 16.04.
    Might be worthwhile to do a clean install and start afresh.
    I never do release upgrades just so I know any problems I may have aren't caused by the upgrade or my own fiddling/customizing.



  • @josephj11
    I'm out of idea why Vivaldi won't produce sound.

    From my research, most related to PulseAudio or Alsa automute audio.

    Or, others mentioned to have that special libffmpeg.so (which you already had).

    I don't use PulseAudio anymore & just go right to Alsa & sometimes Jack.



  • @josephj11
    This my common downloader arsenal:

    • Turbo Download Manager Helper (Extension).
    • Turbo Download Manager (Apps)
    • Bulk Media Downloader (event listener, catch anything. Produced by same author of two extensions above).
    • GetThemAll Video Downloader (even listener. Never fail me).
    • Imagus (Thumbnail viewer).
    • NooBox (Reverse Image search to some search engines).

    Bulk Image Downloader (on test):

    • Fatkun Batch Download Image.
    • Image Downloader (there's 2 extension with same name. I'm still testing both).
    • Imageye - Image downloader.
    • DownAlbum. (Download Facebook, Instagram, Pinterest, Twitter, Ask.fm, Weibo Album).

    If all fail. Developer Tools. Always success.



  • @CantankRus said in Still no sound ...:

    apt policy adobe-flashplugin

    [email protected]:/opt/vivaldi$ sudo apt-get install adobe-flashplugin
    [sudo] password for bigbird:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following additional packages will be installed:
    adobe-flash-properties-gtk
    Suggested packages:
    x-ttcidfont-conf ttf-bitstream-vera | ttf-dejavu ttf-xfree86-nonfree xfs libnspr4-0d libnss3-1d
    The following packages will be REMOVED:
    flashplugin-installer
    The following NEW packages will be installed:
    adobe-flash-properties-gtk adobe-flashplugin
    0 upgraded, 2 newly installed, 1 to remove and 0 not upgraded.
    Need to get 10.4 MB of archives.
    After this operation, 37.8 MB of additional disk space will be used.
    Do you want to continue? [Y/n]

    That will break Firefox which I don't want to do.

    Clean installs are very nice, but I heavily customize my systems and reconfiguration takes a few weeks sometimes - if I can even remember everything, so I don't do it if I don't absolutely have to.



  • @dLeon Thank you! That's a lot to try out. I will get started.



  • @josephj11 said in Still no sound ...:

    @CantankRus said in Still no sound ...:
    That will break Firefox which I don't want to do.

    No it wont. adobe-flashplugin contains both npapi and ppapi plugins.
    Firefox will pickup the plugin.
    0_1489243733106_038.jpg

    I also heavily customize but I keep notes, install scripts and backup configs.
    About an hour and I'm back where I was but that's your choice.

    This may help you diagnose(ffmpeg "description and name search in synaptic)
    0_1489244333786_039.jpg



  • @josephj11
    adobe-flashplugin package try try to install NPAPI. It contain the library it self.
    flashplugin-installer is only a script to download directly from Adobe site the NPAPI Flash package.
    One can not exist while other installed.
    Vivaldi, Chromium didn't use NPAPI.

    Vivaldi, Chromium will need PPAPI. Notice the difference.
    Installing it won't break Firefox. Firefox didn't even use it.

    Debian (my system) has these packages from 3rd party (debian-multimedia).

    • flashplayer-chromium (PPAPI. Used by Chromium based browsers like Vivaldi).
    • flashplayer-mozilla (NPAPI. Former name was adobe-flashplugin).

    We wonder way too far from main issue aren't we? :grin:



  • @josephj11 -- Hi. Sorry i don't have a solution for you - the other posters are more knowledgeable than me for your problem. I'm only posting this to echo/confirm that whatever your problem root cause might actually be, it's not 16.04 per se. My distro uses a 16-04 LTS base, & all iterations of it [Maui is currently on its 4th Gen] have had no problems with Vivaldi [Stable & SS] overall, & specifically wrt video & audio [once i performed the standard steps already much canvassed for Linux in the forum]. Relatively recently i upgraded to the 16.04.02 HWE package, & with this just like before too, V continues just fine with audio & video... eg, http://www.quirksmode.org/html5/tests/video.html.

    I know none of that directly helps you, but it intimates there's something specific to your OS installation causing this hassle for you [ie, it's certainly not systemic/generic], & therefore, if all other alternatives still don't fix it, the nuclear option [fresh Kubuntu reinstall] might be your best bet... OR, possibly even consider a distro-hop to Maui for a [based on my own prior testing] much more reliable & stable Plasma5 experience than Kubuntu 16.04.
    .......................................................................
    Tower = Maui 17.03 x64 Plasma 5.9.3.
    Lappy = Maui 2.1 x64 Plasma 5.8.4.

    .......................................................................



  • I finally figured this out, but forgot to post back here.

    I got an update to adobe-flashplugin so I tried the tests again. No audio.

    Then, I went into System Settings->Multimedia->Audio Volume->Applications and Vivaldi Playback was muted. I unmuted it and all the tests seem to work fine now. I have sound in Vivaldi!

    I don't know if the flash update made the difference or not. I tend to suspect that pulseaudio got me.

    It gets just a bit weirder. When Vivaldi isn't playing anything, the above volume slider and mute button disappear so you can't see if there is an issue unless it's actually playing at the moment.

    I may have missed this before because I usually click right into Audio and Video->Audio Hardware Setup because that's where I tell it whether to use my notebook speakers/headphones or send audio to HDMI (when it's plugged in).



  • @josephj11 Glad it's working for you. Not trying to make you feel bad, but... https://forum.vivaldi.net/post/85122

    "System Settings->Multimedia->Audio Volume->Applications and Vivaldi Playback was muted" --> Ah yes, that has also occasionally bitten me.

    "I tend to suspect that pulseaudio got me" --> Possibly so indeed. I'm having an ongoing running battle with PA. It doesn't seem to play nicely with http://www.webupd8.org/2013/10/system-wide-pulseaudio-equalizer.html, which very sadly i recently chose to remove [great pity, i loves me extra baaaaaaaaaaaaaaaaaaaaaaass] in hope of increasing my system's audio reliability. Also [though it might be related], PA has been openly hostile to all my VirtualBox VMs for a very long time now [possibly the entire time i've been using a 16.04/Plasma5 distro, as last year when back in Mint 17.3 KDE4 PA + Equaliser + VB VMs all seemed to play happily together]... nowadays, if i boot pc & then launch any of my VMs without having first used audio in my Host OS, then VB sees the PA availability & passes it to the VM, which thus has working audio. If however i have used audio in Host & later launch any VM, VB gets apoplexy, says there's no audio available... & thence in the VM indeed there is none. Given my standard daily behaviour is to be streaming music in Host via Clementine, inevitably all my VMs are starved of sound. It's exceedingly annoying.

    "When Vivaldi isn't playing anything, the above volume slider and mute button disappear so you can't see if there is an issue unless it's actually playing at the moment" --> Yes, in 16.04/Plasma5 this seems to be the standard experience [at least, me too].

    ..............................................................................................
    Tower & Lappy = Maui Linux 17.03 x64 Plasma 5.9.3.
    Vivaldi 1.10.834.9 (Official Build) dev (64-bit)

    ..............................................................................................



  • @Steffie This is kind of off topic, but the equalizer hasn't been supported for some time. That's probably the main cause of problems. I use it for the exact opposite reason you do - I like mostly flat response and my headphones have too much bass. ;)
    I notice the equalizer getting dumped on each successive track and I have to activate it again. I lurk on the pulseaudio list and may ask about it there.

    I have very little experience with VMs, but it does seem like you have to be very precise about how you use them with external resources/hardware or you get unexpected results.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.