autoplay videos - why is not this problem FIXED?



  • I've spent over half an hour searching the V. forum, and Google, trying to find a way to stop autoplay Flash and HTML5 videos. I want a choice, not a flat-out block. I see MANY others looking for the same thing - with suggestions offered which include links to nothing, images of options to check which no longer exist, and all sorts of archane workarounds ...and still the damn problem remains.

    A single webpage with an autoplay video can bring my browser to an utter halt, and my computer with it.

    WHY isn't there an easy way of of this problem?



  • @TomCloyd This has been requested in the feature request thread
    https://forum.vivaldi.net/topic/13217/feature-requests-for-1-7/29?page=2

    In the meantime, for HTML5 videos, there is an extension
    https://chrome.google.com/webstore/detail/disable-html5-autoplay/efdhoaajjjgckpbkoglidkeendpkolai

    And for Flash videos there is a setting (accessed in Vivaldi via Chrome UI)
    chrome://setting/search#flash
    (open the content settings and limit or disable Flash plug-in).


  • Vivaldi Translator

    @TomCloyd
    There's also HTML Content Blocker

    Seem to work.
    More or less like "permission" settings in Firefox.

    Downsides:

    • No whitelist/blacklist.
    • It's a block or don't block option only.

    Edit: (Add on)
    Things to note.
    All extensions or userscripts are problematic on Youtube. Aside down right not allowed to run, they're eventually won't work anymore. Youtube maintainer really diligent to change things.



  • @dLeon Thanks for your response. I honestly think that YouTube isn't the main source of these complaints. Other pages which blast me with main content, not to mention video ads - and gobble up my bandwidth - THOSE are what really matter - at least to.


  • Moderator

    @TbGbe said in autoplay videos - why is not this problem FIXED?:

    And for Flash videos there is a setting (accessed in Vivaldi via Chrome UI)
    chrome://setting/search#flash
    (open the content settings and limit or disable Flash plug-in).

    First, you made a typo (it's "settings", not "setting") and second, in most cases the "search" works only when the UI language is set to "English". ๐Ÿ˜œ I think it's better to provide this URL instead: chrome://settings/content ๐Ÿ˜‰


  • Moderator

    @TomCloyd The feature is not implemented yet.
    i reported this as feature request in 2016: VB-17431 "Option to disable autoplay for video and audio"



  • @pafflick said in autoplay videos - why is not this problem FIXED?:

    First, you made a typo (it's "settings", not "setting")

    You're right, thanks
    chrome://settings/search#flash

    and second, in most cases the "search" works only when the UI language is set to "English". ๐Ÿ˜œ I think it's better to provide this URL instead: chrome://settings/content

    Works for Flash, I agree. But it still doesn't have passwords etc.
    If only that url would work when using mouse gestures ( "Open link in New Tab" ).
    I hadn't considered language differences though, thanks.


  • Moderator

    @TbGbe That was the link for content settings (with Flash being a part of it). For passwords you have this URL: chrome://settings/passwords.

    It's fine for you to use the "search in chrome settings" function when looking for something, but it's not that good for telling others where they could find something since the search queries must match the language of each user browser's UI language settings.

    It may work for Flash because Flash is a name of a product and it's not translated in other languages, but for other queries the search results might be empty.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.