orphaned vivaldi processes cause further troubles



  • hi! I know, this subject was already discussed a few times, e.g. here, here and there, but my case seems slightly different.

    When i close the main browser window, lots of vivaldi-bin processes last in memory. I tried all suggestions in the threads listed above, but no success. (i use the latest vivaldi shapshot 1.7.715.3 on ubuntu 12.04.5 64-bit.) it might not be a problem for me, since they consume 0% cpu and my pc has enough free ram, but if i launch vivaldi again, it has lack of disk-related functionality: the links in bookmarks might have no favicons, stored passwords are not being inserted into the form fields, 'save as' file dialog is not opened anymore, etc.

    When i kill all these processes with 'killall vivaldi-bin' and launch vivaldi again, everything is working fine... Until i close it and restart :head_bandage:
    btw, some of these processes can be killed only on the second pass (example of the terminal output is below). How can i deal with this? :worried:

    [email protected]:/etc/pm/config.d$ ps -A -f | grep vivaldi
    vladymir 5238 1 1 22:38 ? 00:00:16 /opt/vivaldi-snapshot/vivaldi-bin --user-data-dir=/home/vladymir/.config/vivaldi-snapshot
    vladymir 5252 5238 0 22:38 ? 00:00:00 /opt/vivaldi-snapshot/vivaldi-bin --type=zygote --user-data-dir=/home/vladymir/.config/vivaldi-snapshot
    vladymir 5254 5252 0 22:38 ? 00:00:00 /opt/vivaldi-snapshot/vivaldi-bin --type=zygote --user-data-dir=/home/vladymir/.config/vivaldi-snapshot
    vladymir 5313 5254 0 22:38 ? 00:00:01 [vivaldi-bin] <defunct>
    vladymir 5315 5254 0 22:38 ? 00:00:03 [vivaldi-bin] <defunct>
    vladymir 5316 5254 1 22:38 ? 00:00:20 [vivaldi-bin] <defunct>
    [email protected]:/etc/pm/config.d$ killall vivaldi-bin
    [email protected]:/etc/pm/config.d$ ps -A -f | grep vivaldi
    vladymir 5238 1 1 22:38 ? 00:00:16 /opt/vivaldi-snapshot/vivaldi-bin --user-data-dir=/home/vladymir/.config/vivaldi-snapshot
    vladymir 9523 1 5 22:56 ? 00:00:03 /opt/vivaldi-snapshot/vivaldi-bin --user-data-dir=/home/vladymir/.config/vivaldi-snapshot
    [email protected]:/etc/pm/config.d$ killall vivaldi-bin
    [email protected]:/etc/pm/config.d$ ps -A -f | grep vivaldi

    vivaldi details:

    Vivaldi 1.7.715.3 (Официальная сборка) dev (64 бит)
    Версия 841b9a58130b84a3816d42023b714a2127e1e56f
    ОС Linux
    JavaScript V8 5.5.372.32
    Flash 999.999.999.999
    User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.92 Safari/537.36 Vivaldi/1.7.715.3
    Командная строка /usr/bin/vivaldi-snapshot --user-data-dir=/home/vladymir/.config/vivaldi-snapshot --always-authorize-plugins --disable-translate --enable-blink-features=ResizeObserver --flag-switches-begin --flag-switches-end
    Путь к исполняемому файлу /opt/vivaldi-snapshot/vivaldi-snapshot
    Путь к профилю /home/vladymir/.config/vivaldi-snapshot/Default



  • Did you had tried this advice?

    • Open chrome://chrome/settings/search#back
    • Deactivate Continue running background apps


  • @Gwen-Dragon
    There won't be that flag on Linux Vivaldi stable. I can confirm Vladimyr problem. Occasionally, I suffer that too. Need to pkill vivaldi 2 times to clear all left over.

    The closest thing (if I'm not mistaking your point) is this flag;
    Enable Push API background mode Mac, Windows, Linux
    Enable background mode for the Push API. This allows Vivaldi to continue running after the last window is closed, and to launch at OS startup, if the Push API needs it. #enable-push-api-background-mode





  • @Gwen-Dragon
    Ah it's a "setting"!
    Seem not all usual default Chrom* settings easily accessible in Vivaldi settings. This setting reside under "System" which not available in Vivaldi settings.

    Need a few days to confirm if this working or not.
    Thanks Gwen-Dragon.



  • thank folks, I turned off 'Continue running background apps' and 'enable-push-api-background-mode'. no effect. :rage:


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.