Saved passwords get completely erased



  • I have just noticed again that all the passwords I saved with Vivaldi are gone again - I am not sure if this happens when Vivaldi is updated, but it is quite complete if it happens. I had maybe 20 passwords saved, and now there are none at all.

    I am using Vivaldi for Linux. Is this intentional, or what/how is this happening? I really love Vivaldi in almost all other ways, but having to retype all my passwords all the time is quite annoying ;-) Thanks!



  • @iquito said in Saved passwords get completely erased:

    Is this intentional

    No it is not. There is a known problem with Keyring/Kwallet
    https://forum.vivaldi.net/topic/12512/prevent-vivaldi-from-accessing-kwallet/

    But you don't mention using that.
    For what it is worth, I haven't encountered a problem with passwords (on Linux Mint 18) and I have both Stable and Snapshot (updated every time).



  • Have heart - this isn't a generic V-Linux fault, so logically there must be a solution for you [but i acknowledge that "getting there" can be damn frustrating!]. In my V "early days" [V has been my default browser since Feb 2015] password loss was a frequent & galling problem. However, for me at least, V's password retention rate has been very high... albeit NOT perfect... for a long time now.

    To explain that caveat; I do use [willingly] KWallet, & do have it configured to store my V passwords. Having set it up that way, it reliably stays in the background; i've sometimes read of others complaining that it constantly gets in their face, but not for me. However here's the thing; occasionally [very rarely] it seems that KWallet & Vivaldi have a hiccup in their internal comms, such that a V start can [rarely] result in no passwords showing up in V's password manager - i surmise this was caused by some momentary blip where they didn't talk to each other properly - closing V & restarting it usually then fixes it - i stress again that whilst this does happen, for me it is very rare, & seems manageable as explained.

    However, there is a weirder, even more random, also-rare glitch that does sometimes manifest. I can browse to a regular site [typically bookmarked], for which i have previously had V [thus also KWallet] save my credentials; i can see said creds still present in V's P.Man [along with all the others still too]... but perversely the page behaves just as if i had never before entered & saved my info. That is, the fields don't auto-populate [reloading page doesn't help], & when i exasperatedly bang in the info again, V offers to save them for me... despite as i already said the bloody things are already there in the P.Man. I repeat repeat repeat -- this happens but it is very rare.

    General remark: My personal preference is to use V for password storage only for "unimportant" sites, eg, fora, online papers, etc. I never save any financial site's creds in V -- all those reside in my external Password Manager pgm [KeePass2 for years, but recently changed to KeePassX for its better Linux integration/behaviour].

    Good luck.

    .................................................................................................................................................................................
    Tower's SSD = Linux Mint 17.3 x64 KDE 4.14.2 [< 26/9/16]; Maui 2 "Blue Tang" x64 Plasma 5.8.3.
    Lappy's SSD = Linux Mint 18 x64 Xfce+Compiz [< 25/12/16]; Maui 2 "Blue Tang" x64 Plasma 5.8.3.



  • @Steffie said in Saved passwords get completely erased:

    However, there is a weirder, even more random, also-rare glitch that does sometimes manifest. I can browse to a regular site [typically bookmarked], for which i have previously had V [thus also KWallet] save my credentials; i can see said creds still present in V's P.Man [along with all the others still too]... but perversely the page behaves just as if i had never before entered & saved my info. That is, the fields don't auto-populate [reloading page doesn't help], & when i exasperatedly bang in the info again, V offers to save them for me... despite as i already said the bloody things are already there in the P.Man. I repeat repeat repeat -- this happens but it is very rare.

    Ha, this rare weird thing just occurred again this morning, out of the blue. One of my regular sites didn't auto log me in; when i tried to manually log in, i found that V [1.8.755.3 (Official Build) dev (64-bit)] wouldn't populate the site's login credentials box. As per my quote, i can see this site's password details ARE still in V's Settings, & ARE still in kwallet... but V simply decided today it was uninterested in picking up these details & inserting them into the site's fields [worked fine yesterday]; several V restarts didn't help. I therefore manually entered them, & V then helpfully offered to save them... despite as i said, me seeing them already / still there in Settings. Weird!
    ................................................................................................................
    Tower & Lappy = Maui Linux 2.1 "Blue Tang" x64 Plasma 5.8.4.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.