Constant mini crashes/lagging?



  • Hello. Heard there has been some major updates for Vivaldi and decided to have a look. It looks very fresh and overall a bit more responsive WHEN it works, but the problem for me is the keyword WHEN. I seem to get random "system not responding" mini crashes (or rather super long "lags") all the time, about once every 5-15 minutes. They seem to last anything from 10 seconds to half a minute. Not only does the browser get unresponsive but it also "hangs" my system totally, so that you cannot even get the task manager to pop up (with ctrl-sft-esc nor ctrl-alt-del). Nine times out of ten the browser then returns from this void after random time and then works again "fine" for next 5-15 minutes.

    Windows logs from event viewer only shows messages like: "Task Scheduling Error: m->NextScheduledEvent 4296" or "Task Scheduling Error: m->NextScheduledSPRetry 4296" or "Task Scheduling Error: Continuously busy for more than a second" when this happens.

    No other programs (I have zillions, admittedly) give me this type of problem and I have all the other generic browsers (+plenty of rarer ones) and this type of thing does not happen with them.

    I am assuming it has to be somehow GPU-driver related as it totally halts the whole comp and I have this problem mostly happening when playing videos from youtube or other similar sites. It DOES happen sometimes when I just change from whatsapp-web tab to another tab or something similar, so not 100% sure only videos do this. (It's possible thou that there are/were some playing or paused videos when this happens, not 100% sure right now). Often the youtube videos also stop refreshing the video and I can only hear audio for x+10 seconds and then it at some point returns streaming the video. Once again a problem that does not happen with other browsers.

    If anyone has any ideas how to solve this or debug, would be glad to give it a shot.

    My specs: i7-3930K/16gb/Asrock Extreme 11/Sapphire R9 290x/zillion harddisks and whatnot.. OS, Win10 PRO (With insider patches/upgrades enabled). All drivers up to date etc.



  • My pc is a bit "slower" (fx 8320, 8gb ram, r7, sata hdd), however I see slowdowns only when I use a large amount of tabs (more than 40-50, which is pretty normal I say).
    Never had particular windows issues (on 10 pro too).
    You may consider to disable some programs to the boot (if you have a lot) and vivaldi extensions (some are known to cause issues) but maybe the culprit can be one of the last insider updates which can interfere with performance: 10 rtm was faster than 1511 update - which caused me a lot of problems - and 1607 which is the latest and is the one I currently using without problems.

    You can try to disable hardware accelaration in browser to see if it solves.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.