Непонятное поведение браузера...



  • Понимаю, что дело может быть и не в Вивальди, но подобные вещи стали появляться именно после начала его использования. Перерыл уже всё что мог - не помогает. Может быть, кто-то сталкивался. Сначала повторю текст сообщения, которое писал на oszone.
    "После случайного перехода на какой-нибудь сайт компьютер начинает терять интернет. Все приложения постепенно отваливаются, например, Telegram и Skype могут еще некоторое время проработать. Причем компьютер значится как активный, если пытаться обратиться к нему через TeamViewer, но безрезультатно.
    Браузер может выдавать сообщение ERR_NETWORK_CHANGED. При этом локальная сеть прекрасно работает, ресурсы видны. Пинг до любого ресурса проходит нормально, смена DNS ничего не дает, nslookup отрабатывает.
    Пробовал различные команды ресета стэка, очистки dns - не помогает. Смена сетевого интерфейса не помогает - зависает так же. Антивирусы, файрволы, все что можно отключалось и менялось. Проблема решается только перезагрузкой до следующего раза. Повторяется с совершенно разными промежутками времени".
    Штука эта поймана уже на двух машинах, совершенно разных OS, "семерка" и "десятка", в разных сетях. По проводу, по встроенному wifi, по внешнему wifi. Странно, но при подключении через мобильного оператора все нормально работает (используется Yota).
    Вивальди продолжает при наступлении бага работать, в общем не зависает, но ни одну страницу открыть нельзя. Другие браузеры при этом либо запускаются и ничего не открывают, либо зависают намертво. То же касается всех приложений, использующих интернет. Process Explorer не может завершить аварийно ни одно такое приложение - access is denied, причем - vivaldi.exe можно выгрузить все инстансы, кроме одного, в котором при просмотре пишется следующее: номер TID (аналог PID, наверное) и !GetHandleVerifier+0x11180.
    Вдруг кто встречал такое - буду благодарен за совет.



  • @Jonathan119 Вивальди стоит на десятке разных компов, с различной организацией сетей. От Win7 до Server 2012 R2 нигде с подобным не сталкивался.
    После прочтения на ум только какая-то зараза приходит. Особо подозрительно выглядит невозможность завершить процессы. Я б MBAM, ADW cleaner, CureIt и KVT прокатал. Ещё при непонятках с сетью помогало AVZ - восстановление системы. Но как-то очень заковыристо проблема выглядит. Не может ли роутер быть виноват? Или глючит или заражён. В практике попадался такой, который умудрялся рекламу в странички запихивать и редиректить на левые сайты. Глюками роутера почти всё, кроме невозможности завершать процессы можно объяснить.


 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.