How to disable Ctrl+Z keyboard shortcut



  • When you use Ctrl+Z, Vivaldi will reopen last closed tab. I can't dissable it and I need to as when I'm working on online documents and use that command to undo something on my doccument, vivaldi will reopen last tab instead of undoing last action, making some activities buggy and difficult.

    Is there a way to disable it or at least change the command?



  • settings, keyboard, shortcuts, tab "reopen closed tab", remove ctrl-z



  • This puzzled me too at first. It's extremely odd default behavior considering how universal ctrl+z is for undo, especially since that particular shortcut comes preset with two different key combinations.



  • @cecoates Why do you think it odd to undo the last action, which was Close Tab? That is pretty useful, and far easier to remember than Ctrl + Shift + T.

    I have not even got used to Ctrl T to open a new tab yet. (The applications that I use, e.g. Notepad, open a new document with Ctrl + N)



  • It's odd because it overrides the default use of ctrl+z in almost any other program. Even browsers. It'd be like if you overrode other common shortcuts such as ctrl+x, ctrl+y, or ctrl+v. They're pretty universally used for specific, non-tab related actions.

    It'd be like making ctrl+a "save all tabs". Or "ctrl+c" clone a tab.

    If anything, if ctrl+w closes a tab, something like ctrl+shift+w makes more sense to re-open it. Which is generally the pattern the other shortcuts follow (like ctrl+shift+t, since ctrl+t creates a new tab).

    I'm not saying there's no logic in using ctrl+z, I'm just saying it's odd for a default.



  • @Pesala My main reason is that whenever I'm working (for example on google docs) and I want to undo something I find myself reopening a tab instead of undoing my last action which is really disturbing


  • Moderator

    @Total_Obsession I think the issue you're describing has been fixed recently in the latest snapshot, so it should work correctly in the next stable update.



  • @pafflick It has in fact. The issue is now solved and you can now easily disable it from the settings menu. I'm using Vivaldi 1.7.735.11 if I'm not mistaken. ^^



  • Ctrl+Z doesn't work for me. And Ctrl+Shift+T works
    Vivaldi 1.7.735.11 (Official Build) (32-bit)
    windows 7



  • @Stardust I am using that version too but on Windows 10. Good to know that Ctrl+Z isn't working for Windows 7


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.