Page title appears superimposed over tabs

  • Noticed this after the latest update — 1.6.689.40 (Stable channel) (64-bit) — but it could have been there before. Each tab displays the page title, but the page title for the active tab also appears at the center of the browser window, partially superimposed over any tab in the center. Is there any way to remove that completely, or is it a bug?

    0_1482259595490_Screen Shot 2016-12-20 at 10.42.21 AM.png

  • Here's what happens if I move tabs to another area of the screen. Superimposition of page title persists.

    0_1482261947110_Screen Shot 2016-12-20 at 11.23.55 AM.png

  • Moderator

    I've never seen Vivaldi look like that, at least not on OS X 10.11.6. Are you using any Chrome extensions that display the page title of the web site?

    If not, what happens if you enable the "Use Native Window" option in the Appearance section of Preferences, and then restart Vivaldi?

  • "Use Native Window" did the trick! (I don't have any extensions installed other than Lastpass.)

    Thanks @xyzzy!

    0_1482341490329_Screen Shot 2016-12-21 at 9.29.57 AM.png

  • (I'd still love to have that turned off and just have the page titles appear on the tabs, but ... well, I guess that's a feature request.)

  • Moderator

    @Yayzerbeam Enabling the "Native Window" was not really meant to be a fix. I wasn't sure if the overlapping text was caused by an extension incompatibility or if Vivaldi had gotten itself into a weird state.

    The only time that Vivaldi should print the page title in that position is if you have moved your tabs to either the left, right or bottom.

    Could you please try the following:

    1. Go into the Tab Settings and move the Tab Bar to the left
    2. Disable "Use Native Window"
    3. Restart Vivaldi.
    4. Verify that the page title is displayed on top.
    5. Move the Tab Bar back to the top

    Did that get Vivaldi back into a good state?

  • @xyzzy I can verify that this fixed the problem. I didn't ever have "Use Native Window" checked, so i just:

    1. moved tab bar to left
    2. restarted Vivaldi
    3. moved tab bar to top

    And the page title stopped superimposing over the tabs. Thanks!

  • Moderator

    @jakepaint Thanks. I'm glad to hear that you were able to get Vivaldi back into a good state.

    @Yayzerbeam Did this work for you as well? I'm marking this thread as "resolved" unless you have any objections.


Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.