Video playback problems, troubleshooting and solutions on Linux.



  • @Gwen-Dragon

    Thank You so much Lady 🌹 🌹 🌹
    I copied Ubuntu's libffmpeg ( 3.2 MB ) to /opt/vivaldi/lib folder and replaced it with old libffmpeg , Now it plays all videos ..... Thanks A Lot

    But if You want to edit Your script , Only replace the old libffmpeg url ( for downloading ) with a new one .... It works nice in Debian too


  • Moderator

    @Lovelorn_2 Thanks for your feedback. 👍

    I found it, a problem of my script. Forgot how find output the filenames. 😞
    Never tested with folders containing spaces. 😊
    I will fix this tomorrow.



  • @Gwen-Dragon
    hello Gwen,

    I updated to Linux-Mint 19.1 and Vivaldi 2.3.1440.61. Now I have the same problem playing videos.
    How I can install our script?
    Thanks



  • @Gwen-Dragon
    We all owe to You for Your works on this forum , Thank A Lot

    @RWBrf

    Hi , Open Terminal ( Ctrl+Alt+T on Cinnamon , Xfce and maybe Mate too ) enter :
    sudo vivaldi

    some warnings will appear , select two lines which one of them includes " curl " and another " tail " , type sudo with a space and paste the copied lines , Press Enter

    If it's hard for You just act like this video :

    https://help.vivaldi.com/wp-content/uploads/2017/12/add-proprietary-media-linux.webm?_=1

    Download the video and watch it with VLC or SMPlayer or GNOME Media Player or open the link with Firefox and watch it



  • @Lovelorn_2
    Thanks, now it runs.


  • Moderator

    Current problem: the compiled version of libffmpeg is not related to the chromium version. Automated scripts which fetch for Vivaldi will not work anymore. Such inconsistences ... crazy. 😞



  • @Gwen-Dragon

    Hello Lady
    You can rewrite a script that inculdes all Vivaldi warnings for all base distros and fetch the package , unpack it and copy-paste libffmpeg.so library to Vivaldi lib folder .... And then all the novice users will be comfortable ..... They only download Your script , Open the folder , Right click in File Manager and click on " Open Terminal Here " then enter sudo ./vivaldi-libffpeg-install.sh

    Regardless of this version , You have done awesome in this 4 years .....
    Bless You Lady 🌹 🌹 🌹


  • Vivaldi Team

    @RWBrf Just update Vivaldi via APT



  • Hello @ruario! Can you enable VAAPI support for Linux? According to this commit, Chromium already have built-in support for hardware video decoding in Linux. Sadly, it's not enabled by default (gn flag use_vaapi), and Vivaldi also doesn't have this flag enabled. So, if I want to use hardware video decoding in Vivaldi on Linux, I should download Vivaldi sources, compile it with use_vaapi=true, download the exact same official version, install it and replace installed binaries with ones I compiled. And I should do this every time I want to update Vivaldi. Which is not great at all.

    Basically, I just ask you to enable one flag before compiling Vivaldi for Linux. That's all I want. I really love Vivaldi, it fits my setup very well, but I can't use it as daily-driver because of this hardware decoding thing. I'm watching a lot of videos, and if I'll use Vivaldi, it will consume my battery charge faster than Chromium with VAAPI. And I forgot to mention this: hardware video decoding is disabled by default even if use_vaapi was enabled during compilation. VAAPI support will not harm existing Vivaldi users on Linux because it will be optional.

    Thanks!



  • I've just solved the problem on openSUSE 15.0.

    Running in a command line, I noticed this

    No suitable library for HTML5 proprietary media (MP4[H.264/AAC]) was found,
    therefore only open codecs will play.
    
    To add support for proprietary media, issue the following command and restart
    Vivaldi:
    
      curl https://launchpadlibrarian.net/414953672/chromium-codecs-ffmpeg-extra_73.0.3683.75-0ubuntu0.16.04.1_amd64.deb |\
      tail -c+1077 | tar JxC ~ --wildcards \*libffmpeg.so --xform 's,.*/,.local/lib/vivaldi/,'
    

    Suggested command didn't work, but I downloaded that deb file manually, extracted, found libffmpeg.so and replaced the one in /opt/vivaldi/lib.

    After restart all videos play.

    It may be a temporary solution - I suppose it will work until the next update, then I will have to replace the file again.


  • Moderator

    @H0w4rd said in Video playback problems, troubleshooting and solutions on Linux.:

    I've just solved the problem on openSUSE 15.0.
    Suggested command didn't work,

    What was failing? Any error messages?

    but I downloaded that deb file manually, extracted, found libffmpeg.so and replaced the one in /opt/vivaldi/lib.

    And your solution is wrong.
    Just put your extracted libffmpeg.so to folder ~/.local/lib/vivaldi/



  • Apologies if this is out of place. The forum renders in a rather difficult way to follow for me here. I see a lot of discussion about videos not playing but without going back through years of posts my issue is rather than playback is simply terrible and can be reproduced by a specific action.

    In short Tab Tearing sucks in Vivaldi, it's clunky and finicky but if I tear a tab with video it begins to stutter horribly and will not play correctly again until I restart the browser. I've tried re-adding the torn tab to the original window and it does not help.

    Ubuntu 18.04 LTS 4.15.0-50-generic Kernel
    Ryzen 7 2700x
    64Gb DDR 4
    GTX 1060 6Gb nVidia 430.14 Driver (Propri) installed
    Vivaldi 2.5.1525.43 (Stable channel) (64-bit)
    Revision 3524ed3c8fde17898d2f46f303b35e6309d2698d


  • Moderator

    @nPHYN1T3 said in Video playback problems, troubleshooting and solutions on Linux.:

    Apologies if this is out of place. The forum renders in a rather difficult way to follow for me here.

    You can start your own topic would be the best choice.



  • @lamarca Sadly I did start my own thread 2 years ago which never got a single peep. Sadly years later the issues still persist, both the terrible tab tearing and the video stutter. One thing I wanted to add to my post and I suppose I should test is the tearing issue across monitors. I was thinking about maybe the issue is Vivaldi using hardware acceleration perhaps locks it to the originating monitor like a game can/does. When I tab tear to another monitor it then struggles to run in software or with a different vsync etc. Either way I just tried and can't get it to do it either way which makes me wonder if it's an issue that only crops up after the browser has been open/idle for some time.


  • Moderator

    @nPHYN1T3 Every problem is linked to a solution. I support you to start a new topic.

    Best

    Edited: grammar



  • I noticed that video playback (like Youtube) is using much more CPU.
    At first I thought, may be that those last KDE Neon updates made the system heavier, or all those Intel microcode updates made this old hardware (is an old notebook) slower. But then I tested in Falkon and the CPU usage is much, much lower, where it used to be (40-50%).

    I use h264ify to force AVC and block 60fps on Vivaldi, but on Falkon even using VP9 the performance is much better.
    So, the problem is with Vivaldi? What happened, that made the CPU usage increase (70-80%) so much even when viewing SD video?

    EDIT: I love you guys! After I posted here I checked for updates and looks like today's snapshot "solved" the problem?!



  • Thank you all for the links


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.