Can't type into Javascript pop-up



  • Hello there! Not sure yet if this is a bug or if I am doing something wrong:

    I currently have the issue that I am unable to type into a text field within a Javascript pop-up. See here:

    Javascript issue

    Everything looks as expected - I have the typing indicator so that I should be able to type, but nothing happens when I do so. This is the only browser where this happens.


  • Moderator

    It works for me, though I haven't tried it on the website you've shown, since I don't know where to click on it, to get that JS prompt. Have you tried this on other websites? Here is an example.



  • @pafflick

    Thanks for the response. Yes, it does work on that example site. Really strange since I do not have this issue neither with Chrome, nor Edge, nor Firefox on that specific site.


  • Moderator

    I could try to investigate that, but how do I make that prompt to appear on vndb.org?



  • @pafflick

    It's not really the best site for looking into the issue unfortunately - you need to be registered, visit the page of any novel and mark it as "finished". Then you need to visit your profile and go into the "list" tab where this novel should now appear. There you can put a checkmark on it and select "set note" at the bottom which opens the prompt. So quite some steps to do...


  • Moderator

    It looks like the input field of the JS prompt window is out of focus because it was called from a drop-down list (which still has the focus - BTW it's quite an unusual way to call such action and perhaps that's why nobody else had noticed it yet). However - I need to test this somewhere else, to make sure.

    The easiest workaround for this is to call the prompt (by selecting "Set Note"), click RMB (right mouse button) in the prompt's input field and then click LMB to close the context menu and focus the prompt.

    I'll try to create a simple example to send along with a bug report about this behavior. In the meantime (before they'll fix this) you can use the workaround that I just described. 🙂



  • @pafflick
    That works like a charm, thanks for the explanation and workaround! And yeah, kind of a strange way to implement it in any case.


  • Moderator

    I've just reported this as [VB-24280] "JavaScript prompt out of focus when called from a drop-down list". I created a fiddle, where anyone can easily reproduce the bug. Now it's up to the developers. 🙂


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.