Just updated to 1.6.689.34 - Can't mouse scroll



  • This just happened. First thing I tried was restarting PC. Nothing changed. Then I turned off all extensions. Still the same. Dunno what to do now, I will probably try older version and hope for the best.

    Using other browsers / programs everything works normal, having a window in front of vivaldi window allows me to scroll through in vivaldi (like total commander for example). Anyone got an idea what is up?


  • Moderator

    @Ri0Rdian - Can't replicate this. Probably related to an extension you are using.



  • All extensions disabled atm.


  • Moderator

    @Ri0Rdian - Disabling extensions does not take them out of the equation. Suggest you refresh your profile and let us know what happens.



  • @Ayespy

    Tried that, still persists.


  • Moderator

    @Ri0Rdian - totally weird. What sort of system are you on? Is your mouse special in any way? Does it work properly in all other applications?



  • @Ayespy

    Yeah, I find it bizzare too. Everything works as it should, just Vivaldi not. That's why I don't think it has anything to do with the mouse (a4 tech 747H). I will probably try an older version and see if that helps.



  • @Ri0Rdian

    Is there an archive with previous version to download? I might be just blind.

    Anyway, I checked and found 1.5.604.4 on my hdd, installed, everything works ok. If there is a way to download different versions I might go and try each till I find one which introduces this again.

    I'm still puzzled though. Everything works ok, but Vivaldi. Till I updated it few hours ago it worked fine too. Disabling extensions, starting with a fresh profile solves nothing. Going way back in version helps though. All this points to something in the browser messing it up. However, if this is the case, why am I the only one with such issue? Bummer!


  • Moderator

    @Ri0Rdian - The blog https://vivaldi.net/ has links to every snapshot. You can try those and see what happens.



  • @Ayespy

    Got it, thanks. Tried every version going from the most current one to the oldest that worked.

    1.5.676.6
    This is it. Each version after that didn't allow me to scroll via mouse wheel.

    You mentioned that disabling extensions might not be enough. So I assume either something introduced after this updated is causing this or one of the extensions doesn't play nicely with the newer version of the browser even when disabled.

    The most likely (the only ones that seems relevant) cause might be SmoothScroll which as the name implies directly changes the scroll behaviour. Would removing (instead of only disabling) that extension be enough to verify it that is the case?

    EDIT:

    Just noticed, although the scrolling works - while in the settings it doesn't!


  • Moderator

    @Ri0Rdian - Probably. Be sure to at least restart the browser after removing the extension. My standby is a complete profile re-set or new, clean standalone install to ensure access to the bare bones code of the browser without changes. If THAT works, then you know something in your profile or settings is causing the problem.



  • @Ayespy said in Just updated to 1.6.689.34 - Can't mouse scroll:

    @Ri0Rdian - Disabling extensions does not take them out of the equation.

    Why? How?


  • Moderator

    @rseiler - Can't say I know for sure. What I DO know is that in more than one case, a user had a persistent problem, disabled all extensions and still had the same problem.

    Then the user would uninstall some extension or reset their profile, and the problem would go away. re-install the guilty extension, and the problem returns.

    But note, most importantly above, DISABLED all extensions, and the problem persists. REMOVE the offending extension or all of them, and the problem is gone. SOME extensions, I postulate, keep some minor part or function resident in memory, even if they are "disabled" (much as AV apps do), and these can throw a monkey wrench in the works.

    Again, all I have is empirical investigation to rely on, but it's pretty strong evidence.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.