Using short host names in Vivaldi



  • I've had Vivaldi installed for a while but only used it as a secondary browser until this week, I'm now giving it a go full time (or at least as primary). One thing that has really irked me thus far is that if I want to go to an internal site I have to enter the FQDN (server.my.domain) instead of just the short hostname (server/) like I can in pretty much any other browser I've ever used. It's quite cumbersome, and as I've grown accustomed to doing it this way it's annoying to have it search every time I need to go to an internal site. I've gotten used to putting the forward slash ( / ) character after the hostname as for other browsers this seems to indicate it's a site not a search query, but Vivaldi doesn't seem to care. It will instead do a search on "hostname/". If I put http(s):// in front I can get it to actually go to the site, so I think it's just the browser's default behavior.

    I guess what I'm asking is there a way to change this behavior? If not and a dev happens to be browsing here, is it possible to either change the behavior or add the ability to modify the behavior as I have described? For reference I am on a domain, but this would in theory work the same for anyone who is using a private DNS server with custom entries.


  • Moderator

    This is a known problem and open bug.
    Resolving any URL with a raw hostname without probing for DNS may result in security problems a developer said.
    I don't know when issue this will be fixed.

    You can add a / at the end to get the corret URL.



  • Thanks for replying. I don't see how resolving a short name really presents a security problem. It would just be appending the primary DNS suffix (which would be done on the OS level) and loading the page. Adding a forward slash doesn't seem to help at all. I've tried it a few times and it just ends up doing a search for the hostname (including the forward slash) in the default search engine. The forward slash trick is how I would get about it in other browsers. I guess it's good to know that it's at least been reported. Is there anywhere Is there a bug report available somewhere that I can track progress and offer any additional information (if needed)?


  • Moderator

    Have you tried un-checking "Search in Address Field" in vivaldi://settings/search/? I don't have any internal site to test this on, but when I type for example localhost it redirects me to http://localhost/ instead of looking it up on Google, even though the address is empty.

    @peedeeramone said in Using short host names in Vivaldi:

    Is there anywhere Is there a bug report available somewhere that I can track progress and offer any additional information (if needed)?

    Unfortunately it's not available.



  • @pafflick

    I did notice this, and that would probably work, except for that it would then prevent me from actually searching using the address bar, which I do frequently. It's a potential short term solution, though, and one I may end up settling for. To be completely honest, I'd almost prefer to eliminate the search bar entirely and have a single chromium-esqe 'omni bar'. I didn't see an option to do so and I won't loose any sleep over it, but other than the ability to select search provider, if you can search (by default) from the address bar, it makes the search bar a bit redundant.


  • Moderator

    I cant discuss it with you having less knowledge about programming internals.
    The Vivaldi developers said they can not fix the bug yet.
    Thats all.


  • Moderator

    @peedeeramone - If I understand you correctly, you'd prefer to lose the search bar. You can do so, of course, by turning it off in Settings. Uncheck the first option under the Search category, "Show Search Field in Address Bar."


  • Moderator

    Oh, yes! @Ayespy Good hint.
    A workaround is to disable the automatic Search in address field.
    The all "short" hostnames connect.

    And you dont loose a search, you can start a Search in address field with ? .... or shortcut of your search engine.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.