[Resolved] Bug: EXE downloads aren't finished properly



  • I'm using Vivaldi 1.6.689.13 64-bit on Windows 8.1. I have a problem while downloading EXE files. Up until now it was all right, but since last update downloads with EXE file won't finish properly.

    All is left is .CRDOWNLOAD file and it's name won't change after download is finished. I'm not 100% sure but the file itself seems to be damaged somehow as the installers after manually changing the name don't seem to be able to start properly.

    Pls fix.

    I'm using Download Manager but I tried with this addon disabled and the problem is still there so it's probably with the browser itself.



  • Doesn't happen to me, I just tried a couple, any example? Can't be your antivirus?



  • Weird. Now that I checked it it only seems to be about one page.

    The problem happened when I tried to download this file: https://multibit.org/releases/multibit-hd/multibit-hd-0.4.1/multibit-windows-x64-0.4.1.exe

    Doesn't seem to be antivirus. I'm using Avast and it's set up to ask every time there'a a problem and it would pop up on blocking a file. Nothing like that happens. This file downloads normally when using MSIE.

    When I download it using Vivaldi, it fails to complete. When using MSIE it downloads normally. It may be something about this particular server but still Vivaldi is at fault IMO since MSIE downloads the file without any problem.



  • It downloaded OK here


    Specs: AMD A10-6800K, 8 Gb on Win 7 64-bit • Snapshot 1.6.689.13 (Official Build) (32-bit)



  • Downloaded ok, rather slowly, 200kb/s while I normally get 880kb/s, file is exactly 33663568 bytes and completed, .exe extension.


  • Moderator

    Sometimes the Microsoft worldwide download servers (Akamai net) have problems with broken transfers. I got such problems very often, with other browsers, too.



  • Whether it was a but or not, it seems to be fixed in latest Vivaldi. Just a moment ago I tried downloading the same file I had problems and now it downloaded without any issues.


  • Moderator

    @GBozyk Good to hear, that it works now.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.