Vivaldi and ubuntu12.04 (and derivated) does not install



  • Is support for Ubuntu12.04 and derivated ended? I cannot install version 1.5 on it because of dependency issue. (have to tell, if i manually edit the control file inside the deb, removing those dependecies , vivaldi install and works well.)


  • Moderator

    Das sollte doch so klappen:

    sudo dpkg -i  vivaldi-.....deb
    sudo apt-get -f install
    


  • This isn't going to work. That's because VIvaldi is compiled whit some package version not present in the 12.04 repository (For example libfontconfig1 >=2.9.0, but in the repos only 2.8 is available) . Maybe you're using a newer version for compile?


  • Moderator

    That is similar to issue VB-22210 "Snapshot has missing dependencies in Ubuntu 12.04 LTS" and VB-23524 "Cannot install version 1.5 on ubuntu 12.04"

    I fear all dev tests were done with Trusty (14.04LTS) as 14 LTS is the current LTS version of Ubuntu.

    Solution told (by a dev):
    !!! dpkg -i --force-depends vivaldi-snapshot_1.5.658.42-1_i386.deb



  • Understand. But As far as i know, 12.04 is still a supported LTS by ubuntu..... I'll live whit it :)


  • Moderator

    Yes, but LTS means only security related and bug fixes, not enhancements of other libraries.

    LTS is good for running servers but if you use a desktop you should upgrade to the latest LTS version.



  • @Gwen-Dragon said in Vivaldi and ubuntu12.04 (and derivated) does not install:

    That is similar to issue VB-22210 "Snapshot has missing dependencies in Ubuntu 12.04 LTS" and VB-23524 "Cannot install version 1.5 on ubuntu 12.04"

    I fear all dev tests were done with Trusty (14.04LTS) as 14 LTS is the current LTS version of Ubuntu.

    Solution told (by a dev):
    !!! dpkg -i --force-depends vivaldi-snapshot_1.5.658.42-1_i386.deb

    Simply install whit the --force-depends option, put the apt database in a corrupted state, with apt-get complaining about corrupted package, and willing to uninstall vivaldi....
    As told before, editing the Depends file in the deb package solved the issue.....
    The latest package conly hase libfonconfig1 dependency issue.



  • How exactly do you edit the control file and where do I get it? I will update Ubuntu to 16.04 soon but I'd still like to try Vivaldi in 12.04 32bit first.


  • Vivaldi Translator

    @brumman

    I will update Ubuntu to 16.04 soon

    I believe you should do that first instead. It's far more easier than to learn how to get "control" file from deb package and then repacking it. The tutorial to do all the procedures probably fit one or more A4 paper.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.