YouTube video quality settings?



  • Does any one know what it will take to get Vivaldi to respond to the video settings from YouTube? For the most part, when you are watching certain videos you will have the option to change the settings 'quality.' However, there are a lot of times that it will default to the lowest quality settings with no options for better quality. If you view the same content in Chrome all the settings will be available. I just updated Vivaldi [1.6.682.3 (Official Build) dev (64-bit)] with hopes that the issue will be resolved. Is it something that I am doing wrong? Any help to an answer would be greatly appreciated!



  • What distro are you using?

    On Ubuntu MATE I have full control over video settings on any video I have tried using Vivaldi 1.5.x series.

    Cheers,

    Jeremy



  • I am using Vivaldi 1.6.682.3 (Official Build) dev (64-bit) with Solus 1.2.1 64 bit OS. It almost seems as though it is getting better, but the issue is still there. When Vivaldi do not give higher quality for viewing I switch over to Chrome.



  • Hi, no problems on Opensuse Leap 41.1, 42.2 64 bit at different systems.
    I am use the latest snapshot.

    Cheers, mib



  • @diahron said in YouTube video quality settings?:

    Does any one know what it will take to get Vivaldi to respond to the video settings from YouTube? For the most part, when you are watching certain videos you will have the option to change the settings 'quality.' However, there are a lot of times that it will default to the lowest quality settings with no options for better quality. ...

    Please provide links to videos that other Linux users can check for you.

    Also mention your internet connection speed.



  • I agree on a test link would be helpful. Solus might have some missing piece that Vivaldi is looking for, but without a bit of testing I am not sure. So have a video link that the community could check on?

    Also have you checked if HTML5 or Flash is being used when playing YT video?

    Cheers,

    Jeremy



  • Try this link: https://www.youtube.com/watch?v=sBluMtsvCq4&list=PLHHEH8A1pSa7xks_bIXzO7geTD9s6GXoh&index=1

    The link above worked like a charm. Try this link:
    https://www.youtube.com/watch?v=6Pco0nJGpnU

    What's going on? The first link will work, no problem. The second link, which comes from YouTube subscription of 'Bootstrap' linked in at: https://www.youtube.com/channel/UCpunnZHMhSFrt5U3I4E5lyA
    will not give quality adjustments.

    If you try the last two links, you should get the same result when trying to view the content. The first should work. If you open either of the last two in a diff browser they should work.



  • @diahron Well I tried both links using Vivaldi 1.5.658.44 running on Ubuntu MATE and I got the video settings. I even tried changing the settings on both links and it worked fine.

    Now I am using the HTML5 player. Are you using the Flash version? Since Flash is a security nightmare I use Vivaldi (my primary browser) with out Flash and switch to Chrome if I need to use something in Flash. This is rare as generally I just skip content that forces Flash. I have no respect for that horrible "standard".

    Cheers,

    Jeremy



  • I checked the Vivaldi about and I see Flash 23. Do that mean that I am using the flash version. If so, how do I change it? And if not, where from here? With the exception of this little quirk, Vivaldi works great.



  • @diahron When watching a YT video right click on it and see if you have a line that says "About the HTML5 player". If so you are using HTML5. However if you see anything about Flash or Shockwave then that is probably your issue.

    The only way to test would be disable Shockwave/Flash by typing in "vivaldi://plugins" into the URL/address part and clicking on "Disable" for Shockwave/Flash.

    Now go back to YT and reload the page and try a previous video that didn't provide settings.

    Cheers,

    Jeremy



  • @diahron said in YouTube video quality settings?:

    I checked the Vivaldi about and I see Flash 23. Do that mean that I am using the flash version. If so, how do I change it? And if not, where from here? With the exception of this little quirk, Vivaldi works great.

    Another check Youtube HTML5
    For me all options are supported (Mint 18).


  • Vivaldi Translator

    Tested www.youtube.com/watch?v=6Pco0nJGpnU

    My result:
    Vivaldi: 480p only
    Opera: 360p only
    Chrome: 144p-720pHD ???
    Firefox: Same with Chrome.

    They all in HTML5. Except explicitly asked, Youtube never gave me the Flash video version for long time, even if Flash installed. All browsers above are the latest.

    Anyway, too make sure Flash is disable; visit vivaldi://plugins. I'm sure you could figure it out after that page show.



  • @dLeon said in YouTube video quality settings?:

    Tested www.youtube.com/watch?v=6Pco0nJGpnU
    My result:
    Vivaldi: 480p only
    Opera: 360p only
    Chrome: 144p-720pHD
    Firefox: Same with Chrome.

    I get 144p-720pHD in Vivaldi (1.6.687.3 64-bit) for that video. :confused:


  • Vivaldi Translator

    Confused. I dig a little bit. Check "Stat for nerd" on video.

    In Vivaldi and Opera, the video is delivered in video/webm format. In Chrome and Firefox is in video/mp4, maybe h264. But, does Vivaldi already support h264?

    Anyway, the webm format seem re-produced in low quality only.
    So we can rule out problems like Distro or Flash/Plugins.

    Edit: Just an add in. Based on https://bitmovin.com/browser-capabilities/ Seem Vivaldi only support video/webm (currently).



  • I upgraded yesterday to latest stable "1.5.658.56 (Stable channel) (64-bit)" and I have all the options for the videos including HD.

    Also checking the "Stats for nerds" shows the second video is "Mime Type: video/mp4; codecs="avc1.4d4014".

    So on my Ubuntu MATE 16.04 rig running Vivaldi 1.5.658.56 I am getting all setting choices and the video is playing as mp4.

    So it still could be a distro issue (or missing library) or perhaps a 1.6.x issue. I also tested 720 and 480 in full screen and there is a difference. So Vivaldi on my system isn't just claiming HD without changing.

    Cheers,

    Jeremy


  • Vivaldi Translator

    I'm out of idea.
    Debian sid and same Vivaldi version here. If plugins is the problem; Mint suppose to be win. It a slap anything as long is work type of distro. Far more than Ubuntu.
    Cheers.



  • @dLeon It sounds like your system doesn't have libraries to play MP4.

    Google Chrome is a different beast as Google pays fees to include some software that isn't in their open free version. So that is most likely what is happening.

    Ubuntu MATE allows an easy one click install of common codecs. Still I have installed both VLC and MPV and I am guessing one of those downloaded some extra libraries needed for MP4's at the system level.

    I am just guessing at that but it would make sense. My system clearly has some library(ies) that seem to be MIA on yours.

    Cheers,

    Jeremy


  • Vivaldi Team

    @dLeon said in YouTube video quality settings?:

    Tested www.youtube.com/watch?v=6Pco0nJGpnU

    My result:
    Vivaldi: 480p only
    Opera: 360p only
    Chrome: 144p-720pHD ???
    Firefox: Same with Chrome.

    They all in HTML5. Except explicitly asked, Youtube never gave me the Flash video version for long time, even if Flash installed. All browsers above are the latest.

    Anyway, too make sure Flash is disable; visit vivaldi://plugins. I'm sure you could figure it out after that page show.

    I get up to 720p in Vivaldi 1.6.689.13 and do not have any problems switching on any YouTube video.



  • @christian Out of curiosity distro? Thanks!

    Cheers,

    Jeremy



  • @cleverwise said in YouTube video quality settings?:

    @christian Out of curiosity distro? Thanks!

    Cheers,

    Jeremy

    no problem here either on debian stretch using https://gwendragon.de/repo/linux/vivaldi/vivaldi-libffmpeg-install-1-0-6-BETA.sh (with -F) and no flash.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.