How to set Vivaldi as default browser in Windows 10



  • It never shows in the drop down that window provides for me in the windows settings. It only prompts me with other browsers and to search the Windows Store for another browser


  • Moderator

    @oondy - How do you have it installed? Conventional? Standalone? Standalone on an external drive? If standalone, did you check to box to register it on install? Did you check the checkbox in Vivaldi Settings to set as default? (that should have taken you to the Windows dialog to do so)



  • @oondy
    One way to approach it: Control Panel\All Control Panel Items\Default Programs\Set Associations. Then select the extension. Then "Change program..." button. Then "Look for another app on this PC." Did you try that?

    Oops, that didn't work for .url files like I expected it would! Sorry!



  • @oondy
    Did you try searching on "default browser" in "Settings"? When I do that in Win 10 Pro 64-bit, you get a "Choose a default web browser" result, which when clicked on takes you to the "Choose default apps" page, which includes a "Web browser" setting, which when clicked on shows Vivaldi in the list. Choosing Vivaldi was successful for me just now.



  • @oondy
    You can also go to the windows Settings app, click the link at the bottom labeled something like "define default values per application", and see if Vivaldi appears in the list on the left of the window that opens.
    In that case, you can select it and either apply all defaults (first link at the bottom of the window) or choose which defaults to apply (second link). In that case, the most important to check are HTTP and HTTPS protocols, but you can also check supported filetypes.
    Once you did that, Vivaldi should appear as the default browser in the Settings app.

    (I noticed that just selecting the default browser in the Settings app, as @vivabrowser mentioned, did not always work on my machines, it didn't always set all values correctly (in my case HTTPS was not set) so the old default browser remained displayed in the Settings app; Windows 10 x64 1067. Probably a Windows bug.)

    Note : this may not work if you installed Vivaldi as standalone and it didn't create registry keys (it's been a long time since I did a standalone install, so I'm not sure whether it does create registry keys or not).



  • @IcePanther said in How to set Vivaldi as default browser in Windows 10:

    You can also go to the windows Settings app, click the link at the bottom labeled something like "define default values per application", and see if Vivaldi appears in the list on the left of the window that opens.

    You mention the Windows "Settings app", by which I presume you mean the Windows "Choose default apps" page of the new Settings app. Is that correct? In any event, I'll mention that the choices there that relate to your post are "Choose default apps by file type", "Choose default apps by protocol", and "Set defaults by app". The last one, which I'm thinking is the one that you're referring to, lands on the old Windows Control Panel "Set your default programs" control panel.



  • @Ayespy yes it takes me there but when I click the drop down menu to choose Vivaldi it only shows me other browsers I have which I don't use anymore



  • @Ayespy How do I know if I have installed it conventional or standalone?


  • Moderator

    @oondy - If it's in the users/(yourusername)/appdata/local/Vivaldi directory, it's probably conventional. In that directory should be both the Application and User Data files. If you didn't select any advanced options on install, it's probably conventional. If it's in any other directory, it's not conventional.

    If you installed it conventionally and Windows 10 is blocking you from setting it as default, (Win 10 makes me crazy with this garbage. Usually it behaves, but 1 out of 100 or 1000 times, it inexplicably pretends there's no such thing as Vivaldi on the system) there are a couple of tricks we can try to force it to register Vivaldi.



  • I've also encountered this problem while installing Vivaldi on a family member's computer. Windows 10 is really stubborn in trying to force you Microsoft Edge down your throat.

    Even using Vivaldi's settings option to register as default was not working properly. I can't really remember any more what I ended up doing, but I think a simple restart after installing solved it.

    After restarting Vivaldi started showing up in the menu and I could register it successfully.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.