vivaldi freezes whole system (x230, disc usage goes to 100% with ssd)



  • Sometimes vivaldi (snapshot) starts using all disc and whole system gradually (quite fast) becomes unresponsive until it freezes If I don't kill vivaldi fast enough. It appears to me that it happens randomly (with many open tabs, with a few open tabs, while writing, while using different app...) I've been using firefox and opera before with no problems, chromium also seems to work fine, but I'm not using it often. Perhaps I'll switch to stable version but I don't have much hope with that. I'm using vivaldi for a few weeks and I love it.

    vivaldi-snapshot 1.5.676.6-1

                   -`
                  .o+`                 [email protected]
                 `ooo/                 OS: Arch Linux 
                `+oooo:                Kernel: x86_64 Linux 4.8.11-1-ARCH
               `+oooooo:               Uptime: 2d 5h 35m
               -+oooooo+:              Packages: 1518
             `/:-:++oooo+:             Shell: zsh 5.2
            `/++++/+++++++:            Resolution: 1366x768
           `/++++++++++++++:           DE: KDE5
          `/+++ooooooooooooo/`         WM: KWin
         ./ooosssso++osssssso+`        GTK Theme: Breeze [GTK2/3]
        .oossssso-````/ossssss+`       Icon Theme: breeze
       -osssssso.      :ssssssso.      Font: Noto Sans Regular
      :osssssss/        osssso+++.     CPU: Intel Core i5-3320M CPU @ 3.3GHz
     /ossssssss/        +ssssooo/-     RAM: 2723MiB / 3655MiB


  • Hi, this sometimes happen with corrupted "Top Site" files, simple delete them.
    After restart they are recreated but you loose speeddial icons, F5 reload them.

    Cheers, mib



  • Did as you sayed, now I'm gonna hope it worked
    Thank you!



  • @SelfishJelly I would recommend also getting Click and Clean from extensions or one of the cache and history cleaners. Keeping it clean keeps it fast and stable. Also more RAM.



  • so, deleting "top site" did not help, I've tried deleting whole cache before with no help.



  • @SelfishJelly said in vivaldi freezes whole system (x230, disc usage goes to 100% with ssd):

    so, deleting "top site" did not help, I've tried deleting whole cache before with no help.

    Just to clarify, there are 2 files (see Help/About for profile location):
    "Top Sites" and "Top Sites-journal"
    did you try deleting both?
    Warning about Bookmarks Icons still applies.

    This has been a successful workaround for many users - but it is only a "workaround".

    Also see Abnormal IO activity



  • I had the similar problem when AHCI was disabled in BIOS/UEFI settings.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.