A general Linux issue…



  • Hi, everybody. Well: I've stumbled into Vivaldi by a pure coincidence. After taking a look at the "[i]who is who (behind the scenes)[/i]", I've quickly decided to give it a try. And here we are: both on Linux and on Windows (7), [b]it works really well[/b] - despite its apparently being still quite ripe (e.g.: memory-wide, it seems quite "[b]hungry[/b]"; and, in the "configuration / setup department", it's still very "[i]immature[/i]", missing - as far as I can see - some of the most important setup options the competitors already have implemented: for example, the "[i]ask for saving passwords[/i]" option, or a "[i]clear the offline contents[/i]" button). Nonetheless, I have [b]ONE TRUE[/b] criticism to make: Linux, OK, we have both the .rpm (even if - as usual - [b]only for Fedora[/b]. And [b]openSUSE?[/b] :dry: ) and the .deb... but... But it's evident that you have packaged the browser [b]ONLY[/b] for Ubuntu (/Debian). Actually, [code]dpkg -i Vivaldi-TP-1.0.83.38-1_amd64.deb[/code] works without any hassle, while (both under Fedora 19/20 and under openSUSE 13.1) [code]rpm -i Vivaldi-TP-1.0.83.38-1.x86_64.rpm[/code] returns [code]error: failed dependencies / lsb >= 4.0 necessary for vivaldi-stable-1.0.83.38-1.x86_64[/code] [b]What?![/b] :blink: openSUSE 13.1 and Fedora 20 aren't "lsb >= 4.0"-compliant? Or, what on earth are we talking about? I can't help avoiding the usual, annoying impression that you (as well as Opera's developers, and those of [b]a lot[/b] of other programs) by now tend to implicitly use the ([b]FALSE[/b]) identity "Linux = Ubuntu"... which makes for an implicit discrimination among Linux users... Sorry :(



  • Have you tried the fix suggested here?

    yum install redhat-lsb
    


  • Have you tried the fix suggested here?

    Yes, right now: and IT WORKS! :)

    It would seem that (K)Ubuntu 14.04 is more LSB-compliant than Fedora 20 or openSUSE 13.x. So far, so good :P

    Anyway: thank you, gray :)



  • For the record, RPM is also used by Mandriva and forks or derivatives thereof (Mageia, PCLinuxOS). And yes, it installed just fine here.



  • On opensuse13.2 I did the install via "zypper in vivaldi" after copying vivaldi from /tmp to /Downloads and getting this have integrated to the repos.
    Smooth install, zypper asks for dependencies, resolve them, vivaldi is on disk and works quite well



  • Actually, I was quite pleased to see the package actually was for Debian.
    This is unlike Otter, which only builds for Ubuntu :sick:


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.