Vivaldi can't be good with Jitouch(and moom) in macOS 10.12.1 Sierra



  • ONE DRIVE GIF LINK:
    https://1drv.ms/i/s!Al4BOBkjHQRQg-pf4rl_dS4Cym-zUg
    0_1480247140375_J.png
    please see this gif link(cuz it's too big 11.7M),when I open 的 the vivaldi ,the jitouch isn't working well ,but other apps all work well with jitouch,like finder.... then I try to switch the full screen mode in vivaldi ,then the jitouch is working well on vivaldi,and title bar appeared the tab name ,so totally speaking,there are 2 bugs here:

    1.open vivaldi ,the jitouch isn't work well,except I switch the full screen mode,then jitouch gonna be well

    1. when I use vivaldi and jitouch same time,switch the full screen mode,the title bar will appeared the tab name

    BTW:
    the same problem is in moom with vivaldi,I have to switch the vivaldi to full screen mode first,then the moom'll be working normal!

    0_1480247233379_M1.png
    0_1480247242408_M2.png

    so,please fix them ,thanks !!



  • nobody?here?who can solve this problem?



  • You probably should contact the jitouch developers about it. Does it work in chrome or opera? Doesn't seem like a vivaldi issue.



  • Why I think these bugs are from vivaldi?
    Cuz jitouch is working well with others(such as chrome,finder,opera,third-party apps...), so I have to feedback them here...


  • Moderator

    See these two existing threads about Moom:
    https://forum.vivaldi.net/topic/7125/moom-and-vivaldi
    https://forum.vivaldi.net/topic/9129/problems-between-vivaldi-and-moom

    If you turn on Vivaldi Preferences->Appearance->Use Native Window, Moom (and probably) Jitouch will work as expected, but Vivaldi will also look less pretty then and tab groups may no longer work.

    When Use Native Window is not turned on, Moom seems to work in one window but not the others.

    I think the problem is that both sides do something slightly hacky: Moom/Jitouch modify the behavior of the standard system fullscreen buttons and Vivaldi creates it's own windows control buttons, unless Use Native Window is turned on. When those two things are combined, the problem emerges.

    I do all my window management with Keyboard Maestro, because that is much faster, so I don't have a lot of experience with Moom (and none with Jitouch), but at least in Moom, there seems to be a way to trigger the window resizing grid via a keyboard shortcut. Maybe that could be a feasible workaround.



  • I know what the way(Use Native Window) to make the moom working ,but the UI is too old and ugly,so I don't think it's a good way to solve this problem,and the other way what I said switch full screen mode one time,this problem also can be solved ,but as I said this is a BUG, I really hope vivaldi team can fix it and make moom working well with vivaldi in a normal user situation(turn off the "Use Native Window"),tks a lot!



  • nobody can fix it?


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.