Vivaldi crashes when starting (v1.5) - unstable and stable release



  • Some weeks ago I changed from stable to unstable release to get version 1.5 because of login problem with LastPass. The problem with LastPass was solved but sometimes Vivaldi crashes right after starting.

    When Vivaldi crashes only a white quick-start tab is shown. All of the links on quick-start are gone. Also LastPass is not asking for credentials. If I click on the tab title all links are shown but still Vivaldi behaves strangely. If I want to open a link into a new tab nothing happens. After clicking again on the link for opening in a new tab suddenly two tabs with the same website are open. Also I have to manually login into LastPass.

    If I close Vivaldi and look into taskmanager there are still 7 processes running of Vivaldi. If I shut them down manually all of my extensions break down. If I restart Vivaldi same behavior is often shown. I have to restart Vivaldi a few times again to get a fully working Vivaldi. Often I have to restart my computer.

    This crashing bug is still there in stable release of version 1.5 (1.5.658.44). I'm using 32 bit installation of Vivaldi.

    Is there any chance for you to fix this problem? Can I send you may be log files to search for an error?

    Hope to get rid of this problem because it's really annoying and I thought about changing my browser again away from Vivaldi...



  • @PoooMukkel I would suggest you try with a clean profile as it sounds like yours has been garbled by something.

    See https://help.vivaldi.com/article/full-reset-of-vivaldi/



  • I will try. Just export the bookmarks and import them. All the other stuff I will do a clean install. Thanks a lot!

    After trying some time I will come back to you if it works or not. :)



  • @PoooMukkel said in Vivaldi crashes when starting (v1.5) - unstable and stable release:

    All the other stuff I will do a clean install

    Not a clean install. Simply rename the profile folder as described in the link I gave you.



  • I did a clean install and thought till now that everything works just fine. But the problem still exists... I opened Vivaldi and saw a white quick start website with no links. LastPass didn't ask for credentials. Same problem as before making a clean install. :(

    Any further idea what I could do? May be it is a real bug and has to be fixed by developers?



  • No further ideas to resolve my problem? Problem still exists... May be should I try the newest snapshot? I don't know... :(



  • @PoooMukkel As I said before - a clean install will not reset everything.

    As you are the only one reporting this problem, I don't think it is Vivaldi bug as such. Crashes can be caused by extensions, bad bookmarks data etc.

    Please try with a clean profile (no extensions, bookmarks etc.) as described in the link I gave. By simply renaming the Profile folder you can check if the problem persists or not.
    Your bookmarks etc will still be in the renamed folder for backup.



  • I can verify this, seems to be a problem with the "Preferences" file at "Vivaldi\User Data\Default"



  • @TbGbe Ok. I will try with renaming the default folder... Thanks!



  • @JanPetterMG And why do you think that the prefernces file could be the problem?



  • @TbGbe I can try a clean install but I just want to use my settings. So I will make screenshots of the settings I used and would set them in clean install. But what if the problem lies in the settings like "JanPetterMG" said some days ago??



  • @PoooMukkel

    Nope. Just close Vivaldi, rename profile folder and then restart Vivaldi to test.

    This will make sure ALL settings are reset for your test.
    Another Install will NOT do that as preferences could be preserved across uninstall/re-install.



  • @TbGbe Did the reset (delete the profile folder). But there's all away now. Vivaldi is "nacked" without any settings, bookmarks and extensions. Tried some times to open Vivaldi and it works. But the problem doesn't occur permanently. I have to use "nacked" Vivaldi for some days to get the crash. But without any data it makes no sense for me to use Vivaldi.
    Do I have to import my bookmarks and make some settings?


  • Moderator

    @PoooMukkel said in Vivaldi crashes when starting (v1.5) - unstable and stable release:

    I have to use "nacked" Vivaldi for some days to get the crash.

    So, Vivaldi crashes even when you use clean profile? Have you installed any extensions after resetting your profile? In my experience, most of the unusual problems come from extensions.

    You can use your new, clean profile for restoring all of your settings manually (importing bookmarks, passwords etc.) and installing extensions as a last step.

    From what I heard it's not good to jump between stable releases and snapshots using the same profile, as it may cause some unexpected issues (and perhaps it happened in your case). You should rather install another instance of Vivaldi as a standalone app, if you want to switch between Stable and Snapshot releases.



  • @pafflick said in Vivaldi crashes when starting (v1.5) - unstable and stable release:

    So, Vivaldi crashes even when you use clean profile?

    No. I used the clean profile for some minutes and tried opening "naked" Vivaldi some times and it didn't crash. I think I have to use this version for some days to find out if the problem is solved.

    You can use your new, clean profile for restoring all of your settings manually (importing bookmarks, passwords etc.) and installing extensions as a last step.

    I did this with a former completely clean installation of Vivaldi. I imported my bookmarks, set all my settings and installed my 5 extensions. And the crash came back.

    From what I heard it's not good to jump between stable releases and snapshots using the same profile, as it may cause some unexpected issues (and perhaps it happened in your case).

    Yes. This was my case. I tried stable and unstable releases of Vivaldi. But now I only use stable release with a completely new and clean install. And the problem is still not solved.



  • @PoooMukkel said in Vivaldi crashes when starting (v1.5) - unstable and stable release:

    I imported my bookmarks, set all my settings and installed my 5 extensions. And the crash came back.

    Did you check for crashing after each step?
    As your "naked" version did not crash, some of the settings must be the cause.
    You should test after each modification.

    Leave your extensions until last and then check ONLY 1 extension at a time.
    Hopefully, you will identify what is causing the problem that way.



  • Like I already wrote the problem is that this problem not occurs permanently. I have to wait for some days after every step. And that's really hard to use Vivaldi without all my settings and extensions... :(



  • @PoooMukkel It might help if you tell us which extensions you use, someone may have a clue as to possible problematic one(s)?



  • @TbGbe That's an idea. Those are my extensions:

    • Adblock Plus
    • Bitdefender Wallet (not active)
    • Enhanced Steam
    • LastPass: Free Password Manager
    • Tampermonkey
    • Xmarks Bookmark Sync

    Yesterday I already deleted two of them (Bitdefender Wallet & Enhanced Steam) but some minutes ago there was the crash again.



  • @PoooMukkel Hmm, I don't use any of those so can't be much help.
    However (based on no knowledge) I would suspect Tampermonkey - simply because Vivaldi is written using JS and CSS.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.