Address bar auto-complete



  • Has anyone noticed the difference of address auto-complete between Vivaldi and other browsers? I mean how the browser suggests possible entries with highlighted blue text as you type in the address bar.

    In some browsers like Firefox, it will suggest only domain names if you just started typing. But with Vivaldi it shows the whole URL no matter how long it is. And here is an example when I tried to visit Google Translate:

    alt text

    This is quite annoying when visiting websites which use GET method on some of their forms, or when trying to go to the homepage of a blog site but the browser automatically takes you to some random article.

    Can this behavior be configured or are there some add-ons which can change this?



  • Hi, disable Address Auto complete in Address Bar Settings.

    Cheers, mib



  • @starfish_head It suggests you the complete URL - one that you visited already (or the one that you have in your bookmarks), not just some "random" ones. But you should probably post this as a feature request here.



  • Hi, I Completely agree with you. It is really annoying, and I had to delete my browsing history many times because of this.

    Because I had used a link to some deeper article instead of the homepage for the first time as I had visited some of my favorite web pages.

    Just make it an option, Vivaldi. "Always autocomplete only to the root domain"



  • @RRR13 said in Address bar auto-complete:

    @hixaxon It doesn't have to be an option to always complete to the root domain. It could just make the root domain the first autocomplete suggestion. I don't see how this would bother anyone.

    is there still no way to do this to be root domain only?



  • https://forum.vivaldi.net/topic/6075/bundle-js-modding
    until it's fixed internally, you can use this mod



  • @RRR13 said in Address bar auto-complete:

    @marcosmobley Not that I know of, BUT there is one thing you could do to get rid of your problem.

    In the autocomplete list there is a section called "Typed", which has priority over the section called "History".
    If you type once the full address "translate.google.com" and navigate to it, it will be placed in the Typed section and it will be the first to be used next time when autocompleting.

    For example, I have once typed "translate.google.com" and now, when I type "trans", I get "translate.google.com". Also, I have never typed "google.com", so I don't have it in the Typed section. That's why when I type "goog", I get some long entry from the History section.

    You only have to do it once and it should really solve your problem.
    Let me know if it works for you.

    problem is i have to copy/paste urls constantly...so i end up "typing" even though i didnt :( thanks anyway



  • @RRR13 said in Address bar auto-complete:

    @marcosmobley Even so, doesn't the shortest autocomplete option come first? That I didn't try, so I don't know.
    For example, if you have both "translate.google.com" and "translate.google.com/some_crap_I_translated_someday", which one has the priority?
    I hope the shorter one does.

    you would hope. so would i. doesn't happen, though. seems to decide based on which one you've "typed" in the most...or i don't know how it decides. never seems to be the short one, though.



  • This is SO annoying. They had it working for awhile. If you went into Settings/Address Bar/Address Auto-Complete - you check "Enabled" but don't check "Always Prefer Bookmarks". Then it worked perfectly. It would only give you the root domain as you began to type.

    But now for some reason it's not working at all. Whether "Prefer Bookmarks" is checked or unchecked it's auto completing a whole long URL. And it's a different URL depending on whether Prefer Bookmarks is checked or unchecked!

    I really wish they would get this fixed because it's so darn annoying it's actually going to force me to another browser. They may not think it's a big deal but if every time you want to go to Google or Youtube or Facebook, you end up having to type in the whole domain name and then press the delete key to delete the rest of the unwanted URL - it ends up taking a LOT of extra time to get to a web page.

    The purpose of auto-complete is to save time and this ends up taking a lot more time!


  • Moderator

    @jonYork: I'm not sure they EVER had "domain-only" working, but it is a goal.

    Edit: I take that back! It's working perfectly right now, in all three of my different builds that I have installed!



  • @jonYork I had the same problem with the newest 1.8 snapshot (see my post here).

    I installed 1.7 in a different directory to use until it's fixed in the snapshots and it's now correctly auto correcting to just the domain (as long as I've visited it before).


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.