Office 365 / Exchange Online Error



  • I just switched to Vivaldi yesterday and I'm experiencing the same issue with our on premises ECP (Exchange 2016). Having to go back to Firefox for Exchange admin stuffs for now. ­čśĽ



  • @Mogle I'm 99% positive the problem is with Vivalidi. I don't have the same problems with Chrome, and the problem came up after a version update to Vivaldi.



  • @digitrance
    It's already confirmed with bug number
    https://forum.vivaldi.net/post/85177
    Some post above you @Gwen-Dragon also confirm it some time ago.

    I expect no ETA for fix. There's also other people bugs/requests plus original planned target features in waiting list.



  • Problem corrected in 1.8.770.25.

    Still present in 1.7, so it wasn't a back-end fix by MS.

    But was it an intentional or incidental fix on the part of Vivaldi? Doesn't matter, but curious.


  • Moderator

    @rseiler 1.8 includes an intake of the more recent Chromium build. It could be related to that.



  • @iAN-CooG The problem happens whether I have extensions enabled or disabled.



  • Still broken in 1.8.

    0_1490795881169_2017-03-29 08_47_07-About Version.png


  • Moderator

    @digitrance I'd like to test those issues by myself and offer my help (as much as I'm capable of), but unfortunately, I don't have access to any of the websites on which this issue occurs. I hope that at least one of the Vivaldi testers/developers have access to one of these sites - otherwise, it might be difficult to address that issue...



  • @digitrance said in Office 365 / Exchange Online Error:

    Still broken in 1.8.

    That's not the right way to put it: "broken again" is a better way. Look a couple posts up. It was working back then, but I tried it just now with 1.8.770.46, and it's not.

    So, which is more likely, that something changed on the back-end multiple times or that it was purely accidental that it ever worked? I think the latter.

    But, look a few more posts up: it has been well-reported, so Vivaldi knows about it.


  • Moderator

    You should report the bug to Office 365 website owner Microsoft. https://support.office.com/home/contact



  • @Gwen-Dragon said in Office 365 / Exchange Online Error:

    You should report the bug to Office 365 website owner Microsoft. https://support.office.com/home/contact

    Good idea, but knowing MS that's going to lead nowhere or involve you doing something like rebooting your PC (which, come to think of it, is also nowhere).

    Anyone who needs it working in Vivaldi: It still works in 1.8.770.25. I didn't test this in later versions (until final), so I'm not sure in which version it broke again.


  • Moderator

    @rseiler said in Office 365 / Exchange Online Error:

    Anyone who needs it working in Vivaldi: It still works in 1.8.770.25. I didn't test this in later versions (until final), so I'm not sure in which version it broke again.

    Thanks, i pinged a developer about this to check when it regressed since 1.8.770.25.



  • @rseiler said in Office 365 / Exchange Online Error:

    @digitrance said in Office 365 / Exchange Online Error:

    Still broken in 1.8.

    That's not the right way to put it: "broken again" is a better way.

    Maybe, but from the perspective of this user, who has only run stable builds, "still broken" is the experienced reality.



  • @Gwen-Dragon I would, but I don't believe this bug is on the Office 365 side. This error doesn't happen in Google Chrome, which uses the same rendering engine as Vivaldi.


  • Moderator

    @digitrance said in Office 365 / Exchange Online Error:

    I would, but I don't believe this bug is on the Office 365 side.

    May be. But i think (decades of years been working on Internet and web development and programming) that it is a mixture of Vivaldi incompatibility problem and a sloppy programmed MS webapp.
    That is like the old days of "Optimized for Internet Explorer" webpages.

    his error doesn't happen in Google Chrome, which uses the same rendering engine as Vivaldi.

    The problem is the running JS and Microsoft's JS libs, not the rendering engine.



  • Have the same problem with Exchange 2013 CU15 on Premise here.

    Don`t really know when this problem began but i had it definitely with Vivaldi 1.6 / 1.7 and 1.8 Stable.

    Client Information
    ------------------
    User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.111 Safari/537.36 Vivaldi/1.8.770.50
    CPU Class: undefined
    Platform: Win32
    System Language: undefined
    User Language: de-DE
    CookieEnabled: true
    -----------------
    Exception Details
    -----------------
    Date: Mon Apr 03 2017 09:11:43 GMT+0200 (Mitteleurop├Ąische Sommerzeit)
    Message: Uncaught Error: Property 'vivaldi-spatnav-clickable' isn't defined on the given object.
    Url: https://.../ecp/15.0.1263.5/scripts/common.js
    Line: 1
    
    Call Stack
    ----------
    Error
        at Function.ErrorHandling.$EM (https://mail.storz-pcb.de/ecp/15.0.1263.5/scripts/common.js:1:172926)
        at ErrorHandling.showUnhandledException (https://.../ecp/15.0.1263.5/scripts/common.js:1:172011)
    
    
    
    
    Dump Event
    ----------
    	isTrusted = true
    	message = Uncaught Error: Property 'vivaldi-spatnav-clickable' isn't defined on the given object.
    	filename = https://.../ecp/15.0.1263.5/scripts/common.js
    	lineno = 1
    	colno = 264272
    	error = Error: Property 'vivaldi-spatnav-clickable' isn't defined on the given object.
    	NONE = 0
    	CAPTURING_PHASE = 1
    	AT_TARGET = 2
    	BUBBLING_PHASE = 3
    	type = error
    	target = [object Window]
    	currentTarget = [object Window]
    	eventPhase = 2
    	bubbles = false
    	cancelable = true
    	defaultPrevented = false
    	composed = false
    	timeStamp = 1830.075
    	srcElement = [object Window]
    	returnValue = true
    	cancelBubble = false
    	path = [object Window]
    	composedPath = function composedPath() { [native code] }
    	stopPropagation = function stopPropagation() { [native code] }
    	stopImmediatePropagation = function stopImmediatePropagation() { [native code] }
    	preventDefault = function preventDefault() { [native code] }
    	initEvent = function initEvent() { [native code] }
    
    Detailed Call Stack
    


  • Still broken in 1.9.818.44



  • Yep, still broken in Vivaldi 1.9. Works just fine in Google Chrome 58.

    0_1493301331928_Vivaldi 1.9.png

    0_1493301342491_Google Chrome 58.png



  • As an update, this still appears to be broken in Vivaldi 1.10.867.38. Still works fine in the latest version of Google Chrome 59.0.3071.86.



  • At last! This issue looks to be fixed in Vivaldi 1.11.917.39 (Stable channel). Kudos to the bug smashers who got it working! This will make my life a lot easier... ­čÖé


Locked
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.