[BUG] After update to 1.5.658.44, Ctrl+` no longer working



  • After updating this morning, [ctrl+`] and [ctrl+shift+`] are no longer working for me. I have programmed these to cycle tabs by recent use. Neither shortcut works.

    I tried to delete the shortcuts and re-add them, and - interestingly - am unable to add them back. When attempting to add them as a keyboard shortcut, the shortcut field doesn't populate or respond.

    Other hotkeys (that I have tried so far) appear to be working just fine. I have confirmed that the keys are working fine (as confirmed by my ability to type the characters here). I have restarted both the browser and the computer. Other thoughts? Anyone else have the same issue?



  • I can confirm.

    Just filed bug report VB-23450



  • Strange, tested on my Win 10x64 with Vivaldi 1.5 Final 32bit;
    I added Ctrl ´ and Ctrl Shift ´ for next and previous Tab. And it workled.
    But may it it works on my german PC keyboard.

    What do you use?

    //EDIT: As i could read in bugtracker and understand such issues, it was was closed because such dead keys are not easy to detect and map and for different languages, keyboards and OS.

    Currently it is a "Won't fix".





  • Den_po added a temporary workaround to this issue in VivaldiHooks, try it
    https://forum.vivaldi.net/topic/11298/vivaldihooks-more-useful-mods



  • Want to know if this issue'll be fixed? Don't know how to make the work-around.
    --Running 1.4.



  • @Gwen-Dragon

    1st of all please accept my apologies for too many post on this issue. My attempted spoof of the absurdity of the situation was, in hind site, poorly thought out. The is the original bug thread so i'm posting here in a last attempt to resolve this misunderstanding.

    Also I don' t know you but I sincerely hope that you don't take anything I say as personal criticism because it's not. You have a thankless job here and I appreciate that there are people willing to do it.

    Ok, let's talk about this bug. First of all there ARE no "dead" keys on the standard US "QWERTY" keyboard. I can and do use them all in the browser environment. Secondly to suggest that it won't be fixed because it's "too hard to map for many languages" is a "Strawman" argument. I only sort of makes sense if instead of reporting a bug I had requested adding a (non-standard) key to the list of keys that the browser must monitor. But that's not at all what happened. Sometime between ver 1.4 and ver 1.5 Vivaldi apparently "lost contact with" character #192 on the standard US keyboard. The Vivaldi software is now broken as it no longer fully covers the keyboard of a major language that it supports.

    I understand that neither you nor the developer use the US keyboard and so it's understandable that there could have been this confusion. But once understood then clearly to say that we don't plan to fix this bug is no different than saying that Vivaldi plans to become the 1st software project in history that accepts keyboard input and the supports American English language but not all of their keyboard characters.



  • @laffin_boy The bug is apparently fixed, so what's your issue? `I was able to assign the Ctrl + grave accent shortcut to Close Window, and it works.

    I also tried assigning Ctrl + Shift + # (~on a UK keyboard), and that works too. Shift + # also works.

    Gwen kindly looked up the bug, and told you what the status was. Why do you want to make an argument about this?



  • @Pesala said "The bug is apparently fixed, so what's your issue?"

    sigh...

    (1) Last night I "upgraded" from 1.4.xxx to 1.5.658.56. I tried my "close tab" shortcut: ctrl + (accent) and it still didn't work. Then I installed danpo's excellent Vivaldihacks package and then my custom shortcut worked. "Fixed" with 2 lines of javascript. Just now I disabled this "hack" and the shortcut stopped working. The bug has NOT been fixed in the current stable ver. (Note that while the Ctrl + ` key combo will not work past ver 1.4.xxx on US keyboards I can still type both the accent mark and the tilde character so Vivaldi still "sees" this key.)

    (2) And since the developer evidently marked the bug report as "won't fix" why would you think that it would be fixed? This won't get fixed until the moderators stop "stonewalling" this report and point out to a developer that it's an actual issue that should be fixed.

    (3) I understand that those of you who don't have access to a US keyboard on a US language computer may have problems reproducing this bug in 5 min. Sorry but I don't know enough about keyboard / computer interfaces to tell you how to do it. But I assure you it is an actual bug - it used to work and now it doesn't.

    @Pesala said: "Gwen kindly looked up the bug, and told you what the status was".

    Yes he did. And what he told me - and what you repeated - was not factual. There ARE no "dead keys" on US keyboards. The accent / tilde key on US keyboards are no more dispensable or less important than the a/A key. (if Gwen had actually read the Wikipedia page on dead keys that he linked to (in another post) he would have known that) The most generous conclusion I can come to here is that the developer didn't give this issue much thought and that, unfortunately, those of you who are relaying his / her conclusion are not giving that decision much thought before passing it on. And are now in a position that's not in Vivaldi's interest.

    @Pesala said: "Why do you want to make an argument about this?"

    Considering the tone of my post that you're referring to I find that a strange and offputting question but i'll answer it anyway. Many Vivaldi users with US keyboards users who routinely use the accent / tilde key have taken the "easy route" and just installed VavaldiHacks and thereby circumvented the Bug That's Not Going To Get Fixed problem plus they've improved their Vivaldi GUI. But my geek nature gets upset when there's an obvious problem in front of us and "the experts" are pretending that the "Emperor" is wearing very fancy clothes.

    Also I understand (now) that I didn't win any points here with my "spoof" post but i've appoliged for that which is all I can do now. But you and I have a history. We both used Opera for many years and your wise posts on the Opera forum helped me many times so i've always had lots of respect for you personally. But you're wrong here and you're defending the wrong side.



  • @laffin_boy said in [BUG] After update to 1.5.658.44, Ctrl+` no longer working:

    Last night I "upgraded" from 1.4.xxx to 1.5.658.56.

    That is not the latest version.


    Specs: AMD A10-6800K, 8 Gb on Win 7 64-bit • Snapshot 1.6.689.32



  • @Pesala

    I responded to your post in great detail - all of which you ignored. Your only answer was to imply that i'm not bright enough to find the current newest version. The most recent STABLE ver -as you well know - is 1.5.658.56 which is what I just installed and the previous stable version was the one I filed a bug report on. I prefer not to use "snapshots" and I have no reason to believe that they are any more likely to be free of this particular bug.

    In the context of this conversation your one line reply was dishonest and i'm baffled by your hostility.



  • @laffin_boy said in [BUG] After update to 1.5.658.44, Ctrl+` no longer working:

    all of which you ignored

    If you're not using the latest version, then the rest of your post is irrelevant. Try the latest build, or wait a day or two for the 1.6 Stable build, then test it again and see if your result is any different to mine, then it might be worth investigating.



  • @Pesala
    it's really not fixed even in latest SS, I can confirm. And the official explanation of "won't fix, dead key" really makes no sense, as the "fix" is really 2 lines of codes as it can be seen in den_po's VivaldiHooks, the definition of keyvalue 192 is simply missing/removed since 1.5 branch.

    vivaldi.jdhooks.hookModule('_getPrintableKeyName', function(moduleInfo) {
    moduleInfo.exports[192] = '`';
    });

    I'm using italian qwerty kbd but in Windows it's really not a problem setting multiple kbds, in control panel I just enable English (UK) and English (US) kbds and enabled the switch on the traybar so I can have 3 different switchable kdb settings.
    Setting EN/US kbd the `/~ key reacts on the address bar, but not in Vivaldi settings/keyboard key assignments. Unless the VivaldiHooks fix-graveaccent-hotkey.js is activated.
    Setting EN/UK kdb the key is `/¬ but strangely enough it even reacts in keyboard assignments, even without the fix active. Btw # is on the total opposite (right) side of the kbd, it's not about which symbol it's needed a key to print, it's a matter of keyboard scan codes ;)



  • @laffin_boy Gwen is not a guy. Hmmpf. :girl:

    @iAN-CooG as a external tester I can't give reason, why the devs didn't add the patch of Den_po yet.

    If you want, you can file a bug report about this Ctrl ~ issue, which will notify the devs that there is a need for a fix.



  • @Gwen-Dragon of course, nobody is criticising you for anything :)
    In any case, as long as there's VivaldiHooks with all its workarounds to the issues and Vivaldi behavior changing, I can wait with no problems whatsoever until everything gets implemented natively. I invite also others doing so.
    Keep calm and use VivaldiHooks.



  • @Gwen-Dragon said in [BUG] After update to 1.5.658.44, Ctrl+` no longer working:

    If you want, you can file a bug report about this Ctrl ~ issue, which will notify the devs that there is a need for a fix.

    I would suggest that a bug for this is raised.
    You could refer to previous bug (won't fix) and add a note that a workaround has been provided in VivaldiHooks so ask if it should be looked at again.



  • @Gwen-Dragon said "Gwen is not a guy. Hmmpf."

    Whoops, sorry ma'am :flushed:



  • @Gwen-Dragon said in [BUG] After update to 1.5.658.44, Ctrl+` no longer working:

    @iAN-CooG as a external tester I can't give reason, why the devs didn't add the patch of Den_po yet.

    ` on US/RU keyboard has the same keycode as ö on DE. Physically these are different keys.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.