Videos not playing + browser needs manual restart a lot



  • @Aronand Just adding my machine to the list to see if it helps the issue get bumped up the list, same problem as everyone else...

    MacPro (Late 2013)
    Processor 3.5ghz 6-core xeon e5
    Ram 16gb 1866Mgz DDR3
    Graphics FirePro d500

    Thanks!



  • Hi,

    Just want to share my experience with this problem.

    20% of the time I get this error on youtube videos :
    0_1483813531857_Capture d’écran 2017-01-07 à 19.24.21.png

    In the advanced statistics of the previous video I get :
    0_1483813596213_Capture d’écran 2017-01-07 à 19.24.04.png
    As you can see the mime type is "mp4"

    If I display the statistics for a working html5 video :
    0_1483813809710_Capture d’écran 2017-01-07 à 19.16.56.png
    The mime type is webm with codec vp9

    One day, after a lot of refresh (including refresh without cache), I tried to change the resolution of the video (720p by default) to 144p. After refreshing the page, the video started (in flash, not html5), this process always work, so I can use Vivaldi as my default browser for youtube, but it's annoying.

    For Twitch I use the flash player, because the html one does not work at all.
    It's impossible to watch twitter, dalymotion... videos

    I do not have this problems on safari and chrome.

    I tried to disable / enable "Override software rendering list" in vivaldi:flags and start vivaldi with the "open /Applications/Vivaldi.app --args --ignore-gpu-blacklist" command, but the problem is still here.

    Here is what I have in vivaldi:gpu :
    0_1483814457957_Capture d’écran 2017-01-07 à 19.12.08.png

    Config :

    iMac 21,5" end 2012
    MacOs Sierra 10.12.0
    Vivaldi 1.7.705.3 64bits (same problem on stable branch)



  • I have a similar problem with videos in Vivaldi.
    Certain videos in YouTube fail to load with the HTML5 player, and instead displays this message:


    Usually, YouTube changes to the flash player on it's own, but it can be slow sometimes.
    It usually affects some recently uploaded videos, but also some older ones, such as this one:
    https://www.youtube.com/watch?v=ZBpOYnP72RU&ab_channel=SciShow

    All videos on Twitter, including gifs, are always unable to load
    This is the message that appears

    My Config:
    MacBook Pro (13-inch, Early 2011)
    Processor: 2.7 GHz Intel Core i7
    Memory: 8 GB 1333 MHz DDR3
    Graphics: Intel HD Graphics 3000 512 MB
    OS: macOS 10.12.2 (16C67)
    Running on Vivaldi 1.7.715.3 (Official Build) (64-bit)



  • Bug still present in 1.7.721.3.



  • Hi again

    @PEPIT0
    Thanks for the tip about the codec, i have the same issues on Youtube and i confirm that webM videos are allright but not mp4.

    @AltCode
    Same here about Twitter, i can't play any media : video, gif ..

    can a Vivaldi dev confirm all theses issues please ?



  • Oddly enough, I can play some mp4 videos, but it's rare, and the instant anyone tries anything other than a straight embed (some sort of streaming, or any sort of changes to the playback mechanism) it fails.

    I can also get Twitter GIFs, but not other videos.



  • Thanks for the tip about the codec, i have the same issues on Youtube and i confirm that webM videos are allright but not mp4.

    What I do when I encounter this problem is :
    Change the resolution of the video to 144p (sometimes it works only with 240, 360...) then refresh the page.
    The mp4 video starts in flash. Then, you just have to change back the resolution to 720/1080p in the flash player.
    This trick works on 100% of the videos.
    But again as said, can't do anything for twitter, steam...

    can a Vivaldi dev confirm all theses issues please ?

    In the previous page they said that they were aware of the problem, trying to fix it, so just wait...



  • @silv_
    Thanks silv_ ! It worked for me.



  • I am also experiencing problems with videos playback and my macbook is not that old (MacBook Pro Retina, 13-inch, Early 2015). Running on Mac OS Sierra 10.12.3, latest version of Vivaldi, which I also tried to reinstall.

    I have blocked third party cookies and using several extensions including:

    • One Tab
    • Frame by Frame for YouTube
    • Magic Actions for YouTube
    • LastPass
    • Reopen closed tab Button
    • Pocket
    • uBlock Origin
    • Youtube Playback Speed Control

    On top of this, I am losing all open tabs (incl. pinned tabs) when the computer restarts. I've highlighted the issue here: https://forum.vivaldi.net/topic/12568/all-tabs-lost-after-computer-restart



  • Hi

    I updated Vivaldi to 1.7.735.46 (Stable channel) (64 bits) but issues are still here.



  • @Aronand Are you able to provide an update on this issue? Is there a fix in the works still since it was in dev back in version 1.5? This affects the entire Mac Pro line it appears, so I hope it is still moving through dev. Thanks!


  • Vivaldi Team

    @chainlightning Hey, yeah I can give a quick update, no fix in the pipeline yet, as we are currently working on other, bigger media issues, and because of that I can't really provide any sort of time estimate either.



  • @Aronand Any update is better than no update, I appreciate the reply. Thank you!



  • Hi,
    Thanks for the quick update @Aronand.

    I managed to fix the youtube issue doing this :

    I've found this chrome extension HERE. It disables the webm, vp8 and vp9 mime types. So I installed it, and as expected no youtube videos were working anymore.

    So I changed the extension code you can find the repo here.
    I simply changed the variable (in the inject.js)
    var disallowed_types = ['webm', 'vp8', 'vp9'];
    into
    var disallowed_types = ['mp4'];

    Then installed the modified version.

    And now all youtube videos are working !!

    Before, the mime type of none working videos were 'mp4', now I get 'vp8', which is working.
    0_1489529420494_Capture d’écran 2017-03-14 à 23.04.03.png

    As I don't know if I can put my modified extension in the chrome store (legally), I can make a tutorial...

    edit : spell check (not my main language :smile: )



  • @PEPIT0

    I am having the same problems others have noted. I'm on a Mac Pro with Yosemite 10.10.5, Vivaldi 1.7.735.46 and Flash 25.0.0.127.

    I'm not sure where Github comes into the picture here. Once you install the Extension can't you just navigate to

    /Users/<yourname>/Library/Application Support/Vivaldi/Default/Extensions/<Extension name>/1.0.4_0/src/inject

    and modify inject.js in there? No need to reference Github ...

    I am really curious to know how you discovered this Extension and knew to modify this inject.js file! Great work :-)



  • @RiotNrrrd So the good news is, YouTube videos that did not play before are playing now. Great.

    The bad news is, Twitter videos are still giving me "The media could not be played" errors. Here's an example:

    https://twitter.com/KimDotcom/status/843334733509492736

    If I do an Inspect on the media window, I see something interesting:

    Uncaught SecurityError: Failed to read the 'localStorage' property from 'Window': Access is denied for this document. chrome-extension://aleakchihdccplidncghkekgioiakgal/src/inject/content_script.js:30

    That Chrome extension is the one I installed from @PEPIT0 's post above.

    If anyone cares here is the full player from the Inspect:

    <div
    id="playerContainer"
    class="player-container full-screen-enabled video-played"
    data-config="{"is_360":false,"duration":38133,"scribe_widget_origin":true,"heartbeatEnabled":true,"video_url":"https:\/\/video.twimg.com\/ext_tw_video\/843334307372396544\/pu\/pl\/VNqupDBEqXXhab2d.m3u8","disable_embed":"0","videoInfo":{"title":null,"description":null,"publisher":{"screen_name":"KimDotcom","name":"Kim Dotcom","profile_image_url":"https:\/\/pbs.twimg.com\/profile_images\/2320423543\/9qheijpvtu9g5dteqvvw_normal.jpeg"}},"cardUrl":"https:\/\/t.co\/uek9tSWoTR","content_type":"application\/x-mpegURL","owner_id":"611986351","looping_enabled":true,"show_cookie_override_en":true,"visit_cta_url":null,"scribe_playlist_url":"https:\/\/twitter.com\/KimDotcom\/status\/843334733509492736\/video\/1","source_type":"consumer","image_src":"https:\/\/pbs.twimg.com\/ext_tw_video_thumb\/843334307372396544\/pu\/img\/30MXlErBtBFJzWcN.jpg","heartbeatIntervalInMs":5000.0,"use_tfw_live_heartbeat_event_category":true,"video_loading_timeout":45000.0,"status":{"created_at":"Sun Mar 19 05:34:03 +0000 2017","id":843334733509492736,"id_str":"843334733509492736","text":"A tiny tour of the Penthouse \ud83d\ude0e https:\/\/t.co\/uek9tSWoTR","truncated":false,"entities":{"hashtags":[],"symbols":[],"user_mentions":[],"urls":[],"media":[{"id":843334307372396544,"id_str":"843334307372396544","indices":[31,54],"media_url":"http:\/\/pbs.twimg.com\/ext_tw_video_thumb\/843334307372396544\/pu\/img\/30MXlErBtBFJzWcN.jpg","media_url_https":"https:\/\/pbs.twimg.com\/ext_tw_video_thumb\/843334307372396544\/pu\/img\/30MXlErBtBFJzWcN.jpg","url":"https:\/\/t.co\/uek9tSWoTR","display_url":"pic.twitter.com\/uek9tSWoTR","expanded_url":"https:\/\/twitter.com\/KimDotcom\/status\/843334733509492736\/video\/1","type":"photo","sizes":{"small":{"w":340,"h":425,"resize":"fit"},"thumb":{"w":150,"h":150,"resize":"crop"},"medium":{"w":600,"h":750,"resize":"fit"},"large":{"w":720,"h":900,"resize":"fit"}}}]},"source":"\u003ca href=\"http:\/\/twitter.com\/download\/iphone\" rel=\"nofollow\"\u003eTwitter for iPhone\u003c\/a\u003e","in_reply_to_status_id":null,"in_reply_to_status_id_str":null,"in_reply_to_user_id":null,"in_reply_to_user_id_str":null,"in_reply_to_screen_name":null,"geo":null,"coordinates":null,"place":null,"contributors":null,"retweet_count":0,"favorite_count":0,"favorited":false,"retweeted":false,"possibly_sensitive":false,"lang":"en"},"show_cookie_override_all":true,"video_session_enabled":false,"media_id":"843334307372396544","view_counts":null,"statusTimestamp":{"local":"5:34 AM - 19 Mar 2017"},"media_type":1,"user":{"screen_name":"KimDotcom","name":"Kim Dotcom","profile_image_url":"https:\/\/pbs.twimg.com\/profile_images\/2320423543\/9qheijpvtu9g5dteqvvw_bigger.jpeg"},"watch_now_cta_url":null,"tweet_id":"843334733509492736"}"
    data-source-type="consumer"> = $0
    


  • @RiotNrrrd said in Videos not playing + browser needs manual restart a lot:

    @PEPIT0

    I'm not sure where Github comes into the picture here. Once you install the Extension can't you just navigate to

    /Users/<yourname>/Library/Application Support/Vivaldi/Default/Extensions/<Extension name>/1.0.4_0/src/inject

    and modify inject.js in there? No need to reference Github ...

    I will have to test... But it might worok and it's even simpler this way :)

    The reason I talked about the Github is that I wanted to fork the extension (clone it and distribute it with the modification). I will probably do it this week end (if I don't have too much work ^^).

    I am really curious to know how you discovered this Extension and knew to modify this inject.js file! Great work :-)

    I tried a lot of thing regarding the mime type of the videos, so I ended up to this extension.
    As it was programmed to block the vp9 mime type, I searched in the code where the variable vp9 was and changed it.

    I'm currently searching a workaround for the twitter videos too (but I have so much work right now...)

    And thanks for the inspect :)

    Edit :

    The bad news is, Twitter videos are still giving me "The media could not be played" errors. Here's an example

    The extension only apply to the youtube website. I will try to apply it for twitter too and test...

    In the manifest.json :

         "matches": [
              "*://*.youtube.com/*"
      ],


  • @PEPIT0 said in Videos not playing + browser needs manual restart a lot:

    @RiotNrrrd said in Videos not playing + browser needs manual restart a lot:

    The bad news is, Twitter videos are still giving me "The media could not be played" errors. Here's an example

    The extension only applies to the YouTube website. I will try to apply it for Twitter too and test...

    In the manifest.json :

         "matches": [
              "*://*.youtube.com/*"
      ],
    

    Ah, I see said the Blind Man!

    But I am not json-savvy. Can you add more than one URL to that matches clause, or have multiple matches clauses?



  • @RiotNrrrd @PEPIT0 @Aronand I went ahead and made my first extension, it's up on the Chrome Store and can be found here until the issue can be resolved on the Vivaldi end.

    • It applies to all web traffic
    • As RiotNrrrd noted, it doesn't necessarily fix everything as some sites offer just mp4 and nothing else, so errors can persist in some cases
    • It was a fork of the h264ify project, but then I just broke it off and reused the MIT code for this. It wasn't a good idea to pull into the h264ify project teams due to applying to all traffic as opposed to just youtube

    Give it a shot, I wrote it a weekend or two ago, but didn't have a Chrome Dev account till now. The link to the extension is here



  • @RiotNrrrd Please, don't poste such raw code into an answer.
    !!! Use a code block. See http://commonmark.org/help/ !!!


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.