cannot disable hotkeys in vivaldi



  • I've tried to remove the hotkeys from my browser, but everytime I tested the hotkeys, they still work? I've removed all the hotkeys disabled them, reenabled them, I'm honestly about to lose my mind because I use the ESC key a lot, and it exits the browser, I use my mouse a lot, which apparently reverts you to the last page you were on? Which is extremely annoying, and I cannot remove it, and I have my own hotkey system for my keyboard which the browser seems to be conflicting with. I've also looked on the settings menu on vivaldi and I tried to make sure if I missed anything that says "Save Settings" or anything of that sort.
    Please help fast.



  • @valook There is an "enable/disable" flag under Tools/Settings/Keyboard.

    (allow "all keyboard shortcuts" and "single key shortcuts").

    Note: ESC does not exit the browser for me whether flag is enabled or not !?



  • @TbGbe What flag? And I cannot enable both options, and the ESC minimised the page not close it, sorry.



  • @TbGbe I use mac, so I believe browser settings are different.



  • @valook
    I'm on osx too, checking "disable all keyboard shortcuts" in settings works for me. No Vivaldi hotkey will work after taking this step.

    You can disable mouse gesture too, make sure "allow gestures" is unchecked in settings/mouse.

    One thing to note is that esc will still exit fullscreens when all keyboard shortcuts are disabled.



  • @luetage I've done what you did over 10 times before, but it does nothing..



  • @luetage said in cannot disable hotkeys in vivaldi:

    @valook
    I'm on osx too, checking "disable all keyboard shortcuts" in settings works for me. No Vivaldi hotkey will work after taking this step.

    You can disable mouse gesture too, make sure "allow gestures" is unchecked in settings/mouse.

    I had enabled the one key shorts to get a / for search in page going one thing I discovered is this program cannot distinguish between typing in text box like I am now and a shortcut. So when you type one of the default single keys or one you set you get both actions the shortcut is executed and the key is typed. Which leads me to this if you have the normal shortcuts enabled the you want to go into its settings and remove the Backspace key for back in browser as if you make typo and hit backspace well then you get character removed and get to go back in the browser as well. I'm on 10.11.6 and disable works fine.



  • @MacUser2525 How can I downgrade then? Because I really need to fix this, asap



  • @valook said in cannot disable hotkeys in vivaldi:

    @MacUser2525 How can I downgrade then? Because I really need to fix this, asap

    No clue really have not used this long enough to have ever done an upgrade/downgrade of the program. Should have mentioned I'm on the 1.4 they have released.



  • @MacUser2525 I've cleared the cookies of the browser in hopes of fixing the problem.. yet still the same issue



  • @valook said in cannot disable hotkeys in vivaldi:

    @MacUser2525 I've cleared the cookies of the browser in hopes of fixing the problem.. yet still the same issue

    Cookies should have nothing to do with this, what version are you using?



  • @MacUser2525 The latest version there is.



  • @MacUser2525 I realised that there's version 1.5, I thought 1.4 was the latest, my apologies.



  • @valook said in cannot disable hotkeys in vivaldi:

    @MacUser2525 I realised that there's version 1.5, I thought 1.4 was the latest, my apologies.

    Well could be worth dropping back as I think that 1.5 is snapshot release as all that was offered to me little more than week ago was 1.4 stable release to download.



  • What version of osx are you guys on?



  • @valook said in cannot disable hotkeys in vivaldi:

    @TbGbe What flag? And I cannot enable both options, and the ESC minimised the page not close it, sorry.
    @TbGbe I use mac, so I believe browser settings are different.

    Should have mentioned I'm on the 1.4 they have released.

    Ok. Because you said "latest version available" I assumed you were on a V1.5 snapshot.
    But the flags are there in V1.4 as well (on Windows and on Linux).

    As you are on MAC and there is a problem with Snapshots on MAC at the moment, I'll have to leave this to MAC users; sorry.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.