Alt key opens menu.



  • Hello everyone! When switching between typing languages with Alt+Shift, it opens Vivaldi menu like i'm pressing on the red V square, in the upper left corner. I don't see any issue with this browser and i'm pleased using it, but just that puts me into trouble - auto open menu with the Alt button.



  • i cannot replicate your issue. which operating system are you on? in linuxmint kde 18: system-settings>hardware>input devices>keyboard>layout>shortcuts. i remember seeing the same option in cinnamon as well.



  • @telliev said in Alt key opens menu.:

    auto open menu with the Alt button.

    You will have a better chance of having a good reply if you explain wich version of Vivaldi you have, OS, and being an issue with key probably also your desktop manager.

    I do have the same issue, if I understand you correctly.

    Pressing the ALT key opens the Vivaldi menu. I have "single key shortcuts" disabled. Anyway ALT should only be a modifier key, not a shortcut by itself, I presume.

    Vivaldi 1.5.658.3, openSuse 13.1, XFCE desktop manager (4.10?)



  • @rkzn That's what i was talking about. ALT key should not open the Vivaldi menu. The people most frequently are using ALT+Shift to switch between languages, but every time i switch the language, Vivaldi menu opens. I'm using Debian with Gnome and latest version of Vivaldi.



  • Hi,
    I've got the same issue. I'm using i3wm on Ubuntu 16.04. The issue happens only when I have "MENU: Vivaldi button" turned on (with the other setting - it's all OKay and menu is not appearing).
    By default i3wm uses ALT key as a modifier for all its hotkeys, so I'm using it heavily to switch between windows and for most of the shortcuts in the system.

    Please fix this behavior.
    Thanks!

    Additional info:

    • Vivaldi 1.4.589.41 (Stable channel) (64-bit)

    • Revision afa9b018e32575fcd8f8283755a315804ecf0671

    • OS Linux

    • Blink 537.36 (@afa9b018e32575fcd8f8283755a315804ecf0671)

    • JavaScript V8 5.3.332.47

    • Flash (Disabled)

    • User Agent Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.148 Safari/537.36 Vivaldi/1.4.589.41

    • Command Line /usr/bin/vivaldi --always-authorize-plugins --disable-translate --window-depth=24 --x11-visual-id=33 --wm-user-time-ms=23793 --flag-switches-begin --flag-switches-end



  • One way to workaround the problem is to set the menu to use "Horizontal menu" instead of "Vivaldi button". I agree though that "alt" is a bad choice.



  • Yes, please make this configurable, and mappable to a regular key instead of a modifier. I would prefer / or F10 as a default (these have been used in other applications for this purpose)
    Although, to be honest, the original Opera also does this...



  • Another from me for making this customizable. I use the ALT key for mappings as well so having it opening the menu in Vivaldi is just annoying.



  • So glad I'm not the only one who finds this annoying. I use Alt+X as a modifier for Guake. Each time I open/close Guake with Vivaldi underneath, the V menu pops open.
    Extremely frustrating.


  • Vivaldi Translator

    Configure able probably make sense.
    But, Alt+(something) almost universal on window GUI. Such as Alt+f to open menu File, Alt+e to open menu Edit, and so on.

    Just a suggestion:
    On Linux DE/WM, I usually stay away from excessive use of Alt, Ctrl and Shift key. Reconfigure them to use Win or Caps Lock keys all the way. So I don't interfere any GUI shortcut keys.



  • @dLeon That's impossible for me. I'm using Linux on a Dell Chromebook 13 and there's no Caps Lock key, nor a Windows key. Instead, the Search key (which is located where the Caps Lock key would usually be located) acts as Super (just like the Windows key would). But Vivaldi thinks the Super key is the reload key (despite the reload key also working as intended!) so I can't use any Super + key shortcut when Vivaldi is focused, which I why I've switched a few important shortcuts over to the Alt key.


  • Vivaldi Translator

    @Motionshot
    I see. So Vivaldi wrongly detect keyboard set on Chromebook.
    That's far too internal for me.

    Let one of the moderators here give green light for you to report bug directly. I don't have right to advice you to do so.



  • +1 for enabling turning of the alt key.



  • +1 from me as well

    I am using Fedora 25 and use the alt+shift combination to change keyboard layouts for other languages. I use gnome 3 and i had this problem with firefox as well, but there was the ability to disable it, deep in the about:config section. More here

    In Chrome there was no such problem. Alt button ignites nothing it seems. In vivaldi i resorted in enabling the horizontal menu to overcome this, which i honestly dont like, since it takes space from the screen.

    I think the alt menu should be configurable somehow.



  • 11.02.2017 and Vivaldi still opens Menu by pressing the Alt key! >:(



  • The problem appears to be tied to keyboard detection and not strictly the alt key.

    Vivaldi 1.10.845.3 (Official Build) (64-bit)
    Revision df584d06dcb8232b5f0f8862a1f92af5549a085c
    OS Windows 10 Pro x64
    JavaScript V8 5.8.283.38
    Flash 25.0.0.171

    Other possibly pertinent information:
    Dell Latitude E5470
    Logitech K330 wireless keyboard, unifying receiver
    Greenshot 1.2.9

    For me, it's the Print Screen button that also sometimes opens the Vivaldi menu. It's reproduce-able but not every time. Sometimes, after closing the menu, I can then press the Print Screen button without the Vivaldi menu opening again. I can get the problem to happen again by switching to a few different applications then coming back and switching between a few tabs in Vivaldi. Just switching to one other application and back or just switching to one other tab does not seem to cause the problem to happen again, it needs the multiple switches. This has been happening since at least version 1.8 for me but it's a rather minor issue and I had hoped it would just go away on its own but that doesn't look to be the case. If needed, I can produce a gif of the issue and of the reproduction after making it go away temporarily.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.