Netflix only works when Chrome is installed



  • Never tried this on Windows 10 since I use the Netflix app from the Windows Store. However, I noticed that I got Netflix to work on Vivaldi only because Chrome was installed. When I uninstall it, it's gone. How do I uninstall Chrome and keep the Widevine and other plugins that are required to run Netflix?



  • Unless your'e using an older/buggy version vivaldi should download the required components by itself.

    If not just go here

    vivaldi://components

    And push the nice videwinwe button



  • "Netflix only works when Chrome is installed" ... well, this news certainly comes as a great shock to me. I wonder how it is then that every night i watch hours of Netflix on my Lappy in V, & sometimes during days i do ditto on my Tower, with no Chrome installed on either? I guess i must be only dreaming it... or maybe you're wrong...
    ...........................................................................................................................................................................
    Tower's SSD OS = Linux Mint x64 17.3 KDE 4.14.2. [< 26/9/16]; Maui 2 "Blue Tang" x64 Plasma 5.8.2.
    Lappy's SSD OS = Linux Mint x64 17.3 KDE 4.14.2. [< 18/9/16]; Mint 18 “Sarah” x64 Xfce+Compiz.


  • Moderator

    @Steffie said in Netflix only works when Chrome is installed:

    "Netflix only works when Chrome is installed" ... well, this news certainly comes as a great shock to me. I wonder how it is then that every night i watch hours of Netflix on my Lappy in V, & sometimes during days i do ditto on my Tower, with no Chrome installed on either? I guess i must be only dreaming it... or maybe you're wrong...
    ...........................................................................................................................................................................
    Tower's SSD OS = Linux Mint x64 17.3 KDE 4.14.2. [< 26/9/16]; Maui 2 "Blue Tang" x64 Plasma 5.8.2.
    Lappy's SSD OS = Linux Mint x64 17.3 KDE 4.14.2. [< 18/9/16]; Mint 18 “Sarah” x64 Xfce+Compiz.

    Be nice. On a fresh clean install, the WideVine plugin is not downloaded immediately. It arrives for Vivaldi when it "updates" (which in my experience can take five minutes to a day). If it doesn't update fast enough, then going to it in vivaldi://components and clicking on it can cause it to "update" (ie, download). I think this could actually be a licensing thing, whereby Vivaldi is actually not allowed to package it.



  • @The_Solutor

    I've seen others [& maybe also you] in past months & year mention this [re Components], but it's always puzzled me. In my V-SS i have never had Widevine show up in Components, only Plugins... yet NF works just fine for me. Any ideas how this might be pls, & if i should somehow rectify?
    0_1478482973870_V Plugins vs Components_20161107_123708.png


  • Moderator

    @Steffie - Good question. It sure shows up here. I don't know how your install managed to hide it. Mebbe a Linux thing. But I don't think so.



  • @Ayespy

    I imagine it's just another manifestation of my special ability... to stuff things up!



  • @Steffie said in Netflix only works when Chrome is installed:

    @Ayespy

    I imagine it's just another manifestation of my special ability... to stuff things up!

    Nope - I don't see Widevine on either page (not on components, not on plugins) on my Vivaldi Snapshot - Linux Mint.

    Don't use Netflix so I'm more curious than concerned.



  • @Ayespy said in Netflix only works when Chrome is installed:

    @Steffie said in Netflix only works when Chrome is installed:

    "Netflix only works when Chrome is installed" ... well, this news certainly comes as a great shock to me. I wonder how it is then that every night i watch hours of Netflix on my Lappy in V, & sometimes during days i do ditto on my Tower, with no Chrome installed on either? I guess i must be only dreaming it... or maybe you're wrong...
    ...........................................................................................................................................................................
    Tower's SSD OS = Linux Mint x64 17.3 KDE 4.14.2. [< 26/9/16]; Maui 2 "Blue Tang" x64 Plasma 5.8.2.
    Lappy's SSD OS = Linux Mint x64 17.3 KDE 4.14.2. [< 18/9/16]; Mint 18 “Sarah” x64 Xfce+Compiz.

    Be nice. On a fresh clean install, the WideVine plugin is not downloaded immediately. It arrives for Vivaldi when it "updates" (which in my experience can take five minutes to a day). If it doesn't update fast enough, then going to it in vivaldi://components and clicking on it can cause it to "update" (ie, download). I think this could actually be a licensing thing, whereby Vivaldi is actually not allowed to package it.

    It's a fair cop. YamiYukiSenpai, i unreservedly apologise. Note to self -- work harder to keep my inner bitch suppressed.


Log in to reply
 

Looks like your connection to Vivaldi Forum was lost, please wait while we try to reconnect.